(Topic ID: 134360)

Bally Boomerang indefinitely resetting FIXED


By futurepinhead

4 years ago



Topic Stats

  • 17 posts
  • 4 Pinsiders participating
  • Latest reply 4 years ago by futurepinhead
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

20150801_184906.jpg
20150801_184735.jpg
20150801_225400.jpg

You're currently viewing posts by Pinsider futurepinhead.
Click here to go back to viewing the entire thread.

#1 4 years ago

I am trying to help a friend with his Boomerang. It is constantly trying to reset and never stops. I have received several tips but I wanted to put a feeler out here too. Someone said the zero switches aren't reading in the backbox but I advanced the score reals by activating the coil by hand and they all stop at zero while resetting so I do not think that is it. The score motor in the cab is arcing quite a bit and someone told me to take that out, clean it and tighten all the screws. I can do that but I assume since it is arcing, it is getting a connection and shouldn't be the issue. I got it to start a game once and not any other time.

I have posted this on a group on Facebook as well incase this sounds familiar and you are a member of that group.

#5 4 years ago
Quoted from rolf_martin_062:

in Your collection I see a "Surf Champ" and "4 Roses". I guess You are familiar with EM-Pinballs.

Sadly, no. These are sitting in my workshop awaiting me to be smart enough to repair them. This guy dropped this game off and begged me to fix it so it is giving me the courage I need to try and repair this. I actually rebuilt a stepper this weekend which is awesome.

The game goes into reset after I hit the start button. So if I hit the start button, the score rotates back to all zeros and then the never ending reset starts.

I'm going to pick up 2 arcade games tonight but I'll look at it some more Wed. I'll start with that big motor in the bottom, if you think of anything else, please let me know.

#9 4 years ago

Sorry guys, I haven't worked on this since my last post. I picked up an Asteroids and Galaga arcade super cheap so I was getting an inventory of parts needed for Asteroids and I got Galaga working. I hope to spare a couple of hours on it this weekend.

#10 4 years ago

Played my first game on her tonight!

I took off the backbox and pulled out each of the score reels. There were two or three that seemed they just stayed closed no matter what number was displayed. The fuse holders are shit. The playfield lights don't work and I only got to play one game now I can't get it to turn on at all so I suspect the fuse holders. I'll rebuild those this weekend and share results. Thanks guys.

#12 4 years ago

I did tighten those screws first, that didn't fix it but one was very loose so that'll help in the future. I replaced the fuse holders and it fired right up. All lights work now and it resets with no problems. I still need to replace that burnt coil on the bonus stepper and this game 'should' be golden. I can play it right now but once it hits one of the bonus targets that coil gets locked on. The left flipper is quite loud and I would love to know how to fix that

#13 4 years ago

20150801_225400.jpg

20150801_184735.jpg

20150801_184906.jpg

#15 4 years ago

The burnt coil still works but the plastic sleeve inside it has melted so bad that it has closed the hole completely. When it tries to fire, there is an end of stroke switch that deactivates that coil. Since the plunger can not go through the hole, the coil stays active and starts to smoke. It only gets turned on when a bonus 1000 switch is hit. There are 8 rollovers and 2 inlane switches that cause this bonus coil to get activated. Any other 1000 point switch and the game still runs fine, just the bonuses. I have a new coil ordered and every test I have done makes me think this coil installed will have this have running 100% but we will see.

#17 4 years ago

This game is now fixed as far as I can tell. I installed a new coil in the stepper and now the EOS is being opened correctly and its not getting locked on. I played a whole game, not one coil was hot afterwards. I will play a 4 player game as soon as I get all the bulbs in. The backbox is missing quite a few so I want to make sure they are all lighting up correctly.

Thanks again for all your help in my first official EM repair.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 21.00
€ 3.95
Flipper Parts
Multigame
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 400.00
Boards
Great American Pinball
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods
$ 149.00
$ 7.00
Playfield - Toys/Add-ons
Pinball Z
From: $ 5,999.00
Pinball Machine
Monster Bash Remake Out of stock
Flip N Out Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 64.00
Lighting - Under Cabinet
Lermods
$ 249.99
Cabinet - Armor And Blades
Id Rather Play Pinball
From: $ 40.00
Gameroom - Decorations
Gameroom Mods
$ 29.50
Playfield - Toys/Add-ons
The MOD Couple
$ 20.00
Playfield - Toys/Add-ons
3D MODS
$ 34.00
Playfield - Toys/Add-ons
The MOD Couple
From: $ 14.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 9.99
$ 194.99
Lighting - Led
PinballBulbs
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 175.00
Lighting - Interactive
Professor Pinball

You're currently viewing posts by Pinsider futurepinhead.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside