(Topic ID: 249062)

Bally Black Jack MPU bootloop


By 76brian

14 days ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 7 days ago by CanadianPinball
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    #1 14 days ago

    Hi all, I'm having an issue I hope the vast knowledge here on pinside can help with. I'm no stranger to electronics and soldering, but very new to working on a pinball machine.

    I bought this Black Jack recently and it was working and playing great, but it had some minor lighting problems. I pulled the lamp driver to check which SCR's were bad, and while I had it out I reflowed the joints on the header pins with fresh solder. Then I figured while I'm at it, I'll do the same to the MPU, as well as add a ground jumper to J4.

    When I was done I slapped it all back in the machine and booted it up. I get the initial LED flicker followed by 7 flashes, but the score displays were flashing 222222 instead of the high score, and a bunch of lights on the playfield were stuck on, although some others looked like they were cycling for attract mode normally. The chimes sounded as normal, and I was able to coin it up and launch a ball. Everything seemed to work except the displays and lights... the pop bumpers, flippers, chimes, etc all did what I expect them to... but then it would seemingly reboot.

    Each time it reboots I get the 7 LED flashes and I hear the little relay click. I usually get a 0 at first on all the score displays except player one, but they all flash 222222 as if that was the high score (it's not). Even before adding a credit or starting a game, the credit display says 1 credit and on ball 1.

    All supply voltages are good, connectors are good, double checked to make sure I didn't bridge any pins, pulled the mpu board back out and re-seated the IC's in their sockets and gave them some deoxit just in case... but the same thing happens. Seems to be in a bootloop of sorts.

    Hoping it's something simple... has anyone run into this before?

    Thanks

    #2 14 days ago

    What do the pins inside of the J4 connector on the MPU look like? Chances are it needs repinned, especially if the MPU had any corrosion damage.

    I am leaning toward the connectors because of experience and because you used Deoxit - if the pins are corroded, they need replaced.

    #3 9 days ago

    Check the top left connector on the MPU and make sure it's making proper contact with all pins as the displays go through that connector and can cause weird issues!. If you don't have a new connector at least clean the pins and check all cables are tight in their socket...

    #4 8 days ago

    Thanks folks! The bootloop issue mysteriously went away. I still decided to redo all the connectors and nothing really has changed.

    So here's where I'm at...

    When game is on standby/attract mode, the players 2, 3, 4 displays are flashing between 00, 222222, and the high score. Player 1 display remains blank.

    When the working displays show the high score, it only lasts a fraction of a second and the "All time high score" light in the backglass lights up with it and goes out, as it should.

    When playing a game, the player 1 display (as well as the others) is usually blank, but player 1 sometimes lights up with 9's or 8's and it seems that if the score is in the hundreds, it's 999 or 888. If it's in the thousands, it's 9999 or 8888, if it's in the 10 thousands it's 99999/88888 etc etc etc.

    "Credits" and "ball in play" displays work fine. If playing a multi player game, the displays for the other players appear to show the score as they should. 1-up, 2-up, 3-up indicator lights work as normal, but 4-up is stuck always on.

    When I put the machine into display test mode, Players 2/3/4 flash 111111 through 777777 as normal, player 1 is blank. When it comes to 8's, player 1 lights up all 8's, but the others go to all 0's.

    When it comes to 9's, again, player 1 lights up all 9's like it should, but the others light up all 1's. Then it's back to 0's and the player 1 display goes out again.

    The following lights on the playfield/back box are constantly lit:
    Player 18
    Dealer 18
    Bonus 8000
    5x bonus
    Spinner lane #4
    Player Wins
    Clubs top lane
    "Beat the dealer" Saucer 3x
    "Tilt" on the backbox
    "4 up" on the backbox

    All of these seem to be driven by U4 (MC14514) on the lamp driver. However, I've ruled that out as a problem for now, because if that was bad, I don't think it would affect the digital displays. There are also other lights controlled by U4 that are working fine.

    That being said, the U4 chip seems to be driven by one of U10 or U11 (both 6820's) on the MPU, and so is the digital display.

    I'm suspecting PA7 signal from U10, which appears as though it should send an inhibit signal to U4 on the lamp driver. It also has a relationship to the displays through U20 (4502), but I can't quite figure out the schematic from this point.

    I'm hoping that's enough detail to narrow down the problem and hopefully someone more experienced with these boards can help point me closer to the issue. Thanks for the input so far!

    #5 7 days ago

    Check the game audits and bookkeeping, set a new value for a few things and then reboot. Go back and recheck, eliminate a semi-faulty 5101.

    Promoted items from the Pinside Marketplace
    From: $ 220.00
    $ 10.00
    Electronics
    Yorktown Parts and Equip
    $ 15.00
    Electronics
    Third Coast Pinball
    $ 17.00
    Playfield - Toys/Add-ons
    BK Pinball
    From: $ 42.00
    Cabinet - Shooter Rods
    ModFather Pinball Mods
    From: $ 19.50
    Apparel - Unisex
    ArcadeMade
    $ 229.99
    Lighting - Led
    PinballBulbs
    From: $ 9.99
    Eproms
    Matt's Basement Arcade
    From: $ 9.99
    $ 18.99
    Eproms
    Matt's Basement Arcade
    $ 44.00
    Playfield - Toys/Add-ons
    Lermods
    $ 129.95
    Cabinet - Shooter Rods
    Super Skill Shot Shop
    $ 5,799.00
    Pinball Machine
    Operation Pinball
    $ 7,499.00
    Pinball Machine
    Nitro Pinball Shop
    From: $ 99.99
    Cabinet - Other
    Lighted Pinball Mods
    $ 7,499.00
    Pinball Machine
    Operation Pinball
    $ 2.50
    Various Novelties
    Pinball Wheezer
    $ 6,995.00
    Pinball Machine
    Classic Game Rooms
    $ 7,995.00
    Pinball Machine
    Classic Game Rooms
    $ 89.99
    Lighting - Led
    Lighted Pinball Mods
    $ 89.99
    $ 275.00
    $ 20.90
    Apparel - Unisex
    Pinball Haus
    $ 26.95
    Playfield - Protection
    ULEKstore

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside