(Topic ID: 235022)

Bally 6803 Club - All Welcome

By gweempose

2 years ago


Topic Heartbeat

Topic Stats

  • 470 posts
  • 91 Pinsiders participating
  • Latest reply 8 days ago by Rossc
  • Topic is favorited by 41 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20190129_181728 (resized).jpg
20190129_205447 (resized).jpg
20190129_181802 (resized).jpg
20211006_133306 (resized).jpg
20211006_160415 (resized).jpg
20211006_133700 (resized).jpg
20211006_160426 (resized).jpg
20211006_162311 (resized).jpg
20211006_162809 (resized).jpg
pasted_image (resized).png
20211003_181915 (resized).jpg
20211003_181936 (resized).jpg
Screenshot_20211002-190751_Facebook (resized).jpg
Screenshot_20211002-224314_Facebook (resized).jpg
Screenshot_20211002-224308_Facebook (resized).jpg
Screenshot_20211002-224303_Facebook (resized).jpg

There are 470 posts in this topic. You are on page 10 of 10.
#451 28 days ago

Are you missing some GI over in that corner?

#452 28 days ago
Quoted from JodyG:

Does anyone know what these mystery wires are for on Motordome? Some kind of light

As was indicated, it's a GI socket.

pasted_image (resized).png
#453 28 days ago

Yeah its a bulb sicket that kays flat. I wouldn't worry about it too much,it only blinks when a ball goes through the gate,barely noticable.

#454 28 days ago

Sweet, thanks guys! I just needed to know because...

I'm working on some brand new ramps for this game, as I am about to swap in a nice new playfield into mine!

20210916_170016 (resized).jpg20210920_162118 (resized).jpg
#455 28 days ago
Quoted from JodyG:

Does anyone know what these mystery wires are

According to Todd - "one lousy little light bulb".

#456 28 days ago
Quoted from Enver:

Today I rolled over my Truck Stop. I got the crazy 5M jackpot, which gave me two replay levels at once -- later at 6.5M I should have gotten a triple-replay award according to the factory-standard attract mode announcement-- but I cannot remember a triple-knock).
So all I have in the end is 3M and I didn't make it into the High Scores!?! Is this really it for the 6803 basic operating system?

I did this with mine also
Kinda of a bummer

#457 27 days ago
Quoted from Viggin900:

Yeah its a bulb sicket that kays flat. I wouldn't worry about it too much,it only blinks when a ball goes through the gate,barely noticable.

Edit, my mistake. It flashes in sync with the turbo booster station on the top right when it is activated. Doesn't provide any gi light but more of an effect.

#458 23 days ago

i found opto set for my 6803 d&d!

IMG_5324 (resized).JPGIMG_5325 (resized).JPG

#459 20 days ago

Not sure how to access the LAB lights and switches on a Bally Strange Science 6803? #Strange Science

For future searchers, here's the answer.

There is a second set of playfield support brackets on the underside of the playfield near the far end. Lift up the playfield until it is about a 70 Degree angle (almost vertical). Lift it off the pins the brackets pivot on mounted on the inside of the cabinet, and take it up higher, until the back brackets can slide on to the pins in the inside of the cabinet. Lower it to a horizontal position, supporting the front edge with something, so it does not rest on the mechanisms and wiring.

You can now easily access the switched and lights on the back panel of the playfield.

It was not that difficult, but I did not see the back brackets at first.

Have fun with your game!

#460 15 days ago

Picked this up tonight. Probably going to have some questions so glad there is a club!

Screenshot_20211002-224303_Facebook (resized).jpgScreenshot_20211002-224308_Facebook (resized).jpgScreenshot_20211002-224314_Facebook (resized).jpgScreenshot_20211002-190751_Facebook (resized).jpg
#461 15 days ago

I just finished applying my own custom graphics over the generic Bally. I kept it somewhat motorcycle and MadMax. The whole thing cost me $26 using the public library vinyl printer.

20211003_181915 (resized).jpg20211003_181936 (resized).jpg
#462 15 days ago
Quoted from Viggin900:

I just finished applying my own custom graphics over the generic Bally. I kept it somewhat motorcycle and MadMax. The whole thing cost me $26 using the public library vinyl printer.
[quoted image][quoted image]

Wow $26! That looks amazing! All my side art is gone...lol.

#463 14 days ago
Quoted from Viggin900:The whole thing cost me $26 using the public library vinyl printer.

That's great, I went by a professional print shop once, they quoted $1000!
I laughed all the way out the door.
Oh, sorry, its was ALMOST $1000, went back to my emails:
pasted_image (resized).png

#464 14 days ago

Not sure if every library has one,I just payed for yhe material. Its the same quality as what you get from other sources.

#465 12 days ago

So my upper left flipper wasn't working. Turns out the coil stop and coil fell off. Put it back together and works great.

1. 2 pops aren't working. Left one has one wire disconnected (on purpose apparently) and middle pop is missing coil.

2. Drop target won't reset. One wire is disconnected (also on purpose).

3. One light won't light - green light #8.

4. Target bolt 2 and 3 give errors on power up and either score automatically or don't score manually or both.

Can someone take some pictures for me of these areas? So I can see how to wire back up? Any idea why all these things would be disconnected intentionally?

Ideas on the light issue?

Disconnect the caps on target bolt 2 and 3?

Have you ever seen a game so damn dirty?

20211006_133306 (resized).jpg20211006_133700 (resized).jpg20211006_160415 (resized).jpg20211006_160426 (resized).jpg20211006_162311 (resized).jpg20211006_162809 (resized).jpg
#466 10 days ago

1. 2 pops aren't working. Left one has one wire disconnected (on purpose apparently) and middle pop is missing coil.
20190129_181802 (resized).jpg

2. Drop target won't reset. One wire is disconnected (also on purpose).
20190129_205447 (resized).jpg

3. One light won't light - green light #8.
Have you checked the associated transistor for this controlled lamp?

#467 10 days ago
Quoted from Atari_Daze:

1. 2 pops aren't working. Left one has one wire disconnected (on purpose apparently) and middle pop is missing coil.
[quoted image]
2. Drop target won't reset. One wire is disconnected (also on purpose).
[quoted image]
3. One light won't light - green light #8.
Have you checked the associated transistor for this controlled lamp?

Thank you for the pictures! I will check the transistor. So does the left pop only have 2 wires going to it instead of 3 like the other two pops and drop?

#468 10 days ago
Quoted from crujones4life:

So does the left pop only have 2 wires going to it instead of 3 like the other two pops and drop?

I don't recall which pop is which, but here is one that does only have 2 wires.

20190129_181728 (resized).jpg
#469 9 days ago
Quoted from Atari_Daze:

I don't recall which pop is which, but here is one that does only have 2 wires.[quoted image]

Thanks very much!

#470 8 days ago

Hi all, a follow up from early this year.
I had ordered a new mpu from swemmer direct and was waiting for it to arrive to do a final post to advise how it all went, so ordering it direct from swemmer started great, prompt emails a good deal on the board, postage and tracking went well. the board arrived nicely packaged with no visible damage.
The board was to replace the original mpu which works without fault ( i wanted a backup just in case), i installed the new board but it would not boot and would stall at different flashes sometimes 1 sometimes 3.
Contacted swemmer for help, initially he accused me of killing the board, i tried re seating the game roms and got the mpu to boot but after a powerdown it wouldnt boot again, informed him of this and he now thought that a mechanical issue was the cause.
After reseating all the chips the mpu would boot now and again but NOT without a long power down between attempts, when it did boot playing a game would see the score screw up, during a normal game the last digit score only shows a zero but this mpu would show an number between 0 and 9, matching numbers would still would award a free game if the first number was matched, last 2 numbers 39 would award free game for 30 nvram would not hold settings either.
Sent the board back for warranty, he informed me that the nvram was in the wrong slot and that was causing the issue and now the board boots fine but testing would continue for a few days just to be certain, he said that the board seemed still to be a little flaky and would build a new board to be sure, i asked if he was using new chips (not the ones from the original board) and was asured that he was, testing coninued for a week before being posted back.
Board arrives, installed, same fault, i swapped the the game roms from the oem board and purchased a new Nvram locally once these were installed the game works but now has several SCR's that were blown i changed these over and the board has worked okay for several months.
All of these repairs were done with permission ( to avoid warranty issues), a refund was given for the Nvram but i asked to have the Eproms replaced (i wanted to keep the oem board intact) his response was that he would replace them bu he was shifting house and advised it would be around june before that could happen, after repetead requests this has still not happened and now refuses to respond to my emails.
In my original post i highly recomended swemmer, i withdraw that recomendation and if you choose to use him it is done without my recomendation

There are 470 posts in this topic. You are on page 10 of 10.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside