(Topic ID: 290012)

Bally -35 Kiss - Stops halfway on attract mode

By perry1670

1 year ago


Topic Heartbeat

Topic Stats

  • 29 posts
  • 7 Pinsiders participating
  • Latest reply 1 year ago by BigAl56
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

PXL_20210317_162810764 (resized).jpg
PXL_20210317_162806637 (resized).jpg

#1 1 year ago

Man I'm having a run of bad luck here lately. Rehabbing an MPU

Bally Kiss - Can get all 7 flashes, and the start music comes on. It will go into attract mode for about 3 seconds, then stops.No further lights will turn on. Can coin up, but when the start button is pushed, no solenoids fire. Displays are all blank except Player 3 which strobes all 0's. I checked the data lines and they are still active after the Atrract Mode stops.

Self Test - Controlled lamps work, coils work, switch test works and are shown on the displays 1 and 2.

I initially thought it was a ROM issue, but after replacing the sockets and burning new Eproms, still having the same issue. U11 PIA controls the solenoids and displays so I swapped it with U10 and still the same issue.

Burned new Eproms
New Sockets on U1,U2,U6, U15,U16,U7 and U8
Checked PIAs on Neoloch Inquisitor

Maybe the U11 socket is fine until it warms up then has some issues? I'll check that socket next and see what it does.

Otherwise, thoughts?

#2 1 year ago

tilt switches?

#3 1 year ago

Tilt switches are open and the diodes are good.

#4 1 year ago

slam switches?

#5 1 year ago

what happens with just J4 connected on the MPU?

#6 1 year ago

Slam switches are the same.

With just J4 connected, I get 7 flashes, and the boot up music.

J4 was repinned and I got halfway through repinning J1 when I got tired of it.

#7 1 year ago

It just acts like the program isn't fully loading, if that's even a thing.

Player 1 and 2 displays work on self test, so they are getting the strobes and interpreting correctly so they must not be getting strobes when the game ROM is loaded and playing.

Checked the 6810 and the 5101 on Neolock and they both checked good. I realize these are checked on startup as well.

#8 1 year ago

This is an interesting problem!

Question: displays are working. Do solenoids fire correctly in self test? Curious, as "loss" of +43 from the CPU perspective will cause a pause--but not a lockup/crash.

#9 1 year ago

It's defintely a new one for me

Answer: Yes all the Solenoids work during self test. I did have to change out the decoder and the 3081 on the driver board to get it firing though not that it should matter I suppose.

On startup the drop target coil does fire and then goes into attract for the approx. 3 seconds.

I did check the voltage after everything stopped and the voltages still are present and good on the MPU.

#10 1 year ago

I changed out the Solenoid board from a working machine that I had recapped just to make sure I wasn't losing voltages and that wasn't the problem.

What I did find though was that once It stops the brief attract mode, I can manually hit the targets and it will score points and make sound affects.

#11 1 year ago
Quoted from perry1670:

I changed out the Solenoid board from a working machine that I had recapped just to make sure I wasn't losing voltages and that wasn't the problem.
What I did find though was that once It stops the brief attract mode, I can manually hit the targets and it will score points and make sound affects.

Kind of sounds like a switch problem. Unplug the two connectors on the right side of the MPU and see if it stays in attract mode.

#12 1 year ago

That's kind of what I thought, but if it is, it isn't with the playfield. I should be able to unplug J2 and put it into self test and verify that no switches are made on the playfield, this would be indicative of a board problem as it's unplugged.

I unplugged both connectors on the right and it does the same thing

#13 1 year ago

Possibly a power problem. What does the 5v read? Do you still have the original power supply capacitors?

#14 1 year ago

Power seems to be holding steady on the 5V and 12V rail. TP2 reads a solid 12.82VDC and TP5 reads a solid 5.25VDC. I measured from machine off through startup until the attract mode stops and it doesn't drop out. I could hook up the O-scope and verify but the Fluke 179 should easily see a momentary drop.

I have used both the original and rebuilt Solenoid board and the same issue occurs.

So if I didn't have a switch problem earlier, I have one now. When going into Test mode, the switches no longer register on the playfield. I went ahead and repinned J2 and J3 connectors and re flowed the pins. No change.

#15 1 year ago

so all headers checked for dry joints?

when it crashes, what's the status of the LED on the mpu?

#16 1 year ago

I didn't see anything abnormal. No cracks or bad looking joints. I reflowed them just as a matter of course.

The LED stays unlit after the 7th flash and stays unlit for the duration, even after the crash.

#17 1 year ago

If we take the power off the table it leads me to believe an MPU crash. Possible battery damage from a past life?? Can you post a video of the game in this crashed state. Include a clear steady view of the MPU around the LED and battery area.

#18 1 year ago
Quoted from BigAl56:If we take the power off the table it leads me to believe an MPU crash. Possible battery damage from a past life?? Can you post a video of the game in this crashed state. Include a clear steady view of the MPU around the LED and battery area.

Yes this. We still don't understand your fail mode fully. If it is racking up points that leads me to believe it is not really "crashed" but just starts a game as soon as attract mode hits and the CPU is running software fine per the inputs it thinks it is receiving.

Clear the current credit audit 5 back to zero so there are no credits on the game (if you can get to test mode, start to hammer the test button right at MPU self test flash 7).

With two connectors off of the right side of the MPU. Short from switch row to switch column to test switches at the MPU. Check at least one switch in every row and column and make sure you get the right number for the combination you are closing. That will tell you if the MPU is reading switches OK.

Also keep in mind the U10 PIA is very busy. The same PIA ports that handle switches can do other stuff like displays and lamps. I noticed in post one you say player 3 is all zeros. This may be an indication the PIA is bad or shorted. Most common way the PIA port gets shorted is a switch shorts to ground. Like the start button leans on the grounded coin door.

#19 1 year ago

My apologies for the confusion on what the problem is. I realize that I'm confused and I'm sitting here looking at it, let alone reading someones poor description of events. Here is a video from startup to "failure". I then go into audits and work through the various self test functions up through the switch test. Also are two pictures of the MPU. It has been re-jumpered to accommodate 2716 EPROMs. Hopefully this sheds a little more light on the topic and thank you all very much for the help!


PXL_20210317_162806637 (resized).jpgPXL_20210317_162810764 (resized).jpg

#20 1 year ago

Nice clean MPU. You're lucky. I don't see a battery installed (off board) and you are not using NVRAM to replace the stock 5101 chip at U8. I would suggest clearing audits in the service menu and rebooting. Too many times I have seen stuff stuck in RAM that goofs up the MPU. I can't say this will exactly solve your issue, but it is worth a try.

There is a great NVRAM available that many of us use and is designed / supported by a member too. Here is the link: https://nvram.weebly.com/

I would clear the audits and see what happens. Then I would suggest ordering the NVRAM and clear audits when you have the NVRAM installed and see what happens.

#21 1 year ago

Defintely good advice on the NVRAM, just haven't got that far into it yet. Silly pandemic taking all of BarakandI stock, who buys just one chip at a time

So I have tried clearing the audits as best I can. Player 1 and 2 display will only show 00 when going through the audits so I just went through them and cleared each one as I went, hopefully I got them all. Unfortunately it did not appear to have any affect. I have also tried two different 5101s, again with the same outcome.

#22 1 year ago

Video shows very strange operation.

Things I notice. Solenoids fire out of order in test mode. They are controlled by U11 but is often a connector issue.

Player 3 display is enabled at the wrong time (always?). This is controlled by U11 PA2 which also does lamp address 2 and switch strobe 2. PA2 shorted to something on PCB? Switch shorted to ground? Other displays are off and P1 does not rack up score staying at 00. Bad U10? Probably not the 4502 since there is problems beyond the displays.

U8 has an impossible date code. Does not mean it is bad, but could be suspect. Sounds like you swapped it out already tho.

Can also unplug the lamp board and isolate one display at at a time that has been verified working in another game in case problem on the lamp board or a display is fudging up the PIA through MPU j1. Check the zero X for 120hz and the display interrupt for 320-420hz as I suppose an interrupt problem is possible.

Seems likely the problem is at or around U10. The solenoids firing out of order probably separate connector issue between MPU j4 and driver j4.

#23 1 year ago

I unplugged all the displays, installed a known working in player 1, both with the lamp board plugged in and without it plugged in. No Change.

I went ahead and installed a new socket on U10 and U20. I changed the 4502 - same result on the displays. I swapped U10 and U11 and double checked them both on the Inquisitor, no change.

I may have screwed this up, but I checked the zero crossing on Pin 4 of U14 and it was 118hz, so good I would say and Display interrupt at U11 pin 40, bounced around some bit was within the specs given, 320 - 420 hz.

U8 - Ebay special, but did check out good on Inquisitor.

I did a cursory search for shorts on PA2, but nothing found so I"ll do some more probing on that one.

#24 1 year ago

So I was able to get Player 3 to stop pulsing like it was. I went back and start snooping around the Rectifier board and found a number of questionable wiring practices. It looks like the three Switched Illumination Buss' had been cut and hacked up (with an additional non powered bridge rectifier to boot) so I got that lined out and Player 3 no longer pulses.

None of the displays now work, even when going through Self Test. I replaced the original 4502 but that didn't change anything. Display fuse is good on the Solenoid board. I mark this as an improvement, maybe not much of one but at least it takes one issue off the table.

#25 1 year ago

I checked a few more things and no smoking gun so I changed out the MPU from another machine.

Same issues happening with the "new" MPU. Player 1 and Player 2 displays now work, but board will randomly reset or lock on a solenoid. I'm going to finish repinning J1 and then start searching from there.

I for one am feeling much better to have issues on a second MPU because I just wasn't finding anything on the first. I'll keep the thread open and report back what/if I find.

#26 1 year ago

Sometimes you gotta know when to quit and I'm in over my head. I'll send the board off for some professional repairs.

Thanks all for the help none the less.

#27 1 year ago

Update:

On J4 I found a couple crimps that had too much coating crimped onto the wire which was causing some issues depending on the location of the board IE: On the standoffs, hanging down, etc. So I got those lined out and got the Second MPU to solidly boot up.

I put the original MPU back in, and it was still exhibiting the same behavior as in the video. So I took the canned of compressed air out and starting cooling off some chips to see if it had any impact. The thought was maybe a socket was so bad that even that brief boot up and attract mode was causing heat buildup and things to go awry. Sure enough, after cooling off u10 the machine would either lock on the 4th flash, only give 3 flashes or just do other weird stuff like lighting random lights or occasionally throw a sound out. Maybe it's a poor socket job?? Regardless I'll be changing out the socket and seeing what happens.

The constant strobing of the 3rd display is display specific. With the working MPU I am able to move it around and the problem follows the display.

#28 1 year ago

If you've got a hacked up rectifier board I'd start there. A new one from weebly is like $40. With 2 MPUs exhibiting the same behavior your issue is likely either power or connectors. Re-crimp anything suspect, verify wiring from the schematic.

#29 1 year ago

Install an NVRAM and try swapping U10 and U11. That's what I would start with.

Promoted items from the Pinside Marketplace
$ 179.00
Cabinet - Other
Pinball Pimp
From: $ 45.00
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
From: $ 10.00
Cabinet Parts
Wire-Bot
From: $ 170.00
$ 99.99
Lighting - Other
Lighted Pinball Mods
$ 29.00
Boards
PinballReplacementParts
$ 10.95
Eproms
Pinballrom
$ 119.95
Boards
Allteksystems

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!