(Topic ID: 257850)

Official Rick and Morty Club - You are not like other carbon based life forms.

By TheNoTrashCougar

1 year ago


Topic Heartbeat

Topic Stats

  • 16,600 posts
  • 628 Pinsiders participating
  • Latest reply 2 hours ago by Alamo_Pin
  • Topic is favorited by 324 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20211124_215803 (resized).jpg
20211124_132129 (resized).jpg
20211124_132106 (resized).jpg
20211122_152120 (resized).jpg
20211122_151128 (resized).jpg
20211122_150536 (resized).jpg
797C8916-E87F-4825-961A-9717153F30F4 (resized).jpeg
RM (resized).jpg
CB0194E1-9FCD-4E94-B44F-80B011709C99 (resized).jpeg
Screenshot_20211116-082730_Chrome (resized).jpg
99E09A19-A829-4C51-9D9F-600A73221BA4 (resized).jpeg
A2615975-FED2-42CF-B7F8-9F9059C7BE56 (resized).jpeg
48DFBAEA-5B25-4CEE-8A8F-6E472F85830A (resized).jpeg
purple_coin_door_decal (resized).png
3d_printed_plate (resized).jpg
decal_peeling (resized).jpg

Topic index (key posts)

83 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 16,600 posts in this topic. You are on page 332 of 332.
#16551 5 days ago

Having some GI issues on the right side. Lights sometimes not working or only white. I have probably used a whole stick of hot glue trying to keep the connectors on the affecting board down. Has anyone else had lighting issues that were caused by something other than the connectors on the lights boards being loose?

#16552 5 days ago

Just saw that Halloween knife handle plunger from Spooky. And here I was thinking that a lack of a plumbus on R&M was such a lost opportunity. Would have been awesome to have a manual plunge to include it, but there has to be some genius modder that can make a custom plumbus butt-on pusher.

#16553 5 days ago

Hey anyone with the PinballModCo lcd replacement…

Are the tiny foam strips for separating the screen from the plastic screen protector on front? Did you just put them on four sides of the new lcd? Or two on bottom corners and top corners or what? Or did you use them?

Thx in advance
Kevin

#16554 5 days ago
Quoted from northerndude:

Hey anyone with the PinballModCo lcd replacement…
Are the tiny foam strips for separating the screen from the plastic screen protector on front? Did you just put them on four sides of the new lcd? Or two on bottom corners and top corners or what? Or did you use them?
Thx in advance
Kevin

Per the supplier, the thick foam and thin felt are two different thickness of spacer, to fill the gap between your clamps and the backside of monitor, depending on a variety of factors regarding your clamp and your monitor thickness. I used the felt because the foam seemed too thick on mine. Nothing goes between monitor and plastic protector.

#16555 5 days ago
Quoted from Morgoth00:

Per the supplier, the thick foam and thin felt are two different thickness of spacer, to fill the gap between your clamps and the backside of monitor, depending on a variety of factors regarding your clamp and your monitor thickness. I used the felt because the foam seemed too thick on mine. Nothing goes between monitor and plastic protector.

Thanks for this response (and northerndude for asking), I haven't swapped mine out yet because I wasn't sure what all the pieces were for either. I also have the plastic protector, so I will follow your method when I install mine.

#16556 5 days ago
Quoted from Morgoth00:

Per the supplier, the thick foam and thin felt are two different thickness of spacer, to fill the gap between your clamps and the backside of monitor, depending on a variety of factors regarding your clamp and your monitor thickness. I used the felt because the foam seemed too thick on mine. Nothing goes between monitor and plastic protector.

Thx, he got beck to me. There was a second video that was on a different page on the website I missed.

All good. I believe I now have an issue with the green pcb mount bracket hitting the wood at the lock area and it’s stopping the door from closing that extra < 1/8” and I can’t lock it now, might have to start clipping the green bracket.

I’m having an issue with the screen flickering also. Ben trying to figure out why

EDIT- also, I used the foam instead of the felt as it had enough “give” and I was able to tighten it gently and left the foam have just enough pressure to hold down firm enough

#16557 5 days ago
Quoted from Morgoth00:

Working on my upper flipper alignment since I am swapping shooter ramp. Even with rubber post ring removed, I can't get it perfect. Middle screw can no longer be installed and middle tab is hitting black rail. End tab screw is maxed out and will need to be re-drilled to go farther. Will going that last little bit be worth drilling new holes or will I notice a difference?
Factory before:
[quoted image]
As close as I can go:
[quoted image]
[quoted image]

I sanded the corner off the black rail down to a 45* and slid the tab under the rail and drilled new holes for the ball guide.

The amount of ‘tweaking’ I had to do on this game was beyond what anyone should have to do.

#16558 5 days ago
Quoted from Lounge:

I sanded the corner off the black rail down to a 45* and slid the tab under the rail and drilled new holes for the ball guide.
The amount of ‘tweaking’ I had to do on this game was beyond what anyone should have to do.

So true, but I actually enjoyed the journey since I love the game so much (and Scott/Spooky/etc. were all very helpful/supportive).

Played it last night after being away from it for 5 months. Wow. Killer shots/combos...so much personality/humor. Game has it all.

#16559 5 days ago

I hope I'm not the only one that needed 4 months to figure out how the magna save feature worked... sad I know! I bought R&M mainly because one of my daughters (who enjoys playing pinball with me) and introduced me to R&M. I wanted to strengthen our shared bond by hunting a game down. Was only last month while she was playing the game that we stumbled on the great feature - just blew me away!

Changing the flipper spacers today - getting ready for Thanksgiving and serious R&M action!

Quoted from TrekTobbyGermany:

Scott somewhere mentioned that he is very happy about that magna save feature. And yes, it is very good.
You have to figure out the behavior and learn how to use and time it. If you do, it's really fun and possible to avoid draining most times. You can sling the ball back to flippers or time the magnet carefully to slightly move from out- to inlane. It's really not easy... And adds much fun to the pin.
Great feature plus on a great and unique pin!

#16560 5 days ago
Quoted from MrExtrm:

Having some GI issues on the right side. Lights sometimes not working or only white. I have probably used a whole stick of hot glue trying to keep the connectors on the affecting board down. Has anyone else had lighting issues that were caused by something other than the connectors on the lights boards being loose?

This is the only issue I've had on my game, I kept wasting time messing with the connector going from the node board to the GI itself, but in my case it ended up being a bad connection on the power going to the node board. I'm not sure the wire housing had been adequately pierced? I shoved the wire further into the connector/plug (using a small flathead screwdriver) and reseated everything and haven't had an issue since.

#16561 5 days ago
Quoted from nogoodnames222:

This is the only issue I've had on my game, I kept wasting time messing with the connector going from the node board to the GI itself, but in my case it ended up being a bad connection on the power going to the node board. I'm not sure the wire housing had been adequately pierced? I shoved the wire further into the connector/plug (using a small flathead screwdriver) and reseated everything and haven't had an issue since.

Thank you, this sounds like it could be my issue as well..

#16562 5 days ago

I went for it and redrilled my upper flipper ball guide, getting it exactly aligned to the flipper. Hello skillshot! New shooter ramp, Xspacers, reset right flipper angle, garage shot curve adjusted, all much better now and much more precise! Still want to run external sub to get rid of all the nasty vibration, since I can't play it without maxing the volume.
Also noticed the number display under the scoop was missing part of a light digit. Discovered the connectors
were hot glued on crooked and had a huge chunk of glue underneath blocking it from seating properly. Game on!

#16563 4 days ago
Quoted from Morgoth00:

I went for it and redrilled my upper flipper ball guide, getting it exactly aligned to the flipper. Hello skillshot! New shooter ramp, Xspacers, reset right flipper angle, garage shot curve adjusted, all much better now and much more precise! Still want to run external sub to get rid of all the nasty vibration, since I can't play it without maxing the volume.
Also noticed the number display under the scoop was missing part of a light digit. Discovered the connectors
were hot glued on crooked and had a huge chunk of glue underneath blocking it from seating properly. Game on!

External sub is a huge improvement.. I just hooked up a car audio sub to the amp in the game, and now I can crank it with zero rattle. Only have to worry about the wife bitching now

#16564 4 days ago

Ditto. External sub is always great but on this game it’s amazing.

#16565 4 days ago
Quoted from Palmer:

Ditto. External sub is always great but on this game it’s amazing.

I love to feel the sub through my hands - I used the zip tie under the glass channel trick (described somewhere in this forum) to kill the rattles, in addition to felt tape lining the edges of the glass. It probably took 8 or 10 on each side to fully kill the rattle.

#16566 4 days ago
Quoted from Trumpanche:

I love to feel the sub through my hands - I used the zip tie under the glass channel trick (described somewhere in this forum) to kill the rattles, in addition to felt tape lining the edges of the glass. It probably took 8 or 10 on each side to fully kill the rattle.

Had the anti rattle tape and rail shims going, but I still had rattle and there was something under glass (probably the house) that was still pissing me off. Disconnecting the factory sub and running speaker cable to an external sub took all of 10mins and makes a word of difference. Not just an improvement in rattle reduction, but also the response as well. The cabinet is way to big of an enclosure for the standard sub, and always sounded a bit sloppy to me. So much better in a right sized enclosure.

#16567 4 days ago
Quoted from nogoodnames222:

This is the only issue I've had on my game, I kept wasting time messing with the connector going from the node board to the GI itself, but in my case it ended up being a bad connection on the power going to the node board. I'm not sure the wire housing had been adequately pierced? I shoved the wire further into the connector/plug (using a small flathead screwdriver) and reseated everything and haven't had an issue since.

Tried this last night and followed up with a half dozen games and left my machine on while after with no issues. Thanks so much for the input, this was the last issue I was trying to work out.

#16568 4 days ago

Okay, my pop bumper finally gave up the ghost. About a month ago the RGB light gave up working and I ordered a replacement. However, after removing the cap of the bumper I realised that soldering the new LED in there was going to be a VERY tight job and I was concerned about how steady my hand would be so I have been living with no Pop bumper RGB. Well, last night the PB stopped popping, it still registers when hit, but doesn't pop the ball. So today I pulled the PF up (almost had a major accident as I pulled it too far forward and it fell right off the rails, luckily nothing seems to have gone wrong there).
Anyway, I found the problem, the positive wire that appeared to be attached to the coil was actually loose and only held by the plastic. I can reattach this and get the PB working minus the light. I have replacement boards for the RGB. Should I try and remove the entire PB mech (plastic bracket that holds the whole thing together that is screwed into the bottom of the PF)? Or, does anyone have any recommendation on the best way to reattach the light and get to the wire I need to solder?

As far as I can tell, I would need to remove one of the prop/leg things that is over the mech and then I can lower the whole thing from the PF and work on it. But, before I do that I would like to hear suggestions from anyone who has worked on this mech.

Thanks in advance,
John

Here is a picture of the underside, and the broken light inside the pop bumper, the light bulb has completely broken off so I know it needs replaced.

20211124_132106 (resized).jpg

20211124_132129 (resized).jpg

#16569 4 days ago
Quoted from Var1AbL3:

Okay, my pop bumper finally gave up the ghost. About a month ago the RGB light gave up working and I ordered a replacement. However, after removing the cap of the bumper I realised that soldering the new LED in there was going to be a VERY tight job and I was concerned about how steady my hand would be so I have been living with no Pop bumper RGB. Well, last night the PB stopped popping, it still registers when hit, but doesn't pop the ball. So today I pulled the PF up (almost had a major accident as I pulled it too far forward and it fell right off the rails, luckily nothing seems to have gone wrong there).
Anyway, I found the problem, the positive wire that appeared to be attached to the coil was actually loose and only held by the plastic. I can reattach this and get the PB working minus the light. I have replacement boards for the RGB. Should I try and remove the entire PB mech (plastic bracket that holds the whole thing together that is screwed into the bottom of the PF)? Or, does anyone have any recommendation on the best way to reattach the light and get to the wire I need to solder?
As far as I can tell, I would need to remove one of the prop/leg things that is over the mech and then I can lower the whole thing from the PF and work on it. But, before I do that I would like to hear suggestions from anyone who has worked on this mech.
Thanks in advance,
John
Here is a picture of the underside, and the broken light inside the pop bumper, the light bulb has completely broken off so I know it needs replaced.
[quoted image]
[quoted image]

Someone else may have a better suggestion, but when my RGB light stopped working I carefully desoldered it and reattached the wires while the pop bumper was in the machine. It was NOT ideal, but I didn't feel like trying to figure out an easier way so I very carefully and minimally soldered the wires back onto the new light. That was many months ago, no issues since.

#16570 4 days ago
Quoted from Var1AbL3:

Okay, my pop bumper finally gave up the ghost. About a month ago the RGB light gave up working and I ordered a replacement. However, after removing the cap of the bumper I realised that soldering the new LED in there was going to be a VERY tight job and I was concerned about how steady my hand would be so I have been living with no Pop bumper RGB. Well, last night the PB stopped popping, it still registers when hit, but doesn't pop the ball. So today I pulled the PF up (almost had a major accident as I pulled it too far forward and it fell right off the rails, luckily nothing seems to have gone wrong there).
Anyway, I found the problem, the positive wire that appeared to be attached to the coil was actually loose and only held by the plastic. I can reattach this and get the PB working minus the light. I have replacement boards for the RGB. Should I try and remove the entire PB mech (plastic bracket that holds the whole thing together that is screwed into the bottom of the PF)? Or, does anyone have any recommendation on the best way to reattach the light and get to the wire I need to solder?
As far as I can tell, I would need to remove one of the prop/leg things that is over the mech and then I can lower the whole thing from the PF and work on it. But, before I do that I would like to hear suggestions from anyone who has worked on this mech.
Thanks in advance,
John
Here is a picture of the underside, and the broken light inside the pop bumper, the light bulb has completely broken off so I know it needs replaced.
[quoted image]
[quoted image]

Dont forget forget install a rubber ring per Thenotrashcougar https://pinside.com/pinball/forum/topic/aw-jeez-official-rick-and-morty-club/page/322#post-6525313

Also see this post for more pop light replacement info
https://pinside.com/pinball/forum/topic/aw-jeez-official-rick-and-morty-club/page/262#post-6258022

#16571 4 days ago
Quoted from orlandu81:

I very carefully and minimally soldered the wires back onto the new light.

That was the easy answer . I unfortunately, since I needed to resolder my coil, ended up taking it apart. This affords me the rare opportunity to replace the pop bumper skirt and housing which I have been putting off for months on my Breakshot. The unfortunate part about pop bumpers is they are generally a major operation to repair or replace. So, I am going to rebuild mine (did take off the support to get access but not the whole mechanism) and put some foam between the light and the body to dampen the vibrations and hopefully it will last longer that way. The reason I did this today is I have a few days to get it finished when the finicky thin wires start to make me crazy.

#16572 4 days ago

That is the exact post I needed and I don't know how I missed it on my search. Since I have it all apart I am replacing the skirt and body as well. I think there were just too many mentions of pop-bumpers. I do have some extra rubber rings, I will use that instead of foam as I had planned.

Thanks for posting the links Morgoth00 !!

#16573 3 days ago

Just unscrew the board, clip a few zip ties and pull the wires up enough to work on the new / replacement board. Then re-install with rubber rings under the board.

#16574 3 days ago

Officially in the club w a beautiful example....

Will catch up in this thread, but simply wanted to say AJ rocks!!!

Deadly, hilarious so far!!!

#16575 3 days ago
Quoted from MK6PIN:

Officially in the club w a beautiful example....
Will catch up in this thread, but simply wanted to say AJ rocks!!!
Deadly, hilarious so far!!!

This game is a pisser, be sure to have the adult settings turned on for the full experience

"Let's Roll Mother Fuckers"

#16576 3 days ago
Quoted from DeathHimself:

This game is a pisser, be sure to have the adult settings turned on for the full experience
"Let's Roll Mother Fuckers"

Dropped around 5 F bombs during the first ball, lol...hilarious!!!

Had to switch to " never" today however...grandkids here for Thanksgiving.....

#16577 3 days ago
Quoted from MK6PIN:

Dropped around 5 F bombs during the first ball, lol...hilarious!!!
Had to switch to " never" today however...grandkids here for Thanksgiving.....

Put it to 1% and have some kid get absolutely shocked, haahahha

#16578 3 days ago
Quoted from northerndude:

Put it to 1% and have some kid get absolutely shocked, haahahha

I don't trust the game lol....this is one, aggressive machine in many ways!!!! Can't wait to really play the hell out of it!!

#16579 3 days ago

Happy thanksgiving to all the Morty’s out there! This may be an unsubstantiated observation, but I feel like I hit more shots right after I clean the playfield. You’d think the game would be a little easier playing a little slower, but all my top score are within a day or two of cleaning. Anyone else notice this?

#16580 3 days ago
Quoted from MrExtrm:

all my top score are within a day or two of cleaning. Anyone else notice this?

I do notice that, I also notice that this game gets dirtier than all my other four combined. It is probably at least a little due to me playing it far more than any other machine I own. I gave it a good clean and wax the other day, just before my pop bumper took a shit, and it was playing amazingly. Helps that I replaced many of the rubbers and adjusted the switches on the sling.

Now I have it apart working on replacing the light and plastics on the pop bumper, but have to leave for TG dinner, will have to finish in the morning.

#16581 2 days ago

New ramp, New ball lock! lol happy Thanksgiving pinheads

20211124_215803 (resized).jpg
10
#16582 2 days ago

Game is the hit of Thanksgiving!!! Son is on it nonstop!!! He has never stayed on any game this much prior ( loves theme big time)

Have no idea what I'm doing yet, but factory hs settings are falling....game is wicked fast and fun!!!

Soo glad I nabbed this one ( audio is incredible!!!)

Happy Thanksgiving all!!! ( watching them actually play the games is awesome!!)

#16583 2 days ago
Quoted from Alamo_Pin:

Did you get this issue solved? I have the exact same problem. My magnet stopped working right after I installed the flipper spacers, so I figured I must have caused a wire to come loose. But I still can't solve the issue.

Nope called spooky need to buy new magnet from pinball life but can't find part number on the magnet. Will call spooky tomorrow if they are open. Bummer mine was just out of warranty.

#16584 2 days ago
Quoted from zebpin61:

I hope I'm not the only one that needed 4 months to figure out how the magna save feature worked... sad I know! I bought R&M mainly because one of my daughters (who enjoys playing pinball with me) and introduced me to R&M. I wanted to strengthen our shared bond by hunting a game down. Was only last month while she was playing the game that we stumbled on the great feature - just blew me away!
Changing the flipper spacers today - getting ready for Thanksgiving and serious R&M action!

If you're playing with your daughter make sure you turn on all the "training wheels" features so she doesn't find it incredibly brutal. Turn on all ball saves, increase timers, etc... I've had to do that for some guests that just found it too unforgiving. It's not one of these layouts where you can just bat the ball and hope it goes up a ramp or something.

In other words it's not CC yuk yuk

Now THAT's a game any beginner will love.

#16585 1 day ago

Hi,

where was it again described how the left lane to the portal is improved?
Post ???

Thx

Sven

#16586 1 day ago
Quoted from Svente69:

Hi,
where was it again described how the left lane to the portal is improved?
Post ???
Thx
Sven

This? https://pinside.com/pinball/forum/topic/aw-jeez-official-rick-and-morty-club/page/37#post-5552517

#16588 1 day ago

deleted. wrong thread.

#16589 22 hours ago

Absolutely loving this machine
Best thing is my nine year old and also my wife have taken to it .. the boy has not engaged in a game as much since forever and the Mrs , well the last game she enjoyed was WoZ
Me and the boy play every morning before school and two games before bed.
What an incredible machine this is ... like TNA but so much better and I absolutely fricking love TNA

#16590 22 hours ago

Was wondering
The moon man mode .... I am
Assuming
It's only 60 seconds due to maybe licensing on the song and maybe Jermaine??? But
Has anyone made it longer ? As in can you change the code on a spooky like what Cleeland for example has done with sterns? Would be great to be able
To extend that mode longer to take in the entire song

10
#16591 22 hours ago

'Shut the fuck up about moon men!

#16592 21 hours ago

What level do you guys have your game at? 6.5?

#16593 21 hours ago
Quoted from WizardsCastle:

What level do you guys have your game at? 6.5?

More

#16594 21 hours ago
Quoted from wizard1974:

Was wondering
The moon man mode .... I am
Assuming
It's only 60 seconds due to maybe licensing on the song and maybe Jermaine??? But
Has anyone made it longer ? As in can you change the code on a spooky like what Cleeland for example has done with sterns? Would be great to be able
To extend that mode longer to take in the entire song

That’s the longest possible due to the animations and audio sync.

#16597 14 hours ago
Quoted from Morgoth00:

'Shut the fuck up about moon men!

Hahahaha

#16598 7 hours ago
Quoted from Deadlander:

Nope called spooky need to buy new magnet from pinball life but can't find part number on the magnet. Will call spooky tomorrow if they are open. Bummer mine was just out of warranty.

Fixed problem after checking continuity on both sides of the z connector we found that one of the idc connectors was broken reset wire and bingo we had a working magnet. Good thing I didn’t buy a new magnet. Really hate those connectors tempted to switch to a Molex connector or just solder them together.

#16600 2 hours ago
Quoted from Deadlander:

Fixed problem after checking continuity on both sides of the z connector we found that one of the idc connectors was broken reset wire and bingo we had a working magnet. Good thing I didn’t buy a new magnet. Really hate those connectors tempted to switch to a Molex connector or just solder them together.

Would you mind taking a pic of the connectors and posting it? I’m hopeful that will fix my problem, too.

There are 16,600 posts in this topic. You are on page 332 of 332.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside