(Topic ID: 257850)

Official Rick and Morty Club - You are not like other carbon based life forms.

By TheNoTrashCougar

2 years ago


Topic Heartbeat

Topic Stats

  • 17,677 posts
  • 661 Pinsiders participating
  • Latest reply 2 hours ago by monitorpop
  • Topic is favorited by 325 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

rick-n-morty-chip-n-dale (resized).jpg
pasted_image (resized).png
20220513_212449 (resized).jpg
20220512_173122 (resized).jpg
20220512_185914 (resized).jpg
20220512_185910 (resized).jpg
20220512_180325 (resized).jpg
F9C623CA-A25E-4B0E-B514-1B88366A9FA8 (resized).jpeg
pasted_image (resized).png
Screen Shot 2022-05-12 at 12.44.08 PM (resized).png
rick-morty-portal-alternate-pinball-translite-alternative-flipper-backglass-spooky. (resized).jpg
IMG_4229 (resized).jpg
IMG_4228 (resized).jpg
IMG_4227 (resized).jpg
IMG_4230 (resized).jpg
736E58DB-FCBF-493B-9091-57E3C8ED6109 (resized).jpeg

Topic index (key posts)

90 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 17,677 posts in this topic. You are on page 290 of 354.
#14451 11 months ago

Finally got to setting up my R and M. Didnt realize the box is like 1/4" bigger then Sterns or JJP, had to unbox outside then get it indoors since it didnt fit through my doorway.
Hope no more hiccups on my journey haha.

#14452 11 months ago

Update ...

Ok I’m only getting butter cab from now
On ! Phenomenal!

Gotta say this is my first spooky machine and man it looks awesome !

1F934BBD-A466-4AB8-B05E-F5458D3E478F (resized).jpeg

CC7AD234-FC55-4092-8AE5-710A8F9F905D (resized).jpeg

#14453 11 months ago

Anyone else hit the scoop in meseeks mania and not get an eject, ball search etc? It's a fatal bug as it never ejects!

IMG_20210618_233755 (resized).jpgIMG_20210618_233759 (resized).jpgIMG_20210618_233806 (resized).jpg
#14454 11 months ago
Quoted from Penguindeity:

Anyone else hit the scoop in meseeks mania and not get an eject, ball search etc? It's a fatal bug as it never ejects

Nope, never had any non-ejects.

Check your scoop switches.

rd

#14455 11 months ago

I've had it twice in over 2000 games. It was during one of the multi balls, not sure it was Meeseeks, but either way, Eric knows about it and its hard to tell what causes it when there is so much going on.

#14456 11 months ago
Quoted from Calfdemon:

I've had it twice in over 2000 games. It was during one of the multi balls, not sure it was Meeseeks, but either way, Eric knows about it and its hard to tell what causes it when there is so much going on.

Indeed I have had it a few times too. Pretty rare, but I am not investigating mechanical issues related to this any more as it is determined as not a mechanical or wiring fault. I spent enough time chasing that rabbit hole and it went nowhere each time, but similarities with the game modes active. Game is fine, been hoping to record it happen for EP but the camera seems to scare it away Lol

One of the times I went to menu tests, to check on the switch and coil while in fault configuration. Switch edges show ball in scoop, then coil tests eject the ball without hesitation.

It is somehow code related.

#14457 11 months ago

I had the loss of sound effects bug and ball stuck in the scoop bug during the same game this week.

#14458 11 months ago

Hey fellow Rick and Morty's. I picked up bloodsucker #181 a few days ago. Bought it from a fellow Pinsider. Game was billed as "no issues" but after I got it home and set it up...I notice an issue with the ball launch wire form ramp lifting up and causing the ball to NOT fall into the playfield only to slide back down to the launch solenoid. The ball kicker sends it back up the ramp, and it may or may not make it to the playfield depending on if the wire form is lifting up. This will happen repeatedly and not every time but enough to piss you off. It did not happen when I test played the game, but I guess he musta smashed it down real good beforehand.
I've searched this thread for this issue, it doesn't seem common - just wondering if anybody else is having this happen? I'm posting some pictures, it looks like the previous owner was aware of this but didn't say anything or disclose at the time of sale. I lifted the PF last night to inspect and discovered the wire form under the play field had been molested to keep it from lifting... thus, l conclude the previous owner was aware of this. Such as pinball life...
I have an idea how to fix but I would like to see a picture of somebody else's wire form ramp under the playfield to see what it looks like from the factory.
Any assistance would be great!

IMG_20210618_204011__01 (resized).jpgIMG_20210619_094031__01__01 (resized).jpg

#14459 11 months ago
Quoted from Inferno:

Hey fellow Rick and Morty's. I picked up bloodsucker #181 a few days ago. Bought it from a fellow Pinsider. Game was billed as "no issues" but after I got it home and set it up...I notice an issue with the ball launch wire form ramp lifting up and causing the ball to NOT fall into the playfield only to slide back down to the launch solenoid. The ball kicker sends it back up the ramp, and it may or may not make it to the playfield depending on if the wire form is lifting up. This will happen repeatedly and not every time but enough to piss you off. It did not happen when I test played the game, but I guess he musta smashed it down real good beforehand.
I've searched this thread for this issue, it doesn't seem common - just wondering if anybody else is having this happen? I'm posting some pictures, it looks like the previous owner was aware of this but didn't say anything or disclose at the time of sale. I lifted the PF last night to inspect and discovered the wire form under the play field had been molested to keep it from lifting... thus, l conclude the previous owner was aware of this. Such as pinball life...
I have an idea how to fix but I would like to see a picture of somebody else's wire form ramp under the playfield to see what it looks like from the factory.
Any assistance would be great!
[quoted image][quoted image]

Problems with the ball launch wireform are pretty common. Pinball Life actually made a completely different replacement wireform to make the ball launches work better. It's not on his website, you have to email him for it because people were pissed he was selling something that made the ball launch work right that they felt should have been included with the pin, even though Terry doesn't own Spooky pinball and just sells pinball parts. This made no sense, but it's what happened. So he pulled the part from his site.

Maybe someone with the machine can give you tips on improving performance with the stock wireform, but issues with it are common.

#14460 11 months ago

Right ramp, left ramp, inner orbit, inner orbit, garage shot!

What a satisfying combo!

#14461 11 months ago

Buffalo Pinball is streaming their Bro, Do You Even Pinball? Show on a Rick and Morty at 4 PM est today.

#14462 11 months ago

I am having an issue with my machine in that when the game is first turned on, the balls have collected in the trough eject. The machine will say that balls are missing. You have to take the glass off the machine and use a magnetic wand to remove the balls from the eject and return them manually. It does not happen every time you turn on the machine. Could this be an intermittent opto failure?

Thanks

#14463 11 months ago
Quoted from Inferno:

Hey fellow Rick and Morty's. I picked up bloodsucker #181 a few days ago. Bought it from a fellow Pinsider. Game was billed as "no issues" but after I got it home and set it up...I notice an issue with the ball launch wire form ramp lifting up and causing the ball to NOT fall into the playfield only to slide back down to the launch solenoid. The ball kicker sends it back up the ramp, and it may or may not make it to the playfield depending on if the wire form is lifting up. This will happen repeatedly and not every time but enough to piss you off. It did not happen when I test played the game, but I guess he musta smashed it down real good beforehand.
I've searched this thread for this issue, it doesn't seem common - just wondering if anybody else is having this happen? I'm posting some pictures, it looks like the previous owner was aware of this but didn't say anything or disclose at the time of sale. I lifted the PF last night to inspect and discovered the wire form under the play field had been molested to keep it from lifting... thus, l conclude the previous owner was aware of this. Such as pinball life...
I have an idea how to fix but I would like to see a picture of somebody else's wire form ramp under the playfield to see what it looks like from the factory.
Any assistance would be great!
[quoted image][quoted image]

Believe it or not, that is how the ball launch was installed from Spooky. All of them were installed and then bent over like that.

Your best solution is to email Terry at Pinball Life and get one of his redesigned ball launch ramps (not on website). They are made (and installed) way better and work flawlessly.

#14464 11 months ago
Quoted from Penguindeity:

Anyone else hit the scoop in meseeks mania and not get an eject, ball search etc? It's a fatal bug as it never ejects!
[quoted image][quoted image][quoted image]

Yep, a couple of times. Can't remember whether Meseeks had been active but definitely multiball and I am fairly sure it was Roy mode

#14465 11 months ago

Anyone else’s magnet occasionally not activate when pressing the button?

It’s fully charged. I’ve checked the switch. I’ve even directly soldered the magnet wires bypassing the z-clip, which seemed to improve it, but didn’t completely eliminate it.

#14466 11 months ago

New to the club with # 492.
I have had it for 2 weeks now and love it.
Had an issue tonight. I lowered the flipper bushings and 2 games in , broke the ship. Well the bracket that holds the ship. Super bummed.
Any suggestions on how to prevent it again?
Any way to disable it for a fix?
Any help would be appreciated. Now I’m freaked out about playing it. It was a nightmare replacing the acrylic base with the space in the goodie bag.

Dana

#14467 11 months ago

Finally got to play Rick and morty for my first time . Ummm.. this game rocks !

#14468 11 months ago
Quoted from cooked71:

Anyone else’s magnet occasionally not activate when pressing the button?
It’s fully charged. I’ve checked the switch. I’ve even directly soldered the magnet wires bypassing the z-clip, which seemed to improve it, but didn’t completely eliminate it.

Are you 'sure' it's not activating? I swear mine does this sometimes, but hard to tell...

#14469 11 months ago
Quoted from Propsnsports:

New to the club with # 492.
I have had it for 2 weeks now and love it.
Had an issue tonight. I lowered the flipper bushings and 2 games in , broke the ship. Well the bracket that holds the ship. Super bummed.
Any suggestions on how to prevent it again?
Any way to disable it for a fix?
Any help would be appreciated. Now I’m freaked out about playing it. It was a nightmare replacing the acrylic base with the space in the goodie bag.
Dana

You have a few options.

One...they 'should' have sent you an extra bracket (assuming you are referring to the plastic hinge that moves).

Two, you can ask them to send you a replacement

Three, to help prevent it loosen the nuts some on the hinge and/or you can shorten the rod that moves the ship so it doesn't move as far - you can also just release the rod so it doesn't move - but there is a setting in the menu to not move the ship I think.

#14470 11 months ago

Yes they did and I replaced it. Just hoping there is a fix where it won’t happen again.
Dana

#14471 11 months ago
Quoted from Propsnsports:

Any suggestions on how to prevent it again?

Mine broke twice so I replaced the plastic with a metal flex plate. I think you can still buy them.

#14472 11 months ago

I will loosen the nuts. Metal plate would work.
D

#14473 11 months ago
Quoted from Propsnsports:

I will loosen the nuts. Metal plate would work.
D

send a PM to toyotaboy

He sells the metal bracket

E48BD602-B238-4597-BB71-FDCB5CCE5E4B (resized).png
#14474 11 months ago
Quoted from cooked71:

Anyone else’s magnet occasionally not activate when pressing the button?
It’s fully charged. I’ve checked the switch. I’ve even directly soldered the magnet wires bypassing the z-clip, which seemed to improve it, but didn’t completely eliminate it.

If your finger is on the flipper button at same time it will not activate the magnet

#14475 11 months ago
Quoted from northerndude:

If your finger is on the flipper button at same time it will not activate the magnet

Ah, ok, didn’t know that. Now that might be the reason. Will check it out tonight.

#14476 11 months ago
Quoted from northerndude:

If your finger is on the flipper button at same time it will not activate the magnet

Wonder if that’s intentional or a limitation of the system.

#14477 11 months ago
Quoted from cooked71:

Wonder if that’s intentional or a limitation of the system.

I think it's a limitation.

#14478 11 months ago
Quoted from cooked71:

Wonder if that’s intentional or a limitation of the system.

Mag circuit is tied to the flipper coil and will blow the fuse if both coils are fired is what I remember of the conversation. Limited via software iirc.

#14479 11 months ago

Regarding the magna save, also bare in mind that the music based adventures i.e Moonmen, Swifty, maybe another have few sound effects so the magna save doesn't make a noise when you operate it. This has caught me out a few times because I've thought the magna save isn't working when it actually is. I wish they would allow this particular sound effect during those adventures.

#14480 11 months ago

I do find the Magna save to be a bit weak though, my TOM would stop it in its tracks, with R&M it seems to have way less power...

#14481 11 months ago
Quoted from monkfe:

I do find the Magna save to be a bit weak though, my TOM would stop it in its tracks, with R&M it seems to have way less power...

More Charge = More Power

11
#14482 11 months ago
Quoted from monkfe:

I do find the Magna save to be a bit weak though, my TOM would stop it in its tracks, with R&M it seems to have way less power...

It’s not meant to stop it, you have to finesse it out of the lane, give it a tap,tap,tap. I can fling that ball clean over to the left flipper

#14483 11 months ago
Quoted from northerndude:

It’s not meant to stop it, you have to finesse it out of the lane, give it a tap,tap,tap. I can fling that ball clean over to the left flipper

This.. also you can't sit there and lay on the button. This is what my wife does and it's not how it works. You're supposed to tap it so the magnet pulses it in the opposite direction.

#14484 11 months ago
Quoted from toyotaboy:

also you can't sit there and lay on the button. This is what my wife does

This might be the funniest/best thing I read all day.

#14485 11 months ago

My game says to install 4 balls, but it came with 5. The lockdown bracket instructs to install 1 extra ball in 2nd trough. Where is that? Any clarification would be appreciated

28398FA7-5409-429B-986E-7C7823B1245C (resized).jpegD677E69A-30A3-49B9-AFBF-3ECF8069D459 (resized).jpeg
#14486 11 months ago
Quoted from darkryder:

My game says to install 4 balls, but it came with 5. The lockdown bracket instructs to install 1 extra ball in 2nd trough. Where is that? Any clarification would be appreciated
[quoted image][quoted image]

4 balls in drain, put 5th up in the garage hole.

#14487 11 months ago

Many moons ago there was talk of a microverse mod for the coin door dollar bill slot.

has anyone heard anything about that?

#14488 11 months ago
Quoted from Pinmeister:

I am having an issue with my machine in that when the game is first turned on, the balls have collected in the trough eject. The machine will say that balls are missing. You have to take the glass off the machine and use a magnetic wand to remove the balls from the eject and return them manually. It does not happen every time you turn on the machine. Could this be an intermittent opto failure?
Thanks

Whoops, this doesn't do any good sitting in the compose box, hit Send Post, Dan!

Not optos, the trough uses switches. Use switch test to make sure they all activate with balls sitting on them. On my game I had to adjust the switches to make them register more reliably. This was true of the other places where the ball sits on a switch as well. I was getting drains not registering, switch test told me no ball was on the switch when there was! Just bend them a bit so the ball activates them a skosh harder.

#14489 11 months ago

So how is flipper strength increased? I'm used to adjusting it on stern machines as a number but am having trouble finding it on this spooky machine. Thanks

#14490 11 months ago
Quoted from Penguindeity:

Anyone else hit the scoop in meseeks mania and not get an eject, ball search etc? It's a fatal bug as it never ejects!

I had this happen once.

#14491 11 months ago

I need to replace the plastic spring under the ship and was hoping someone could give me some tips / answer a couple of questions about everything I need to remove.

Am I right that I will need to remove both ramps, then the house, then the horseshoe plastic to replace the ship plastic?

Are the only screws mounting the left ramp the two at the entrance? Are there any more for the right ramp other than the two at the entrance and the pink post at the bottom?

Are the screws at ramp entrances screwed into the playfield? Or are the bolts connected through the back of the playfield?

Will I need to remove the ramp optos from the ramps or will I be able to disconnect them and thread the cables through the playfield?

Are the screws/bolts mounting the horseshoe plastic to the posts all they way through the playfield? I’m wondering if to remove the horseshoe plastic if I will be taking the posts off the playfield or if the plastic can be removed leaving the posts in-place in the playfield.

Any other tips for those who have replaced their spaceship plastic?

#14492 11 months ago

Ramps come out super easy.
You should be able to leave all wires connected and just use some towels to keep them out of the way.
No more screws besides the ones you mentioned in the ramps.
All plastic screws for the horshoe are nuts or threaded posts. No post removal required that I recall.
Pretty easy to work on the topside this game.

#14493 11 months ago
Quoted from guitarded:

Buffalo Pinball is streaming their Bro, Do You Even Pinball? Show on a Rick and Morty at 4 PM est today.

Thanks for sharing! This was my first time playing R&M (thanks, pandemic), and I had a blast. It's now on my Pinside wish list

Here's the stream if you missed it. I had to clip out the "Goodbye Moonmen" parts because YouTube flagged them for copyright claims (thanks, YouTube!), but everything else is there:

#14494 11 months ago

Anyone know how to adjust the flipper strength

#14495 11 months ago

Sunsfan23

Home -> Settings -> Machine (Coils)

30 is the default pulse setting. Lowering this weakens and raising it strengthens.

pasted_image (resized).png
#14496 11 months ago
Quoted from Jigz:

Sunsfan23
Home -> Settings -> Machine (Coils)
30 is the default pulse setting. Lowering this weakens and raising it strengthens.[quoted image]

awesome thanks man!

#14497 11 months ago

Anyone know how to remove the house?

#14498 11 months ago
Quoted from SuperPinball:

Anyone know how to remove the house?

Screws on metal clips on both sides of the house and one painted screw on the roofline where it meets the backboard.

I think there might be one wire that requires unplugging and snaking through the backboard, but it is obvious and easily done.

#14499 11 months ago

I over tightened the flipper bolt and grooved the post. Can anyone tell me which flipper fits rick and morty. Pinball life doesnt describe any of the flipper/bat assemblies as fitting spooky or rick and morty specifically. Thanks

#14500 11 months ago
Quoted from Llabnip1972:

I over tightened the flipper bolt and grooved the post. Can anyone tell me which flipper fits rick and morty. Pinball life doesnt describe any of the flipper/bat assemblies as fitting spooky or rick and morty specifically. Thanks

Iirc - they are B/W flipper assemblies.

Promoted items from the Pinside Marketplace
$ 19.50
$ 32.00
Playfield - Other
Pinball Mod Co.
$ 15.00
Playfield - Toys/Add-ons
Game Room Info Shop
$ 35.00
Playfield - Toys/Add-ons
The MOD Couple
$ 399.00
Gameroom - Decorations
Bent Mods
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
$ 60.00
Playfield - Other
NinjaCamp Mods
$ 85.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 99.95
Cabinet - Shooter Rods
Super Skill Shot Shop
There are 17,677 posts in this topic. You are on page 290 of 354.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!