(Topic ID: 301823)

Avengers Premium Issues

By SilverballGamer

54 days ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 32 days ago by PaulRiccardi
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    BFECFA17-D451-4ED9-A92A-BA8E090E239A (resized).jpeg

    #1 54 days ago

    Hello all, early this year I bought an Avengers Premium. However, I have been experiencing a few issues with it, and I was hoping that someone on here might know how to figure some of these out.

    1. The portal lock opto is inconsistent. This is probably my biggest issue, as sometimes I will be hitting the shot up to 4-5 times, and it will just keep going straight through the subway, rejecting it. I’m assuming it’s a bad opto, and if so, is it a specific kind? And where can I get it?

    2. The Avengers tower magnetic keeps holding ball after it’s supposed to let go sometimes. Instead of doing it automatically, you have to press a flipper button for it to let go. I feel like this might be an easy fix, however, I don’t know how to solve it.

    3. The Auto-Plunge is often too weak to get up the right loop/ramp. If you are wondering, it is set to max power, so the problem lies somewhere else.

    That’s all. Any answers or just interest is greatly appreciated. Thank you, and have a great day.

    #2 54 days ago

    I can help u with #3.. look to see if the ball is sitting flat on both sides of the auto plunge. If not I think it doesn't hit the ball clean and rattles and spins out. I pulled mine out, tapped it will a hammer careful to close the gap. Ball sits flush. Makes it well over 95% of the time now.

    #3 53 days ago

    Thank you for the response! Attached is how the ball sits on the auto plunge. Is it bent in the way you imagine? And if so, how should I hammer it?Thank you!

    BFECFA17-D451-4ED9-A92A-BA8E090E239A (resized).jpeg
    #4 52 days ago

    With a C-clamp you'll have more control, IMO

    #5 51 days ago

    I think I’ve solved the auto plunge issue: it just needed it’s power to be lowered. Still not sure about the other two issues though.

    2 weeks later
    #6 32 days ago

    I’m having a strange issue with mine. Normally it registers when a ball drains. But when I’m in a gem quest or multi ball It doesn’t. So I lose my ball and the quest continues. I have to open the coin door and manually pop a ball out. Anyone else having this issue?

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside