(Topic ID: 8686)

Auxiliary power driver board fuse problem


By Brandon

8 years ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 8 years ago by johnwartjr
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider Brandon.
Click here to go back to viewing the entire thread.

#1 8 years ago

Hi,

I have a Whirlwind system 11b machine that uses a Aux power driver board and I now have problems with fuses being blow on powering up the machine. Fuses at location F1 and F4 blow immediately using 4 amp 250v buss fuses. This machine used to boot up with no problem in the past using these 250V 4 amp fuses. Have replaced with two brand new 4 amp fuses with the same results, blown. Is there some kind of other problem that could cause this that I need to check, am I using the proper amp fuses?

Thanks greatly for your help!
Brandon

Promoted items from the Pinside Marketplace
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 14.50
Electronics
PinballElectronics.com
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 16.50
Lighting - Led
Lermods
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 30.00
Playfield - Decals
Metal-Mods

You're currently viewing posts by Pinsider Brandon.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside