Attack From Mars Remake (AFMr) Technical Thread

(Topic ID: 206552)

Attack From Mars Remake (AFMr) Technical Thread


By chrisnack

7 months ago



Topic Stats

  • 276 posts
  • 61 Pinsiders participating
  • Latest reply 4 days ago by HB_GAMER
  • Topic is favorited by 76 Pinsiders

You

Linked Games

Topic Gallery

There have been 38 images uploaded to this topic. (View topic image gallery).

75d45f289722308c595462983b177579ec5f8785 (resized).jpg
IMG_20180614_185018144 (resized).jpg
IMG_20180615_151649649 (resized).jpg
IMG_20180615_151643907 (resized).jpg
2018-04-15 16.53.51 (resized).jpg
9E4F02E3-55FC-42F0-B340-153780823261 (resized).jpeg
0DE14DB6-2F47-43B4-858B-B639AEE8D13A (resized).jpeg
DSC00481 (resized).JPG
DSC00480 (resized).JPG
20180317_233451 (resized).jpg
20180317_233441 (resized).jpg
AFMRleftHi (resized).jpg
AFMRleftNormal (resized).jpg
DSC00495 (resized).JPG
DSC00494 (resized).JPG
amfmrtopperboard2 (resized).jpg

There are 277 posts in this topic. You are on page 1 of 6.
#1 7 months ago

I'm personally tired of reading pages and pages of random discussion. I want to know about communications from CGC and other technical issues people are having and how they are being solved.

So that being said, this thread is for technical issues/solutions. No random discussions, no hey why isn't the LE topper sold separately etc.

CGC Support
-https://chicagogamingcompany.freshdesk.com/support/login

Latest software/firmware. Version is currently 1.0.0
-http://www.chicago-gaming.com/afm_update.php

Known issues:
Flipper strength - needs to be set to default (PIC 1.0) per CGC otherwise board issues
-CGC will be sending out a new PIC along with instructions and puller, in final stages of testing
-UPDATE: PICS are shipping to dealers and some dealers are shipping out already (1/31/2018)
-https://pinside.com/pinball/forum/topic/cgc-pinball-production-update/page/28#post-4168541
-PIC 2.0 addresses the issues and has been reported to work for everyone (myself included)
Shooter plunger/path -
-PDF available here: https://pinside.com/pinball/forum/topic/attack-from-mars-remake-afmr-owners-club/page/49#post-4158609

Topper wiring - some recent deliveries the wiring is very tight/short. I personally had to move the topper board to get everything plugged in correctly.
-Extra pin block, pin can be cut or block removed

Lock eject - takes multiple attempts to eject ball onto ramp
-CGC has video on how to bend the coil bracket

Topper - some are reporting topper isn't working 100%, believe this has been resolved by wiring or board replacement for most

#2 7 months ago

Shooter issue:

Quoted from CGC_DougS:

Hello Everyone!
This year blew by for me and I can’t believe we are knocking on the door of Christmas / New Year’s 2018. We accomplished many great things at CGC this year. Most notably, I believe we are assembling / shipping an amazing product and we are hitting the promised timelines that we have made. The past many few weeks have insane with all that we have been shipping, considering all the various products that we produce.
Update:
1. Overall our games are performing amazingly. However, there has been a small number of reported concerns, on very recently produced games, of the balls trajectory as is comes out of the shooter lane. This really came to light as people opened tickets and we were able to piece to together the problem. By Monday morning our engineering and production team were working on a fix. Let me be clear, there are no failures; rather, the ball on these games comes out of the shooter lane and does not properly travel to the gate or around the orbiter loop. As mention several times, we work very methodically here at CGC. It might take a few days before we release the correction. Regardless, it will be an easy correction and we will post it on our service portal.
2. In the week of Christmas, we are scheduled to switch over in building out a handful of overseas containers. Shortly after the first of the year, we will return to North American production. The remainder of the LE’s will be produced and then it will be all SE’s and CE’s to follow.
3. By February we will have completed nearly 1,500 AFMR games, and with then return back to another small run of MMR.
4. We are still working on the MMR display/speaker panel upgrade. It’s not as simple as one might think and in order to it correctly, it going to take some time. More on this to come in 2018.
5. We will unveil Pin #3 at the Texas Pinball Festival in March.
From your friends at CGC, we wish you all a great holiday season with your families.
Regards,
Doug Skor

Flipper issue:

Quoted from CGC_DougS:

Dear CGC customers:
Let me begin by wishing you all a very happy, successful New Year.
AFMR ONLY:
As I mentioned to a customer on the phone today, when it comes to service, we don’t necessarily have all the answers. As we move forward, it takes a collection of service tickets before we can piece together a trend that then leads to a resolution. In all cases, we at CGC are committed to correcting these concerns. We discovered a software glitch in the PIC that controls our solenoid driver board. While you might try setting down the power on your flippers, the fact remains that these settings are currently having little to no change on the flippers. Our software team has already corrected the problem, and we are testing the new software with a few select customers. Before we do any massive distribution, we want to thoroughly test the update. This might take a few more weeks, and we ask that you be patient as we start to distribute the PIC’s. In the meantime, there will be NO need for you to enter a service ticket at this time in order to obtain the update. Please wait for further instructions. However, we are going to ask that all customers immediately return their software settings to DEFAULT. We have found that if you are using the lower range of settings that it is likely that you will blow one of the FET’s on the Solenoid Driver Board.
More to come.
Thank you!
Doug Skor

#3 7 months ago

It would be helpful to know how many people are having the flipper, shooter and topper issues. And if and what they did to fix them.
I have never had a topper issue or a coil adjustment issue. Mine machine is on -2 where it has been since day 1.

#4 7 months ago
Quoted from chrisnack:

I want to know about communications from CGC and other technical issues people are having and how they are being solved.

The communications for a small issue I have had with CGC have been outstanding!

#5 7 months ago
Quoted from whthrs166:

It would helpful to know how many people are having the flipper, shooter and topper issues. And if and what they did to fix them.
I have never had a topper issue or a coil adjustment issue. Mine machine is on -2 where it has been since day 1.

I’m on -6 without issues and probably a couple hundred plays. It definitely made a difference turning them down.

Other than the short wiring I didn’t have any issues with topper.

My shooter lane is good 98% of the time.

#6 7 months ago

Aside from occasional crazy airballs, I am having no issues (AFMr-0196 Aug 2017).

I had the flippers turned down to -8, but returned to DEFAULT at CGC recommendation. I am not clear I actually noticed any difference, which seems to align with their finding.

My Issues (SOLVED):

(1) I did have an issue couple months ago - one of the topper saucer flashers was stuck ON (dimly) when supposed to be OFF. CGC promptly diagnosed and replaced the topper controller. All is good again.

(2) More recently, I was seeing a "Diverter Stuck Open" error message. Lloyd assisted and suggested playing thru to reset the switch counters - did not help. I diagnosed and re-flowed the coil solder joints, and reset the Connector/Pins on J120. Problem solved.

#7 7 months ago
Quoted from markp99:

(AFMr-0196 Aug 2017).

Yeah my game is also an early build. 8-1-2017

#8 7 months ago

Very much appreciate you starting this thread as the other one had gone off the rails, in my opinion.
I’ve had a few issues with my LE, but Doug has been in touch with me and I feel confident they’ll be fixed. I’ll post the issues and corresponding fixes once I have them ironed out.
Thanks again for starting this thread.
Loving my AFM remake!

#9 7 months ago
Quoted from CyberNinja24:

Very much appreciate you starting this thread as the other one had gone off the rails, in my opinion.
I’ve had a few issues with my LE, but Doug has been in touch with me and I feel confident they’ll be fixed. I’ll post the issues and corresponding fixes once I have them ironed out.
Thanks again for starting this thread.
Loving my AFM remake!

Flippers locking up also? (sorry, I had to pry)

#10 7 months ago

Issues with mine:
1. Shooter Lane issue, ticket raised and resolved following ramp bending procedure and centering plunger on ball.
2. Left popper not consistent, sometime takes 1 attempt to eject ball, more often 2, 3 or 4 and occasionally, 5, 6, or 7 times, ticket raised and still open.
3. Flipper strength, too strong, resulting in numerous air balls, awaiting firmware upgrade.
4. SOL ejecting straight down middle intermittently

Very happy with the game and confident issues will be resolved soon.

#11 7 months ago

Plunger issue.
Ball flying off the tracks on lock shot coming back to right flipper.
Play field not sitting perfectly in cabinet.
Base of speaker panel seems lose at the base.

I hesitate to list these things as it could be operator error

Hasn’t stopped me from putting up an 18B score. Such a blast!!

#12 7 months ago

Thanks for starting this thread.

1. Shooter Lane issue, ticket raised and resolved 90% following ramp bending procedure and centering plunger on ball.
2. Left popper not consistent, sometimes takes 1 attempt to eject ball, most times 2, occasionally 3.
3. Flipper strength, too strong, awaiting firmware upgrade. Left flipper does not feel as responsive as right flipper for tap passing.
4. Playfield dimples very easily. (possibly due to strong flipper strength) - Playing more to cover entire playfield.
5. Balls occasionally go into outlanes when coming down the wire forms. Adjusted this and fixed it by moving left wire form slightly to the right, and right wire form slightly to the left.
6. Perfect light lock shot will occasionally cause the ball to go so fast around the wire form that it flies off the wire form into outlane, inlane, or shooter lane. (reducing flipper strength to around -4 to -6 helps. Waiting on firmware to keep these settings.
7. Shooting cow ramp seems slightly clunky when ball rounds the corner of the ramp onto the wire form.

Having a blast with the game and attacking those nasty Martians. Support from CGC has been very responsive.

#13 7 months ago

I have the SE

My only issues are the flippers are way too strong now that I went back to default per CGC and the left popper takes 2 pops every 25 or so times. My shooter lane has worked flawlessly and we go for the super skill shot attempt 99% of the time. We have a total of 1031 plays.

#14 7 months ago
Quoted from whthrs166:

It would be helpful to know how many people are having the flipper, shooter and topper issues. And if and what they did to fix them.

My game was built on 12/6 and received on 12/11. Flippers were wildly strong...game played awful. Dialed the flippers down to -23 and it was more playable (but still not great). Shooter lane was wonky and had some success adjusting it, however it was never 100%.

On 12/15 (game #19), the right flipper died resulting in a blown Solenoid board. CGC sent me a new board, flipper coils and harness. Arrived 7 days later, despite being promised 2-day shipping.

While installing the coils/harness, noticed the coil sleeve was melted into the right flipper coil housing (common when bad things happen). Unfortunately, didn't have a spare coil sleeve. Drove to a pinball buddy to snarf a coil sleeve.

After installing the new board on 12/22, noticed topper functions weren’t working (color changing LED’s and martian movement). J109 on the new solenoid board, used to power the topper isn’t working.

On 12/24 (game #25), the left flipper died, resulting in a blown Solenoid board.

Game over...by far, the most frustrating NIB experience I've ever encountered (despite CGC being responsive to my obstacles). Instead of enjoying my new game for the holidays, it was out of commission and required constant care. Oh well.

snaroff

#15 7 months ago
Quoted from snaroff:

My game was built on 12/6 and received on 12/11. Flippers were wildly strong...game played awful. Dialed the flippers down to -23 and it was more playable (but still not great). Shooter lane was wonky and had some success adjusting it, however it was never 100%.
On 12/15 (game #19), the right flipper died resulting in a blown Solenoid board. CGC sent me a new board, flipper coils and harness. Arrived 7 days later, despite being promised 2-day shipping.
While installing the coils/harness, noticed the coil sleeve was melted into the right flipper coil housing (common when bad things happen). Unfortunately, didn't have a spare coil sleeve. Drove to a pinball buddy to snarf a coil sleeve.
After installing the new board on 12/22, noticed topper functions weren’t working (color changing LED’s and martian movement). J109 on the new solenoid board, used to power the topper isn’t working.
On 12/24 (game #25), the left flipper died, resulting in a blown Solenoid board.
Game over...by far, the most frustrating NIB experience I've ever encountered (despite CGC being responsive to my obstacles). Instead of enjoying my new game for the holidays, it was out of commission and required constant care. Oh well.
snaroff

Our Left flipper died today. CGC have already answered our ticket and are sending out a new Solenoid board. It would have been nice to read this thread a few hours ago. We had our flipper strength at -23 as I do not like air balls. Our machine is out of action until we get the new board. CGC have also realised that there are software issues and are working towards a resolution. It is very disappointing that we have a new machine and we cannot play it. This has happened to us a few times now. Patience is the key.

#16 7 months ago
Quoted from pinballaddicted:

This has happened to us a few times now. Patience is the key.

The flipper died on you a few times?

#17 7 months ago

I had issues with my flipper dying on me. Was sent a new board and this fixed the problem. I had my flippers set to -20 and had a hundred plays with no issues. Not playing my machine until the software fix comes. When dialing my flipper strength back to default the game is unplayable(too many air balls, ball flying off the lock wireform).

Customer support has been great but still frustrating that I can’t play my game now.

#18 7 months ago


Quoted from snaroff:My game was built on 12/6 and received on 12/11. Flippers were wildly strong...game played awful. Dialed the flippers down to -23 and it was more playable (but still not great). Shooter lane was wonky and had some success adjusting it, however it was never 100%.
On 12/15 (game #19), the right flipper died resulting in a blown Solenoid board. CGC sent me a new board, flipper coils and harness. Arrived 7 days later, despite being promised 2-day shipping.
While installing the coils/harness, noticed the coil sleeve was melted into the right flipper coil housing (common when bad things happen). Unfortunately, didn't have a spare coil sleeve. Drove to a pinball buddy to snarf a coil sleeve.
After installing the new board on 12/22, noticed topper functions weren’t working (color changing LED’s and martian moveme

Wow! That is..... Wow! Thank you for posting this. There apparently is a problem with new Solenoid boards based on what you have said here. They are not enabling the topper. Good Info. Well Done!

#19 7 months ago

This may sound like a dumb question but............. How many of these flipper problems are on the LEs . Has anyone had issues with the standard editions ?

Shooter lane...... solved 100% by me and fires the ball like a rocket around the loop
Had a bad LED on a board ........ Doug handled and sent me one out ASAP.
Flipper strength to strong ... dialed back but waiting for software upgrade.

No other issues otherwise and what a quality product

Lets not forget when Stern put out Spike they were blowing node boards on every other game till they had it right.

#20 7 months ago
Quoted from PinLen83:

The flipper died on you a few times?

No. Only once on AFMrLE and now machine has no left flipper so is unplayable. We have previously purchased a brand new machine and cannot play it because there is an issue with the machine in the first few days. TFLE, AVLE, GBLE and now AFMrLE.

#21 7 months ago
Quoted from whthrs166:

Wow! That is..... Wow! Thank you for posting this. There apparently is a problem with new Solenoid boards based on what you have said here. They are not enabling the topper. Good Info. Well Done!

It's totally unclear if it's the Solenoid boards. I guess it's conceivable I happened to get 2 bad boards, but I'm skeptical (since many other folks are blowing solenoid boards). You'd think the 2nd board would have received testing? Again, J109 was DOA.

My gut says it's something upstream that's zapping the boards. As I've said in other posts, why do so many folks have to dial down the flippers to -23? Makes no sense. The power management just seems wonky. During the debug process, CGC questioned my AC voltage which I proved was spot-on using a cool measuring device I posted about (116-120, depending on the time of day).

snaroff

-1
#22 7 months ago

Out of the box my topper has never worked. No city lights, no martian motor or interaction with game. Still waiting for a hopeful solution to show up. CGC has changed their mind three times on what to send out to try to resolve this. No blown solenoid boards here.

Shooter lane issue maybe 25-35% of shots. Sounds like people are solving this so about to start reading up.

Have a few consistent minor issues like ball flying off wire into outlanes, but that should be a matter of slightly bending or re-positioning wire forms.

#23 7 months ago
Quoted from snaroff:

totally unclear if it's the Solenoid boards. I guess it's conceivable I happened to get 2 bad boards, but I'm skeptical (since many other folks are blowing solenoid boards). You'd think the 2nd board would have received testing? Again, J109 was DOA.
My gut says it's something upstream that's zapping the boards. As I've said in other posts, why do so many folks have to dial down the flippers to -23? Makes no sense. The power management just seems wonky. During the debug process, CGC questioned my AC voltage which I proved was spot-on using a cool measuring device I posted about (116-120, depending on the time

It will be really interesting to see how they get you squared away. Please keep us updated!

#24 7 months ago
Quoted from IonRay:

Have a few consistent minor issues like ball flying off wire into outlanes, but that should be a matter of slightly bending or re-positioning wire forms.

The wireforms shouldn't need to be bent or re-positioned to keep balls from flying off. This design has been battle tested for years. If balls are flying off the wireforms, it's because the flippers are too strong.

snaroff

#25 7 months ago

lights, no martian motor or interaction with game. Still waiting for a hopeful solution to show up. CGC has changed their mind three times on what to send out to try to resolve this. No blown solenoid boards here.
Shooter lane issue maybe 25-35% of shots. Sounds like people are solving this so about to start reading up.
Have a few consistent minor issues like ball flying off wire into outlanes, but that should be a matter of slightly bending or re-positioning wire forms.

I think we also need to keep in mind that CGC Pinball is a new company and they are learning as they go along too.

#26 7 months ago

Sucks to see some of the issues but it still seems to be a small percentage overall.

If anyone has the post for the shooter lane please post/link here. I’ll look for it later if I can.

Current firmware/software is still 1.0.0 I believe as well. I’ll update the first post with that and a link to the software page. Really want to have a kind of master post with fixes listed. I’ve seen that on other forums for other things and it works well.

#27 7 months ago

You're all not alone in the flipper debacle. I too had a left, and right flipper go dead on me. Simultaneously.

Cats out of the bag now. I'll post up about my experience once it comes to a conclusion. For now, I will leave emotions out of it, and let the chips fall where they may.

#28 7 months ago
Quoted from chrisnack:

Sucks to see some of the issues but it still seems to be a small percentage overall.
If anyone has the post for the shooter lane please post/link here. I’ll look for it later if I can.
Current firmware/software is still 1.0.0 I believe as well. I’ll update the first post with that and a link to the software page. Really want to have a kind of master post with fixes listed. I’ve seen that on other forums for other things and it works well.

I believe we are about to find out exactly how "small of a percentage" this is, very shortly.

#29 7 months ago

Right wireform had to be replaced due to "kink" throwing ball off mid wireform.

Stuck right flipper (blown driver board), thinking this was due to constant messing around with flipper power (reducing power)

The flippers are now on default and I can't tell a difference between my -23 power setting.

I've had no issues with the super skill shot (has worked 100% of the time) or kickouts

Awaiting software update

Classic model with color screen and RGB main saucer.

#30 7 months ago

I’ve had my SE since July and have had no flipper problems. Was running at -18. I have close to 800 games on it. Turned it back to default for now. I have the same shooter problem as most everyone else. My SOL delivers the ball back to the left return lane instead of the left flipper, so I turned the coil power down. Sometimes it hits the left flipper, sometimes not.

#31 7 months ago

I have had my LE since July and have not had any issues with it; the only modifications I did was to turn down the intensity of the lights as they were a little bright for me and weakened the flippers slightly. It’s a beautiful game that I’m very happy with.

#32 7 months ago

1. Ball launch issue - awaiting CGC solution or will try ramp bend (thanks to those for posting the fixes). Plunger is centered side to side but hitting high. For temp solution turned down plunger strength to min and shimmed ramp with 2 washers and launch makes it 95% of time but ball just goes in left lane or maybe one bounce and in right but was driving me nuts having it come out side most of the time.
2. Topper Martian stopped bouncing - all other functions worked. 3A fuse was blown - changed out and it works.

Great CS!

#33 7 months ago

What’s wrong with this picture?

A51C5452-073A-4F89-999C-D94E64614DB1 (resized).jpeg

#34 7 months ago

I looked underneath the pf and this is what I saw.

9855017B-998B-4878-9B05-B2D3804FD07E (resized).jpeg

A6293C0F-531C-4EF8-9086-860018962FA7 (resized).jpeg

#35 7 months ago

The coil stop just fell off. I decided to put a little blue medium strength lock tite on the screws so this doesn’t happen again. I figured I’d put some on the screws of the right flipper too but when I took those screws off I discovered they already put blue thread lock on those screws but not on the left flipper screws, WTF? Oh well, it’s working fine now. Oh I do have the shooter lane problem though.

#36 7 months ago

I have an LE since 1 month ago.

1. Launch issues- I have adjusted/bent ball guide/ramp and centered plunger, but still 90% of balls made super skill shot, 5% get to top but won't go around and 5% don't make it to top. I have taken slo-mos of the ball being launched and every time the ball hits the metal ramp it bounces and starts moving side to side. If ball stays to the right it ends up doing fine. If ball leaves guide/metal ramp to the left it will hit the right side of right ramp and come back down. It is random how the ball moves once it hits the ramp. I believe the only pure fix is reshaping the ramp/ball guide somehow so the ball comes off it reliably the same way every time.
2. Left popper not working perfectly. At one point, it took ball 4-5 attempts to come out. I did tighten the long hexagonal metal piece that black popper sits next to. Now, 5% of time it takes two attempts for ball to come out.
3. No flipper issues, but I never felt need to adjust flipper strength.
4. No topper problems, but on installation felt the wiring was short and had to really stretch wiring to make it work.

#37 7 months ago

I've had my LE for about a month now and have experienced many of the same issues everyone else is seeing.

1. Shooter issue was fixed via the ramp bend. I'm on default power and have not had a failure since the fix was implemented. Prior to the fix maybe only 80% were successful. Shooter alignment did not require adjustment.

2. Left pop takes sometimes up to 5 attempts to eject. CGC asked me to bend the assembly under the playfield which worked for about 15 games then returned. I have noticed that many failures occur when the lock diverter is open. After two eject failures the diverter closes automatically and then the 3rd eject usually is successful. Not sure if that's just a coincidence but it's been a repeated observation. CGC still working issue.

3. Ball falls off right ramp down the outlane on high speed lock initialization shots. Perhaps can be addressed when we're allowed to turn down flipper power.

4. Topper wiring was very tight, could have used an extra inch! Wiring instructions could be enhanced a bit, fairly intuitive but seeing clear instructions to validate intuition would be nice (removing the plug for example)

5. Recent development on the shooter lane gate before the pop bumpers staying open allowing a non super skill shot to exit back down the lane missing the pop bumpers. Should be an easy adjustment next time the glass is off but haven't taken a look yet.

6. Recent development of the SOL eject heading SDTM. Normal eject typically hits a small range on the left flipper, but maybe once every 10 games a weak one comes out and drains. I'll keep an eye on it but see others posting a similar issue.

7. Too addicting, my other pins are getting jealous!!

#38 7 months ago

I've got a newly built (December 17') SE with the following issues on an open ticket:

-Skill shot on launch not making orbit. Have since bent ramp and realigned plunger, now about 90% working.
-Numerous air balls and a majority of the lock shots were jumping out of the right return and either draining or landing in the launch lane. Flipper strength does not significantly change these issues, and I see no apparent difference in results with different flipper settings. Have since set it back to default and await a fix.
-Drop target had a downward tilt to the right when down, also when up. Tweaked the adjustment screws from the underside to fix the tilt when down, but it still has a tilt when it's up. Functions fine, just looks off. From my newbie perspective, the black plastic pieces that make up this mechanism have too much slop between them.

#39 7 months ago

Why on earth do they keep suggesting to bend things...shouldn't they be sending out replacement parts instead of having us rig it?

#40 7 months ago
Quoted from abagwell:

Why on earth do they keep suggesting to bend things...shouldn't they be sending out replacement parts instead of having us rig it?

We have been bending things in pinball ever since the machines were invented. Bending is part of pinball and dialling a machine in! Each machine is hand made so therefore each machine is different.

#41 7 months ago

Launch issues: Try this its three for three but no promise's

1) Make sure your ramp is bent correctly like CGC says.

2) This worked for me and others, mines 99% now. ( dont want to say 100% and jinx it because a misfire can always happen and this is NOT CGC approved and you still need to adjust your shooter as best as you can )

Remove jump ramp and use a piece of 1" x 1/2 inch double sided tape. Place the tape on the ramp flap starting right where the ramp meets the flap edge . ( Put the 1" side along that edge where they meet. )

Place ramp back on the game being careful not to let the tape touch until its in position and press down.

When looking at the game tighten the right side screw down untill its snugged down, then tighten the left side screw WATCHING THE CENTER of the jump ramp closely. When you see it start to dip just slightly On the ( watch the left edge ) back off a just a hair.

Turn your setting to MAX and try. What I think it may be doing is when you tighten the left screw down its causing a dip in the ramp causing it to be steeper and lean to the left.

Then tightening sequence is MOST important but being sure the game is level and at the recommended pitch is also very important.

#42 7 months ago

I think this thread will be very helpful. Thanks for starting it. My LE was built 12-21-17. I just received it yesterday. I don't know the in and outs of this game only playing it and loving it a limited number of times I've come across it so there might be things I don't even realize are wrong. My pinball repair skills are limited but I realize I have to learn. I haven't tried fixing anything yet but will when I have more time. Anyway...

1. Topper wires very short. Why? I eventually got it through the top whole but it was more difficult than it needed to be. Topper holes didn't line up until the back part was also loosened.

2. Topper not working. Only has red eyes and light under Martian working. Saucer lights next to Martian light one upon power up then not again. Nothing else works. Ticket to CGC submitted last night.

3. Super skill shot fails to make it around almost every time and will dribble down. Regular launch usually makes it to the normal skill shot but not always.

4. Quite a few air balls. Will often fly off right wireform and lose down the side.

5. Left flipper drooping a bit.

6. Also the latch which keeps the bar(?) on preventing keeps the glass from sliding
off is wonky. I've never had one so difficult to lock in place. I'll have to figure out how that mechanism works and adjust it.

#43 7 months ago

+1 to Sol shooting sdtm randomly
+1 for left upkicker to left rail taking 3-4 attempts every other time
+1 for launch not making it all the way around about 1 in 5

#44 7 months ago

Has CGC released instructions for the shooter lane issues? Or are people just bending based on others are doing and what seems to be working?

Update first post with links to support and latest software.

#45 7 months ago

Lloyd sent me a .PDF with a template for the bend angle after I opened a ticket yesterday. I looked to see if they had posted it but didn't see it anywhere on their site.

#46 7 months ago
Quoted from PDFVT:

Lloyd sent me a .PDF with a template for the bend angle after I opened a ticket yesterday. I looked to see if they had posted it but didn't see it anywhere on their site.

Roger. I heard they were putting something together, wasn't sure if it was going to be public or only if you sent in a ticket.

I just put in a ticket with my list of issues, the more they have report the better.

#47 7 months ago
Quoted from Miknan:

I think this thread will be very helpful. Thanks for starting it. My LE was built 12-21-17. I just received it yesterday. I don't know the in and outs of this game only playing it and loving it a limited number of times I've come across it so there might be things I don't even realize are wrong. My pinball repair skills are limited but I realize I have to learn. I haven't tried fixing anything yet but will when I have more time. Anyway...
1. Topper wires very short. Why? I eventually got it through the top whole but it was more difficult than it needed to be. Topper holes didn't line up until the back part was also loosened.
2. Topper not working. Only has red eyes and light under Martian working. Saucer lights next to Martian light one upon power up then not again. Nothing else works. Ticket to CGC submitted last night.
3. Super skill shot fails to make it around almost every time and will dribble down. Regular launch usually makes it to the normal skill shot but not always.
4. Quite a few air balls. Will often fly off right wireform and lose down the side.
5. Left flipper drooping a bit.
6. Also the latch which keeps the bar(?) on preventing keeps the glass from sliding
off is wonky. I've never had one so difficult to lock in place. I'll have to figure out how that mechanism works and adjust it.

Put in my ticket for the Topper and ball launch issues last night. Already got back to me. Said they’ve seen this issue on recent machines and are sending me a new PIC 2.0, whatever that is. Also sent PDF on ball alignment and bending that metal part.

#48 7 months ago

I think the topper shouldn't be for sale to non-LE members.

That was a great idea starting another thread

#49 7 months ago

Can someone post the documents for the ball allignment and shooter lane fix?

Promoted items from the Pinside Marketplace
€ 3.70
From: $ 6,499.00
Pinball Machine
Flip N Out Pinball
7,299
Machine - For Sale
West Chicago, IL
From: $ 6,499.00
Pinball Machine
Flip N Out Pinball
Wanted
Machine - Wanted
Sheridan, WY
$ 7,299.00
Pinball Machine
Flip N Out Pinball
$ 78.00
From: $ 63.00
$ 36.99
Lighting - Interactive
Lee's Parts
$ 47.00
Playfield - Toys/Add-ons
The MOD Couple
$ 269.00
$ 12.99
Cabinet - Decals
Bent Mods
$ 10.95
From: $ 25.00
Boards
German-Pinball-Modular
$ 89.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
There are 277 posts in this topic. You are on page 1 of 6.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside