(Topic ID: 151749)

Atlantis slingshots and bumpers not working


By Red97

3 years ago



Topic Stats

  • 5 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by wayout440
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider Red97.
Click here to go back to viewing the entire thread.

#1 3 years ago

Atlantis (1989)
Suddenly the bumpers and sling shots stopped working, after cycling the power they would work again. Now a month later they have stopped working completely. I haven't looked into it yet but any ideas where to start would be great.

#3 3 years ago

I checked the fuses last night and there all good. The popper kicker still works. I'm gonna look into it more tonight.

#4 3 years ago

Fixed!! It was the CPU connectors. Had 3 or 4 that where extremely loose. Thanks wayout400

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 14.50
Electronics
PinballElectronics.com
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
Wanted
Machine - Wanted
Ballston Spa, NY
From: $ 18.00
Apparel - Men
Pinside Shop
$ 137.00
Wanted
Machine - Wanted
Utica, MI
From: $ 16.95
2,150 (Firm)
Sale Pending!
Canton, OH
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 21.00
$ 32.99
Lighting - Interactive
Lee's Parts
$ 16.00
From: $ 50.00
Gameroom - Decorations
Pinball Art Prints

You're currently viewing posts by Pinsider Red97.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside