(Topic ID: 276316)

Atari Repairs Gen.1 games


By obxamuse

8 months ago

Topic Heartbeat


Topic Stats

  • 13 posts
  • 5 Pinsiders participating
  • Latest reply 1 day ago by semicolin
  • Topic is favorited by 7 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20200930_165022 (resized).jpg
20200930_175452 (resized).jpg
20200921_181657 (resized).jpg
20200921_203718 (resized).jpg
20200923_215917 (resized).jpg
20200923_213754 (resized).jpg

10
#1 8 months ago

Atari Repairs

Before telling you about my Atari Repairs on the Gen. 1 boards I recommend you get familiar with the boards by looking at the Atari section on Pinwiki and Atariage. Also I found some great videos on utube from Artifacts Electronics.


Artie got a load of Atari pins from TNT Amusements and documented some of his repairs. I wish I had seen his videos earlier. I had already fixed most of my boards before discovering his videos. He showed me a few short cuts in troubleshooting. Also I see that Houston Pinball also repairs these boards. If you do not have time or the experience to do it yourself you might want to send them your board. These boards can be hard to repair and I do not have time to do any repairs for anyone else. Another note, these are pretty tough boards and I was able to remove most chips with my Hakko FR-301 Solder sucker.
I got my collection of Atari pins and loads of parts here on Pinside and now have all 7 Production models of Atari pins. Before getting the Gen. 1 games I already had a Superman and Hercules. All these machines will be available to play in my Flippers Arcade in Grandy, NC next year. Our Arcade is still closed as of this August due to the COVID virus

Now on to my repairs .....

Middle Earth: Stated with bad displays, I pulled the big one out and realigned the pins. I believe the small one was ok. Swapped out auxiliary board with a good one I found since I have loads of parts. Sooner or later I can repair some of the broke ones. After this I got the game powered up and working. Then during playing the game all the switches would just quit. This was real intermittent. I traced it down to a bad green wire with black tracer. It was the common ground for the switches. I ran a new wire from the connector on the Mpu board to the play field green ground circuit. Atari is kinda funny with their grounds. Instead of being on the end of the connector it was like pin 6, on the bottom side of connector. They are letters on the top. A few other minor problems with drop targets but nothing major.

Space Riders: This pin was shopped fairly recently it appears. After checking all connections turned game on, all 8’s in big displays, nothing in small ball count display. Board kept making a beeping sound every 2-3 seconds. I unplugged connector going to coin door since switches appeared to be ok. Beeping went away. I found slam switch shorting out even though contacts were bent apart.
Somehow they were shorting out and after fooling with them now ok.
So now game played with some sticky coils. The small display was out and after checking wiring found wire broke going to the power being feed from large display. I replaced all 3 wires by splicing in new wires replacing broke and wore out ones. There is only 3 wires for power so easy to do. I did replace the big red ribbon cable going to the board also because it was also damaged going from the big display to smaller one.

Note about both pins: both had some strings of the GI lights out. After checking wiring with my meter the wires were good to the main board. The wires make a GND connection through J2, pin 1 and A. These are both GND connections for the GI lights. I fixed the problem by stripping the wires about 2 inches from the board and soldering the 2 wires together. This fixed the GI on both games.
Actually fixed for awhile then some GI’s went out on bottom left of Middle Earth.
Found out this white with a black tracer gender on J1, pin 1 or A. Checking with a Meter both these also are a GND circuit so I spliced these 2 wires together just like I did with J2 pin 1 and A. It probably would make since to tie all 4 of these GND wires together, J1, 1 and A and J2, 1 and A.

Started next on Airborne Avenger, at first I could not get it to boot up. Since
I had a extra wiring harness , boards, power supply, etc. , I built me a tester so I could troubleshoot boards. After cleaning connectors and reseating socketed chips I got the board to boot up. Next problem was it would not coinop and put credits on the display. I troubleshoot the coin circuitry with the help of a schematic and the flow chart in the pinwiki Atari troubleshooting guide. I used a logic probe to look at the signals. The coin inputs come in connector J10 after first passing through the auxiliary board. Please note your problem can be in the auxiliary board also but I knew it was good. The first chip the coin inputs come to is D11, a hex inverter. Some of the signals were wrong when I looked at them with my logic probe and coined it. Just to be sure I wrote down all the signals on this chip with a good board first to make sure the inverters were working. So next I unsoldered D11 and replaced it with another inverter. We’ll I hoped I fixed it but no cigar. I rechecked signals and now they were ok but the next chip down the line, E9 was wrong. This is another Hex inverter but different type. It is a Hex Inverter with Schmitt Triggers. Anyway after replacing this chip board now coins up on the test bench. So now Airborne Avenger works just needs a good shopping. I’ll leave that up to one of my route workers.

Next: Time 2000, boots up, hurray, right flippers need updated to coils, main display out, both bumpers out. Starting this project on April 3, 2020 right in the
middle of the COVID-19 virus Pandemic. Today is Tuesday the 7th, I just finished changing out the 2 right flippers to regular flipper coils. This was a real pain in the butt to do. First off I had a hard time trying to remove the old flippers. I could not find anything in the manuals or on pinwiki. Maybe the info was out there and I just did not see it. Well it ended up there was 2 small Allen screws on each flipper bat. After you take these out the top of the flipper pulls off. Then you just take the screw out underneath and remove the old flipper. Next when you go to install the new old flipper assembly you have to drill out the hole in the play field since it is too small for the flipper plastic that goes through the play field. Now I have the pin flipping and just played my first game and noted my next repairs. Broken bumper, broken drop target and a few switches didn’t work I noticed right away. Then right before the last ball the game reset. So back o work tomorrow. We’ll I had a few issues with the main cpu. I pulled board out and put it on my tester. I checked the 5 volt regulator and it was 4.78 or somewhere near there. I changed it and got it back to 5.1
Volts. Still was having some issues but got it fixed by resetting the 6800 cpu and also resetting all the program proms. This board has all the small proms instead of the 2 EPROMs. Also the display was shot on it so I rebuilt one and got it fixed. During attract mode I started getting a little garbage in 4th player.
I swapped out the big ribbon cable and it seems to have corrected that problem.

Board Repairs

Some of my first checks are power supply first, make sure you have a good 5 volts, then I check the clock on C1, the 6800 Mpu. Note clock signals on pin 3, 36 and 37. Then I usually do a quick test to see if all address and data signals are pulsing.
I didn’t document all my repairs so most of this is from memory. On a Space Riders board the outhole kicker quit working. I replaced the driver transistor but it still did not work. Traced it back to D14, a 7407 hex driver chip, replaced it board now works. Had another board with the display messed up, I believe it was stuck on all 0’s, I replaced A5, MC14050. This is in the DMA circuitry. A lot of this is explained in the Space Riders manual. Had another board acting real weird, after replacing parts and partially getting it working I found out that when I bent the board slightly it would work. After reflowing a lot of sockets it still was erratic. Then I bent leads on those small disk shaped ceramic caps on the board. It looked like some might have been shorting out traces on the board. After that board is now ok. Of course make sure you have a good 5 volt regulator on the board. I replaced any under 4.8 volts to be sure. Also check that cap 220uf, 25 volts. I have replaced a few F3 through F12 with different switch issues. Also replaced C9 on a board that caused the switch common line to be stuck low when it should be high all switches open including the onboard switches F2 and F4. If you have a section of lights out on your play field this most likely is one of the 2N5883’s on the aux. bd. I also replaced one of those.

#2 8 months ago

Great thread! Glad some of these Atari’s will live again.

3 weeks later
#3 7 months ago

This is a great post and now i have learned you and artie have a collection of the atari pins.

This is good info as my middle earth had just lost all its lights. I have arties video bookmarked where he chases it down over the mpu, but for mine, ALL my pf and cab lamps are out. My hv section is good and the backbox is fine. Gsme plays and scores normally. Resets ok and does not exhibit anything else notable. Just no bulbs at all pf inserts or gi.

I checked over all fuses but if u could give me a clue where to start looking, id really appreciate it. Ive been taking a look at the aux board where the large heatsknk would normally be cooking with the 2n6282 would be. Its totally cold as are the 4 other transistors after it that control the lamp strobes... is the aux board the issue?

20200921_181657 (resized).jpg20200921_203718 (resized).jpg20200923_213754 (resized).jpg20200923_215917 (resized).jpg
#4 7 months ago

Great post.

I have a space riders - fully works - but the credit and ball count lights take a long time to come on and often don't come on a the same time. Usually have to play several games or leave the game on for a while before they work. Have never been able to track down the cause.

#5 7 months ago

Sounds like you are not getting the 17VDC from the big power supply to the aux. board. If F3 is good on the main power supply maybe it is that bridge rectifier or a connection on the bridge CR3. Since they all went out at once I wouldn’t suspect Q6-9 on the aux. board which control all the G.I.’s on the board. Good luck.

#6 7 months ago

Also could be Q5 on aux. board, if it tests good reflow solder connections also.

#7 7 months ago

Thank you obxamuse!! Question re q5.

I really want to suspect it is q5, and please advise my testing method.

Im testing on board, power off. Diode mode on multimeter and negative on board ground, positive on q5 body of the cap transistor. It reads 1300 continuously increasing. Then if i power on the machine and power it off, it reads 1 solid, nothing until after a few mins it will go back to 1300 increasing higher the longer i leave the dmm leads at the two points.

Solder connections look good btw.

#8 7 months ago

also f3 tests good.

#9 7 months ago

But for sure what we know is.. the large heatsink transistor on the aux board that has 24v feeding it is dead cold. I just dont know if should get hot even if the lights would be out due to another cause. Usually its running so hot u cant touch it.

Re failure mode, all the lamps failed.. at power on or power off. No fade or strobe, or shimmer, or burn smell

Wiring is good, fuses good. Game otherwise plays normally. Scoring and hv displays ok

#10 7 months ago

Looks like we are all good. If that heatsink on the aux board is cold and power heading into that pin is good, try swapping the bottle cap transistor.
20200930_165022 (resized).jpg20200930_175452 (resized).jpg

#11 7 months ago

Glad you got it fixed. Your machine looks great !

#12 7 months ago

Thanks for this thread!! Artifact electronics on youtube was also a big help! Considering using a modern sound board to have background music, not sure where to feed in line out sounds into the sound circuit unless i can just splice it before the amplifier section.

7 months later
#13 1 day ago

Normally you can't put LEDs in the controlled lamps in a middle earth because it runs warm filaments. Did you modify the drive circuitry?

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside