(Topic ID: 233153)

Anyone tried new rottendog system 9-11 board?


By topkat

10 months ago



Topic Stats

  • 99 posts
  • 36 Pinsiders participating
  • Latest reply 23 days ago by tbrioux
  • Topic is favorited by 8 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

IMG_4661 2 (resized).jpg
A406D0C4-F25D-4790-8097-18CA6EB3DB18 (resized).jpeg
30FCBE37-F5BF-4222-9775-78F45BB83E5F (resized).jpeg
8022F4F5-CF7B-49E3-AD95-911DC820763D (resized).jpeg
43E7AB93-C68B-4F21-A593-E436D7FCE7D4 (resized).jpeg

There are 99 posts in this topic. You are on page 2 of 2.
#51 8 months ago

Understatement of the year

#52 8 months ago
Quoted from Flynnyfalcon:

Do you think Whirlwind is worth the effort or maybe look to another sys 11? Of course finding another sys 11 is always the challenge.

Most regard Whirlwind as one of the best Sys11s.

Hard to say “is it worth it” without knowing
A/ what it cost
B/ what it needs
C/ what it’s worth when it’s finished

My rule of thumb is never spend more on anything than what you can sell it for.

So do the sums above and make your call.

rd

#53 8 months ago
Quoted from goingincirclez:

Understatement of the year

Haha!! I’ve had it at a mates since I bought it so yet to really play it. I have however been eyeing off resto parts... playfield/ramps/plastics etc and already looking at $2000+ without looking too deep into it. The cab needs a full resto also which will add up. I like having my machines in absolute A1 condition, so if I keep it, it’ll need a full restoration

I have a restored Funhouse and Taxi, a mint Shadow and a new MBLE coming, so it was probably more a question to me, of whether it’d suit my collection. 2x Lawlors or maybe track down a Steve Ritchie possibly.

#54 8 months ago
Quoted from rotordave:

Most regard Whirlwind as one of the best Sys11s.
Hard to say “is it worth it” without knowing
A/ what it cost
B/ what it needs
C/ what it’s worth when it’s finished
My rule of thumb is never spend more on anything than what you can sell it for.
So do the sums above and make your call.
rd

Thanks Dave. WW doesn’t come up too often in Oz, so I jumped on one when it came up at a good price. It probably needs a full resto including playfield. I haven’t seen a resto’d one come up so unsure of value, but to the right buyer, $6500 ish for a mint resto... cost of resto including machine will probably be in the same ballpark. The question probably is, is a mint WW worth $6500... and most likely that’s for me to answer :-O

#55 8 months ago

This sucks, lot of good Titles in this grouping and all we can depend on is rebuilt available boards? This would be a deal killer for me, they need to fix this mess.

#56 8 months ago

Got a 2 month old used one for High Speed. No white noise, sounds seem the same. Does High Speed have background sound?

#57 8 months ago
Quoted from greatwichjohn:

Got a 2 month old used one for High Speed. No white noise, sounds seem the same. Does High Speed have background sound?

Yes high speed has a music track that plays in the background.

#58 8 months ago

I got the music back. Someone bent 3 legs on a 6821, & wrecked the ic socket. I tried to remove & still lifted a trace. Worked on a number of boards, new ic, new 6821, & new jumper wire.

#59 8 months ago

Can a few of you post YT vids of the new board in operation? If you post a HS game vid I’ll know right away if the sound is “off” as I’ve played thousands of games of HS.

Chris Hibler - CARGPB #31
Http://chrishiblerpinball.com/contact
http://www.PinWiki.com/ - The new place for pinball repair info

#60 8 months ago

The game here sounds great with the new board. The pin has seen lots of use! No distortion of background that I hear. Had to resolder the head speaker.

#61 8 months ago

Jim from rottendog called me today to enquire about the issue. Kudos to Rottendog for great customer service!!

I just uploaded 2 videos on YT. One is Space Station running with the MPU9211. The other is the same Space Station running with the original sys 11B MPU. I'm still fixing up the sys 11B board, hence the garbled displays. I think I have a broken trace to the display PIA. I find that the MPU9211 has more distortion than the original. It's more noticeable with the SFX and speech, so I did not bother uploading the soundtrack.

Original sys 11B MPU sound:

MPU9211 sound:

#62 8 months ago

I've noticed Sound/SFX issues on a the few games I've tried them in - especially the speech. More scratchy and less clear. It's a good alternative if nothing else is available, but would stick to the originals if possible until they figure this out.

#63 8 months ago

I have such a board in a space shuttle. SFX sounds are fine. Speech is super loud. On old sys-9 board combo there was a pot to turn down the speech volume that was separate from the main volume pot. This board it is absent and no way to adjust speech volume so I have to turn the whole thing down lower. Other than that it is great to have the game up and working. Seemed like I was working on system 9 boards every few months and it was a super pita.

#64 8 months ago

Listened to it again for a few minutes and it does seem that only the speech sounds worst. The SFX sound OK.

#65 8 months ago
Quoted from red_sox_papi:

Listened to it again for a few minutes and it does seem that only the speech sounds worst. The SFX sound OK.

looks like the Harris speech decoder chip is being emulated some how (neat). Probably why it sounds speech sounds different.

#66 8 months ago
Quoted from barakandl:

looks like the Harris speech decoder chip is being emulated some how (neat). Probably why it sounds speech sounds different.

From your experience, Is there a way they can fix it? looks like a pretty good board functionally, aside from the speech issue

#67 8 months ago
Quoted from topkat:

From your experience, Is there a way they can fix it? looks like a pretty good board functionally, aside from the speech issue

Respin the board to use the original CVSD chip instead of emulating it. The original chip is obsolete but Rochester Electronics still has like 7k of them. They are $10ea tho. Probably why R-Dog found a different solution.

https://www.rocelec.com/part/harharhc1-55564-5

#68 8 months ago
Quoted from barakandl:

Respin the board to use the original CVSD chip instead of emulating it. The original chip is obsolete but Rochester Electronics still has like 7k of them. They are $10ea tho. Probably why R-Dog found a different solution.
https://www.rocelec.com/part/harharhc1-55564-5

Thanks good info . I would think with the cost of the board, even if they passed the 10$ on to us it would have been worth it. I imagine they figured emulating it would work fine though.

#69 8 months ago

I put one in an F14. No issues whatsoever that I noticed.

1 week later
#70 8 months ago

Has anyone listened to the two YT videos I posted? Can anyone else hear thw noise/distortion?

#71 8 months ago

I only heard distortion in the vocal clips. Oddly enough, it almost blends as "radio static" for the theme of that particular game, though. Not sure how annoying it would seem on other games or in person. It seems subtle enough that it might not dissuade me from using the board if I had to. That said, I also have a Space Station with the original boardset and the distortion isn't there.

#72 8 months ago

I listened a bunch. Def seemed as though the voicing was “distorted”. Sounds seemed the same or very close
Not sure if it would be deal
Breaker though if I needed a board ..

#73 8 months ago

I have one ordered. I am getting ready to redo some old, not sufficient” battery damage repair on the board in my Pinbot and thought I could use this to play while I have it out of the machine. Plus, as many system 11 machines as I go through I thought I may as well have one on hand anyway.

#74 8 months ago
Quoted from red_sox_papi:

Has anyone listened to the two YT videos I posted? Can anyone else hear thw noise/distortion?

I can absolutely hear the distortion in the voices. I have the previous version of the Rottendog and it's unfortunate they didn't address this issue, as this is a very common complaint from these replacement boards.

I had mine in my F-14 and if you had the volume very low, it sounded ok. As soon as you turn it up, the voices and sound effects are much, much louder than the music and sound super distorted in comparison. It's like a radio station over processing it's music, it sounds louder but there's no real difference in highs or lows and just sounds flat. Not that system 11's have a big dynamic range or clarity by any stretch, but at least you get a bit of it and can feel some bass with the original board, which is completely lost on the replacement.

My original board was thankfully fixed and the sound mixing is much better in the original board so I use that instead, so I have an expensive replacement board which thankfully works should something else occurs, but sounds like crap.

#75 8 months ago
Quoted from slapnuts77:

I can absolutely hear the distortion in the voices. I have the previous version of the Rottendog and it's unfortunate they didn't address this issue, as this is a very common complaint from these replacement boards.
I had mine in my F-14 and if you had the volume very low, it sounded ok. As soon as you turn it up, the voices and sound effects are much, much louder than the music and sound super distorted in comparison. It's like a radio station over processing it's music, it sounds louder but there's no real difference in highs or lows and just sounds flat. Not that system 11's have a big dynamic range or clarity by any stretch, but at least you get a bit of it and can feel some bass with the original board, which is completely lost on the replacement.
My original board was thankfully fixed and the sound mixing is much better in the original board so I use that instead, so I have an expensive replacement board which thankfully works should something else occurs, but sounds like crap.

Once I'm done fixing the original board I plan to install it and keep the rottendog one as a spare just because of the distorted speech.

On a side note, I noticed you live in Moncton. I live about 40 mins from there.

#76 8 months ago

Did anyone hear back from rd?
I thought a few people had mentioned they were contacting. I would think they would want it working properly as well

#77 8 months ago
Quoted from red_sox_papi:

Once I'm done fixing the original board I plan to install it and keep the rottendog one as a spare just because of the distorted speech.
On a side note, I noticed you live in Moncton. I live about 40 mins from there.

Very cool red_sox_papi! I did the exact same thing when it came to the board, just a replacement if something blows up on the original board due to the distortion which I never bothered to contact them about, considering how many peeps complained about the same thing and figured that's just the way it is it seems.

#78 8 months ago
Quoted from topkat:

Did anyone hear back from rd?
I thought a few people had mentioned they were contacting. I would think they would want it working properly as well

They had got back to me requesting some audio clips to compare both boards. I emailed them the audio clips of both boards and I haven't heard anything back yet.

1 week later
#79 7 months ago

Just seeing if anyone has suggestions with the blue trimmer pot for speech/music balancing. I know the instructions mentions, that a lot of turns may be required to get it right, but I'm not noticing any difference.

Right now, I have very loud music and very quite speech. Already emailed rottendog, but figure I'd ask here as well.

#80 7 months ago

I have an original system 11 MPU 100% working and never needed repair I would sell.

#81 7 months ago

Is your MPU a system 11 or an 11a ?

#82 7 months ago

System 11

#83 7 months ago

Thanks tonyhoff1, was looking for a 11a for my F14. Will just send mine for repairs

#84 7 months ago

No problem. But the 11 works all system 11 games!

#85 7 months ago
Quoted from tonyhoff1:

No problem. But the 11 works all system 11 games!

Not really. The 11A board works with all S11. You need to add zener diodes to the plain 11 board in order for it work work with everything.

#86 7 months ago

They are already on my board.

2 weeks later
#87 7 months ago

Add me to the list of low and distorted sound. I installed this board on a Williams Road Kings and I get the same weird sound issues. I'm also missing sounds. I'm attaching a picture of my board, because for some reason I have an extra potentiometer that seems to be added after the original assembly. I bought the board as new from the Pinball Wizard.

IMG_4661 2 (resized).jpg
#88 7 months ago
Quoted from Yuyito:

Add me to the list of low and distorted sound. I installed this board on a Williams Road Kings and I get the same weird sound issues. I'm also missing sounds. I'm attaching a picture of my board, because for some reason I have an extra potentiometer that seems to be added after the original assembly. I bought the board as new from the Pinball Wizard.

I actually had to send my board back, to see what Rottendog could do. Mine also came with the extra pot. But even after 20 min of turning the upper pot in one direction, I noticed no difference in the sound. My music seemed like it was always cranked to the loudest possible setting, with speech and SFX at the lowest possible setting.

Waiting to hear back to see what they find out. I would be happy if the pot worked, and even if the voice/sfx were at the same volume level as the music.

2 weeks later
#89 6 months ago

....

#90 6 months ago
Quoted from Jr99svt:

RD customer service is horrible.

I totally agree. I have had a WPC 95 AV board from them that never worked from the get go. I purchased a full set of boards for my MB build and the sound cuts in and out. Sent the board back to them for repair, Worked a few weeks, then same issue. This board was no longer being made and I couldn't swap it for a new one until recently. I contacted them on several occasions, hoping to get board repaired again correctly or at least an exchange for new "batch" of boards just released.

Finally heard back from Jerod and he basically said send to Rob at Lock when lit and pay to have it repaired myself. Not sure if boregard could repair it, but not happy about paying out of pocket another 125-$150 for basically a new board that never worked correctly. At the least, I asked for a credit toward the new batch of wpc 95 AV boards, but they would not work with me even on that.

After dropping almost 900 bucks for a full set of boards, I am very hesitant to buy anything else from them again.
I will say many years ago, their customer service was much better.....It seems now, they don't really care.

2 weeks later
#91 6 months ago

Forgot to post a follow up. So I’m 99% sure the board I got back is a different one. It’s still the same MPU9211, but a replacement one.

Anyways, I’ve got it installed, and the game plays fine now, and both music and sfx are on the same level. The voices do sound a bit different, but are not distorted or bad enough to make the game sound completely off.

I’m happy it’s finally working, just wished it worked from the start.

#92 6 months ago

After reading this I am glad I chose not to go this way for one of my Sword of Fury.
Was really thinking about the Rottendog board but the sound problem was a big issue for me.

Ended up buying a very nice used original board in Germany => cheaper and all good!

1 month later
#93 5 months ago

So I just got one of these boards and put it in my High Speed. I seem to be having the same distortion on some of the sounds - - music sounds fine, lots of bass, etc. However certain sound effects (the engine revving pre-plunge, screeching tires post plunge, and the horn honking when scoring the right and left channels) sound very hollow" and distorted with very little bass.

Does it look like the verdict on this is that this is a fault in the board and I should send it to them for repair/replacement? Or is this something to settle with? Sounds really bad.

-- M

#94 5 months ago
Quoted from MikeVarney:

So I just got one of these boards and put it in my High Speed. I seem to be having the same distortion on some of the sounds - - music sounds fine, lots of bass, etc. However certain sound effects (the engine revving pre-plunge, screeching tires post plunge, and the horn honking when scoring the right and left channels) sound very hollow" and distorted with very little bass.
Does it look like the verdict on this is that this is a fault in the board and I should send it to them for repair/replacement? Or is this something to settle with? Sounds really bad.
-- M

I have one of these boards just to use to test games. I put it in my high speed to see if a flasher issue was in the mpu. I noticed that the volume on the sound effects was louder than the music but I could not hear the same distortion that you all describe. I instantly put my original mpu back into the game and honestly couldn’t tell much difference.

#95 5 months ago
Quoted from jmountjoy111:

I have one of these boards just to use to test games. I put it in my high speed to see if a flasher issue was in the mpu. I noticed that the volume on the sound effects was louder than the music but I could not hear the same distortion that you all describe. I instantly put my original mpu back into the game and honestly couldn’t tell much difference.

It took a little bit of work to get the sounds balanced -- I had to spin the pots ALOT but got them balanced. I can't tell if the voices are distorted (they may in fact be distorted but they are all "over the radio" so it's hard to tell) but those other sound effects I listed sound like you're listening to them over a crummy phone call.

I did buy new ROMs with my board, can they just be a low quality reproduction? Sounds unlikely to me. It's not like it's a drive of WAVs and someone just had low quality ones.

I have an email into rottendog. And the reseller I bought from. But just curious as to how others fix this problem. Some here seem to imply they got a replacement board from rottendog that was good, others seem to say the board just sucks and either sent it back or use it as a stored spare.

- M

#96 5 months ago
Quoted from MikeVarney:

I did buy new ROMs with my board, can they just be a low quality reproduction?
- M

If you mean low quality reproduction on the sound only; there is some fuzziness on all sampled stuff up until WPC DCS. But eproms will either have the correct data or they won't, and if they don't, they fail the checksum test in the machine.

#97 5 months ago

In the next day or two I'll record samples from both boards and upload them so you can hear the differences (like someone else did here). I assume RottenDog will want to hear them anyways.

-- M

#98 5 months ago

With all these sound issues reported with these new Rottendog boards it just motivated me to repair a system 11A board I had laying around. With other information I got off this site I was able to program new EPROMs so I could use it in my system 9 Space Shuttle. All I can say is the speech and game sounds are clear and balanced. That being said I just cancelled my order with Big Daddy and saved myself over $300 bucks, not to mention they've had my deposit for 6 months!

4 months later
#99 23 days ago

Hi all,
Have same problem on a MPU9211, voices louder than other sounds and musics.
I have not the second pot like on pic attached, can someone tell me if it is mounted just replacing C112 cap ?
Thank's

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 50.00
Trade
Machine - For Trade
Merrick, NY
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 14.99
Electronics
PinballElectronics.com
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 18.00
Apparel - Men
Pinside Shop
There are 99 posts in this topic. You are on page 2 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside