(Topic ID: 165330)

Any Escape From the Lost World owners?


By PinballHelp

2 years ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by PinballHelp
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

eflost-underside_(resized).jpg

#1 2 years ago

I'm looking for some pictures of the underside of the upper playfield on Bally's "Escape from the Lost World" pinball machine. I've been working on restoring a game and some parts were missing, specifically, the coil that opens the escape/treasure gate on the upper playfield. I'm specifically interested in the wiring colors, direction of diode on the coil and whether there's any sort of EOS in use on this assembly? There's a leaf switch that's part of the coil assembly and it's incomplete on mine and I'm not sure if there are any wires that were connected to it, so any pictures of the underside of the playfield would be most helpful.

Here's what mine currently looks like:

eflost-underside_(resized).jpg

#2 2 years ago

If all else fails, try searching archived for-sale ads. Sometimes you can dig up some good reference photos.

There's also a few photos on IPDB, but I'm not sure if they're showing the angles that you need.

http://www.ipdb.org/showpic.pl?id=789&picno=49194&zoom=1

#3 2 years ago

Mine's currently in storage, so I'm no help with pictures. I do know that the "leaf switch" is used as a spring to push the gate closed. There's a manual at Ipbd, and I'm pretty sure it's called the escape gate, page 10-3.

http://mirror2.ipdb.org/files/789/Bally_1988_Escape_from_the_Lost_World_Operating_Parts_Manual.pdf

Good luck. Fun Game!

#4 2 years ago

Here's a picture of under the upper playfield. The coil looks well done!

http://www.ipdb.org/showpic.pl?id=789&picno=49216&zoom=1

It's probably common problem as the coil stays energized while the gate is open

#5 2 years ago

Hmm, looks like IPDB is down right now.. very odd..

In any case, I figured out the wiring for the gate and got it working.

What's interesting is, when the drop targets are knocked down, it does open the gate, but it says "You have escaped!" when they go down. I would expect it not to do that. Is there some config setting that could cause this? I don't know of any switch issues.

Promoted items from the Pinside Marketplace
$ 137.00
Trade
Machine - For Trade
Charleston, WV
From: $ 16.95
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 13.00
Electronics
Yorktown Parts and Equip
$ 50.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 64.00
$ 5,799.00
Pinball Machine
Nitro Pinball Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside