(Topic ID: 198720)

Alien Poker Displays not powering


By Snouticus

2 years ago



Topic Stats

  • 11 posts
  • 5 Pinsiders participating
  • Latest reply 2 years ago by Snouticus
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider Jeewiz13.
Click here to go back to viewing the entire thread.

#7 2 years ago

Check to see if you have voltage on the input connectors at 3j1 on ps board. Should be anywhere from 18v, 28v, or 90v.

Almost sounds like your game isn't booting up since no insert lights and only GI is lit. I'm assuming that is what you mean by static lights.

I never used rottendog or nvram but if no batteries are in a game, an on-off-on quickly can get it to boot. Hope that helps.

Promoted items from the Pinside Marketplace
$ 99.00
Gameroom - Decorations
Pinball Sales
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 72.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 14.99
Electronics
PinballElectronics.com
$ 66.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 9.00
$ 22.00
From: $ 18.00
Apparel - Men
Pinside Shop
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 16.95
Playfield - Toys/Add-ons
ULEKstore
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 2.00
Playfield - Decals
Doc's Pinball Shop

You're currently viewing posts by Pinsider Jeewiz13.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside