New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 208341)

Alice Cooper's Nightmare Castle Club: Enter at own risk!


By Sarge

2 years ago



Topic Stats

  • 5,353 posts
  • 302 Pinsiders participating
  • Latest reply 16 hours ago by vireland
  • Topic is favorited by 121 Pinsiders

You

Linked Games

Topic Gallery

There have been 928 images uploaded to this topic. (View topic image gallery).

M&M_AC_SpeakerSurround_TortureChamber.jpg
IMG_4947.JPG
IMG_4946.JPG
IMG_4945.JPG
IMG_20201020_171900 (resized).jpg
IMG_20201020_172056 (resized).jpg
IMG_20201020_172116 (resized).jpg
IMG_20201015_121100 copy (resized).jpg
IMG_20201020_172001 (resized).jpg
IMG_20201020_172020 (resized).jpg
FB_IMG_1601980903720 (resized).jpg
0362988A-3464-469F-9690-8D0989A8A111 (resized).jpeg
20201015_152729 (resized).jpg
E8888404-04F2-41F9-9C86-4B936F35C715 (resized).jpeg
pb72 (resized).jpg
e4680da2c518f174084190d5345986e86dee77ad (resized).jpg

Topic index (key posts)

11 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 5353 posts in this topic. You are on page 62 of 108.
#3051 10 months ago
Quoted from ArcadeVideo:

I briefly had an issue with the ball getting stuck in the secret passage - the issue was one of the rollover switches. I just bent the switch wire a bit, so it's not so tall anymore.

I just did that on my Hobbit! Also, I increased the pitch of the playfield. No more problem.

#3052 10 months ago

So, I cleaned my game for the first time since picking it up. In the past I have been a big supporter that “all playfields dimple...get over it”...well, they do all dimple, but I now see the difference between dimpling and cratering. Whoever does Spooky’s playfields, knows what quality is. The whole game is a tank. Incredible quality! On top of that, I can’t stop playing it. I actually make myself play my other pins, just so they get some attention. Ok, fanboy rant done.

#3053 10 months ago

Who else has trouble backhanding the secret passage shot. I mean so it registers? I make that shot a lot but it rolls back out and doesn't count.

#3054 10 months ago
Quoted from dnaman:

That set should have my tower in it

I already purchased most of the Medisinyl mods including the crypt, which will occupy the spot of your tower. My next task is to get Mark to paint those as well. If you want your tower painted, that could be arranged

#3055 10 months ago
Quoted from netman63129:

I already purchased most of the Medisinyl mods including the crypt, which will occupy the spot of your tower. My next task is to get Mark to paint those as well. If you want your tower painted, that could be arranged

I quite like the original green, it is unique for this pin but do like what you've done.

Regarding my tower, it coexists with Medisinyl's crypt as the two sculpts don't touch, they mount to different areas. There are a few pics that I've shared where I show that I've located our crypt to the plastic below and to the right, above the crypt lane shot, with the crypt door opening facing the player. I really like it for the shot (telling friends to 'shoot for the crypt', but also thought that it worked better for me so that the tower and sculpt weren't competing in view and scale, being so close, essentially with one sitting in front of the other.

#3056 10 months ago

So i came in today to my location and noticed frank didn't rise up when i entered settings like he usually does. I then noticed 2 balls stuck in his left lock. I cleared the balls but frank is not working. Has anyone had this happen? Where should i start looking?

#3057 10 months ago
Quoted from KingHebes:

So i came in today to my location and noticed frank didn't rise up when i entered settings like he usually does. I then noticed 2 balls stuck in his left lock. I cleared the balls but frank is not working. Has anyone had this happen? Where should i start looking?

Check the fuse in the backbox, over to the right of the CPU board. (Far right side of the back panel.)

#3058 10 months ago

My right ramp return has a problem that is happening almost every game now. The foam pad under the chop leans downward and the ball gets trapped. I can't see any loose screws and not sure if this is just from use. "Chop top" setting is maxed at 100. Any suggestions?

20191223_220250 (resized).jpg20191223_222049 (resized).jpg20191223_222122 (resized).jpg
#3059 10 months ago
Quoted from Crile1:

My right ramp return has a problem that is happening almost every game now. The foam pad under the chop leans downward and the ball gets trapped. I can't see any loose screws and not sure if this is just from use. "Chop top" setting is maxed at 100. Any suggestions?[quoted image][quoted image][quoted image]

Have you tried adjusting this in the service menu? I think it’s in the utilities, servo menu. Use the flippers and the coin door buttons to flip through the menu and adjust.
Oh wait, I see you’ve done that...sorry

#3060 10 months ago
Quoted from dnapac:

Have you tried adjusting this in the service menu? I think it’s in the utilities, servo menu. Use the flippers and the coin door buttons to flip through the menu and adjust.

Servo upper limit is already maxed out at 100. So can't go any higher.

#3061 10 months ago
Quoted from Crile1:

Servo upper limit is already maxed out at 100. So can't go any higher.

Lift the playfield and look at it from the bottom. Is the mech binding on something. Run it through the full up and down from the servo menu to see if it resets it to lift higher. 2 things to look at.

#3062 10 months ago
Quoted from KingHebes:

So i came in today to my location and noticed frank didn't rise up when i entered settings like he usually does. I then noticed 2 balls stuck in his left lock. I cleared the balls but frank is not working. Has anyone had this happen? Where should i start looking?

Yea, it happens to me often in multi player mode. Especially if it has gone through any ball search’s. Seems like it forgets about frank lock any time it searches

#3063 10 months ago
Quoted from Coyote:

Check the fuse in the backbox, over to the right of the CPU board. (Far right side of the back panel.)

Yup!
This fuse blew on me once because the diverter servo behind Frank seized up. I had to replace the servo and then reset the parameters for left, center and right diverter positions in settings, making sure it didn't bind on anything. Easy to do. Spooky sent me two new servos. So I now have a spare.

#3064 10 months ago

Again, Frank and Crypt get lost. This can supposedly be from the crypt locked ball behind front drop target not being detected by opto. It happens to me. I lock Frank ball one, then the crypt ball, and then there's a ball search and both balls get released on 3rd search. I have tried pulling crypt drop target assembly forward as in Spooky video to align opto with locked ball properly, but it still gives me intermittent occurrences of this. I am running the beta code now. Perhaps this is still a code issue??

#3065 10 months ago
Quoted from Crile1:

The foam pad under the chop leans downward and the ball gets trapped.

I asked several pages back about this foam strip under guillotine? Never got an answer. Why is that even there?

#3066 10 months ago
Quoted from Mr_Outlane:

I asked several pages back about this foam strip under guillotine? Never got an answer. Why is that even there?

It isn't the foam. The piece under the foam leans downward. It is flush at the superior part, but there is a gap at the inferior part that causes a ball trap.

#3067 10 months ago

I had problems with the guillotine too and no adjustment fixed it. I finally bought some neoprene and cut to shape, stuck it in to better even out the transition.

#3068 10 months ago
Quoted from Crile1:

It isn't the foam. The piece under the foam leans downward. It is flush at the superior part, but there is a gap at the inferior part that causes a ball trap.

OK, I'm sorry. I misunderstood.
I have a vertical strip of foam on the right guillotine beam (the actual wooden beam of toy). Do not know why it is there? Never removed it yet.

#3069 10 months ago
Quoted from jfesler:

I had problems with the guillotine too and no adjustment fixed it. I finally bought some neoprene and cut to shape, stuck it in to better even out the transition.

good idea.

#3070 10 months ago

Curious: what power does everyone have their upper flipper set to?

#3071 10 months ago

Upper flipper can vary by game. I recommend testing with glass off that you can consistently hit the right Frank ramp. You don't need any more power than that!

#3072 10 months ago

If you get air balls a lot, it's set too high. I did that at first.

#3073 10 months ago
Quoted from Crile1:

Servo upper limit is already maxed out at 100. So can't go any higher.

I had the exact issue and just fixed it by 1) adjusting playfield angle to 6.5 degrees and 2) bending the black metal frame downward so that it is more flush with the foam. It works flawlessly now.

#3074 10 months ago

Anyone worried support and updates for this game will fall by the wayside due to the response for “Rick and Morty”? I wasn’t initially but damn that thread is lit up. Has me concerned.

#3075 10 months ago
Quoted from GvikenL:

Anyone worried support and updates for this game will fall by the wayside due to the response for “Rick and Morty”? I wasn’t initially but damn that thread is lit up. Has me concerned.

Fawzma (David) isn't on Rick and Morty, so hopefully that's not the case. Still looking forward to the item hunt aspect, which was one of the main features I was excited about.

#3076 10 months ago

Concerning rattling glass. It is not just the glass. Here is a video of my pin with glass off. Any suggestions as to where to track this Down?

#3077 10 months ago
Quoted from GvikenL:

Anyone worried support and updates for this game will fall by the wayside due to the response for “Rick and Morty”? I wasn’t initially but damn that thread is lit up. Has me concerned.

I'm not worried at all. They would not blow us off. That would be hugely foolish and they aren't like that. They are close to nailing down the memory leak and then things will start happening. It's their first crack at the Multimorphic P3-ROC board system and their learning curve is huge! Chill and enjoy the challenge thus far. This game kicks my ass all over the place. I love it!

#3078 10 months ago
Quoted from GvikenL:

Anyone worried support and updates for this game will fall by the wayside due to the response for “Rick and Morty”? I wasn’t initially but damn that thread is lit up. Has me concerned.

I (or someone else) answer every email that comes into Service@SpookyPinball.com. What kind of support issues are you having?

#3079 10 months ago
Quoted from KingPinGames:

I (or someone else) answer every email that comes into Service@SpookyPinball.com. What kind of support issues are you having?

On Christmas Eve...

yeah. I wouldn't worry about Spooky Support. Not at all.

#3080 10 months ago

Spooky is next to none with customer support. No worries here. That said...ignore the calls for the Christmas holiday. Let them be with their families.

11
#3081 10 months ago

My wife gave me the lab mod for Xmas from MEDISINYL

Easy install, goes great with the theme. I’m not big on mods but this one is just really good!

5C1003F4-4B48-47B8-B34F-C1C3DBDB302B (resized).jpeg
#3082 10 months ago
Quoted from GvikenL:

Anyone worried support and updates for this game will fall by the wayside due to the response for “Rick and Morty”? I wasn’t initially but damn that thread is lit up. Has me concerned.

Not even a little bit.

#3083 10 months ago
Quoted from Cyrus:

My wife gave me the lab mod for Xmas from MEDISINYL
Easy install, goes great with the theme. I’m not big on mods but this one is just really good![quoted image]

Nice!

#3084 10 months ago
Quoted from Cyrus:

My wife gave me the lab mod for Xmas from MEDISINYL
Easy install, goes great with the theme. I’m not big on mods but this one is just really good![quoted image]

I appreciate the post, and I'm glad to see you're enjoying the mod

Always a bit of a sting to ship these labs off with the time that goes into them (any hand-made art I suppose), but the feedback has been rewarding, and it's awesome to see these photos posted on the forum.

Thanks again, and Merry Christmas!

10
#3085 10 months ago

#437 is set up and the kids approve.

Should keep us busy as we wait for R&M.

Thanks, Spooky!

1EBE0FAD-4C55-4F6B-9489-728F650A4184 (resized).jpeg79389AAD-DB3B-4B34-99B7-5ABEAEB20C4F (resized).jpeg
#3086 10 months ago

I installed the lab mod and the crypt mod from @medisinyl...I did not hook them up to electrical because I didn’t want to affect my warranty. They look awesome! And when I electrify them in a year, they will be all new mods! If you don’t have them, I’d highly recommend them.

#3087 10 months ago

So I frequently have lab lock 2 and sometimes lab lock 1 not registering. Is this a known bug or an adjustment I need to make on my part? Ball search will clear lab lock 1 but Frank doesn't raise high enough to clear lab lock 2 during game.

#3088 10 months ago
Quoted from manadams:

So I frequently have lab lock 2 and sometimes lab lock 1 not registering. Is this a known bug or an adjustment I need to make on my part? Ball search will clear lab lock 1 but Frank doesn't raise high enough to clear lab lock 2 during game.

I’d bet mechanical vs code. Mine took some adjustment, but works 99% now.

#3089 10 months ago
Quoted from dnapac:

I’d bet mechanical vs code. Mine took some adjustment, but works 99% now.

Adjusted my Frank switches and I think I'm good now, thanks.

#3090 10 months ago

My wife and I got machine #414 just before Thanksgiving! It's been a blast so far, also pretty fun to figure out all the little quirks of owning a pinball machine. Spooky support has been awesome for the couple things we contacted them about (had sound issues, turns out the audio cable was just loose from shipping; had one of the slings get 'haunted' and start randomly knocking, turns out we just needed to adjust the leaf sensor a little...stuff that is probably obvious to anybody who's owned a machine before).

We also occasionally have a ball get stuck next to the monster, raising him up a tad from the settings menu seemed to prevent it but had him pretty much touching the top edge of the case which I read was bad, so we lowered him a tad; ball still gets stuck occasionally after a game, but just going into the operator menu signals the monster to raise up a little more which unsticks the ball. Very simple workaround.

The thing we haven't been able to figure out yet is, we're now getting 2 balls loaded into the shooter occasionally (about once every 6-8 balls). Doesn't seem to hurt anything, it's kind of like a "free" multiball. I've noticed a few others with this issue, but any concrete leads on how to fix it (in terms a newbie can understand)?

#3091 10 months ago
Quoted from MintIndeed:

The thing we haven't been able to figure out yet is, we're now getting 2 balls loaded into the shooter occasionally (about once every 6-8 balls). Doesn't seem to hurt anything, it's kind of like a "free" multiball. I've noticed a few others with this issue, but any concrete leads on how to fix it (in terms a newbie can understand)?

I think it's a bug that will be addressed when the code update comes out, happens on mine about the same frequency.

#3092 10 months ago
Quoted from manadams:

So I frequently have lab lock 2 and sometimes lab lock 1 not registering. Is this a known bug or an adjustment I need to make on my part? Ball search will clear lab lock 1 but Frank doesn't raise high enough to clear lab lock 2 during game.

I've covered this on previous pages.
It appears that Frank intermittently does not always raise up all the way (regardless of the servo settings) in non beta code. That was the reason I installed the beta code, and it did resolve this problem. Also, watch the Spooky video on adjusting the crypt drop target (opto not detecting ball in crypt lock). https://www.youtube.com/watch?time_continue=4&v=AQqRUonIkxs&feature=emb_logo

** Go to YouTube and watch all the Spooky company videos on ACNC. **

https://www.youtube.com/user/SpookyPinball/videos

#3093 10 months ago
Quoted from MintIndeed:

we're now getting 2 balls loaded into the shooter occasionally (about once every 6-8 balls). Doesn't seem to hurt anything, it's kind of like a "free" multiball. I've noticed a few others with this issue, but any concrete leads on how to fix it (in terms a newbie can understand)?

Yup. It just started happening to me as well.
They are planning to implement a feature into a future code update that allows us the set the coil strength for the ball trough kicker. This should solve the problem.

#3094 10 months ago
Quoted from MintIndeed:

- It's been a blast so far, also pretty fun to figure out all the little quirks of owning a pinball machine.
- turns out we just needed to adjust the leaf sensor a little...stuff that is probably obvious to anybody who's owned a machine before).

Welcome to Pinball !!
You have a great attitude as a pinball owner! This is not a hobby for the meek !!

#3095 10 months ago
Quoted from dnapac:

I installed the lab mod and the crypt mod from @medisinyl...I did not hook them up to electrical because I didn’t want to affect my warranty. They look awesome! And when I electrify them in a year, they will be all new mods! If you don’t have them, I’d highly recommend them.

I am using an external power supply. I do that with any of my games when I buy the occasional mod that needs power (and right now that stands at only 2 of 11 pins). The power supplies are fairly inexpensive and I can keep the game's power and the mod's power separate.

#3096 10 months ago
Quoted from Cyrus:

I am using an external power supply. I do that with any of my games when I buy the occasional mod that needs power (and right now that stands at only 2 of 11 pins). The power supplies are fairly inexpensive and I can keep the game's power and the mod's power separate.

Can you post a link to what you’re using?

#3097 10 months ago
Quoted from 27dnast:

Can you post a link to what you’re using?

I'm digging your new avatar...

#3098 10 months ago
Quoted from Mr_Outlane:

I've covered this on previous pages.
It appears that Frank intermittently does not always raise up all the way (regardless of the servo settings) in non beta code. That was the reason I installed the beta code, and it did resolve this problem. Also, watch the Spooky video on adjusting the crypt drop target (opto not detecting ball in crypt lock). https://www.youtube.com/watch?time_continue=4&v=AQqRUonIkxs&feature=emb_logo
** Go to YouTube and watch all the Spooky company videos on ACNC. **
https://www.youtube.com/user/SpookyPinball/videos

Solved my issue a few posts ago but thanks for the info.

#3099 10 months ago

Couple of suggestions for Spooky on audio. Igor and Pit creature are lacking any monster noises when you find them and all of the monsters need some audio cue that frenzy mode has started.

#3100 10 months ago

I hope the upcoming software update perfects and/or adds some call outs. There's quite a few moments where Alice blurts out the same thing in repetition... or a bunch of seemingly unrelated call outs are stacked one on top of another. It's those moments where the game kind of takes on a homebrew feel, rather than a manufactured machine appeal. I think I've become more sensitive to this over the months.

Promoted items from the Pinside Marketplace
6,300 (OBO)
Machine - For Sale
West Lafayette, IN
$ 95.00
Playfield - Toys/Add-ons
M&M Mods
$ 107.95
Lighting - Other
Hookedonpinball.com
$ 55.00
From: $ 45.00
Playfield - Toys/Add-ons
Medisinyl Mods
From: $ 7.99
Playfield - Toys/Add-ons
Medisinyl Mods
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
There are 5353 posts in this topic. You are on page 62 of 108.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside