(Topic ID: 234939)

Adjusting BSD magnet microswitch.

By Zennmaster

2 years ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 2 years ago by Zennmaster
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 2 years ago

Hi all -

I've been getting "Magnet Left Error" messages intermittently on my BSD. The rest of the Mist system seems to be working fine, and I'm not getting any other errors or unwanted behavior.

After digging around, it seems that this error by itself means I need to adjust the Magnet Left switch (81). The switch looks like any other microswitch, but with a long, bent lever.

My question is: what kind of adjustment does this switch generally need? What seems to be happening is that the switch doesn't always register when the magnet traverses to the left side during the test. It always works when I test the switch by itself.

I hit it with a can of air to make sure it was at least somewhat clean, and sure enough, it worked for a while, then I got another credit dot, and the same error message. My next thought is to bend the lever a little more so that it makes contact with the magnet earlier and compresses the switch button with more force, but I also don't want to break anything.

Any thoughts or ideas?

Thanks!

#2 2 years ago
Quoted from Zennmaster:

My next thought is to bend the lever a little more so that it makes contact with the magnet earlier and compresses the switch button with more force, but I also don't want to break anything.

This is probably all it needs. I usually push the actuator down so the first part nearest the pivot is against the switch body. Then while holding it down with one hand slightly bend the actuator at the first bend. But just slightly.

I don't remember if the mist test actually runs the carriage right to left to test those switches or not.

#3 2 years ago
Quoted from schudel5:

This is probably all it needs. I usually push the actuator down so the first part nearest the pivot is against the switch body. Then while holding it down with one hand slightly bend the actuator at the first bend. But just slightly.
I don't remember if the mist test actually runs the carriage right to left to test those switches or not.

Thank you, I'll give it a shot.

2 weeks later
#4 2 years ago

Follow-up -

Work had me away form home for a few days, but I finally got a few minutes to work on the games.

A little tiny, honestly imperceptible, bend in the actuator was all it took. No more credit dot, and the magnet test works perfectly every time.

The big surprise: the "magnet off left" test should only take a few seconds, as it is supposed to just transit one direction once. Mine was taking a painfully long time (long enough that I was starting to worry about the motor getting hot). Looking through the coin door, I could see that it was going from right to left, then back again.

The issue didn't really have an effect on game play, but the credit dot and the fault count were really bothering me.

All better now!

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside