(Topic ID: 192412)

Addams family playfield insert lamps not working

By Shamus_7

4 years ago


Topic Heartbeat

Topic Stats

  • 15 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by Shamus_7
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

IMG_20170825_213835 (2) (resized).jpg
IMG_20170825_184850 (resized).jpg
IMG_20170825_184845 (resized).jpg

#1 4 years ago

had to disconnect Addams family pinball to re-locate upstairs, removed play field and back box.. back together and now no playfield insert lights are working, any idea's? i'm guessing a power issue as all lamps out

#2 4 years ago

Did you miss a connector? Bottom right area of the power driver board make sure all the connectors are plugged in and in the right spots. That's where I'd start.

1 week later
#3 4 years ago

thanks for reply schudel5. I double check many times and all looks good. I checked F114 fuse and has 6 volt passing through it.. All lamps and the "THING" lamps on backboard are out, so i'm guessing the whole lamp matrix not working. any hints on what to check next? thanks Shane

#4 4 years ago

If none of the CPU controlled lamps are working, is the CPU getting 5v? Is the ribbon cable properly oriented between the boards. Some pictures would be very helpful.

Marc

1 month later
#5 4 years ago

Ok I've uploaded some photo's, Could you explain how to test CPU? yeah ribbon cable seems to oriented correctly. so its the under-Playfield lights only, I have 18v at B1 and the test point has 18v.

IMG_20170825_184845 (resized).jpg

IMG_20170825_184850 (resized).jpg

IMG_20170825_213835 (2) (resized).jpg

#6 4 years ago

Unplug and then plug back in the ribbon cable going from cpu to driver board. Had a similar issue on my funhouse and that fixed it. Simple stuff first.

#7 4 years ago

yeah I just tried that and still no lamps..

#8 4 years ago

how many volts should be at the fuse?

#9 4 years ago

I thought playfield lamps were driven by 18v. That's how it is on my funhouse. Should be in the manual.

#10 4 years ago

Does the game start and play a game?

#11 4 years ago

yes the game starts and all plays..

#12 4 years ago

Is J133 pin 9 making proper contact? Looks like a damaged connector housing on the left hand side from the photo.

Maybe it's only a coincidence but that's your controlled insert playfield lamp connector.

Squeeze the housing together at the split end to make better contact with the header pins with the machine on and see if the lamps light.

#13 4 years ago

I just tried with damage connector, made sure there was good connection and still no play-field lamps.

1 year later
#14 3 years ago

Hi, sorry to dig up an old thread but was this problem sorted and how? Suffering exact issue on my Fishtales and could do with some pointers....cheers

8 months later
#15 2 years ago

JonCrox, sorry for no reply. I haven't fixed this problem yet, I ended up buying a New playfield and doing a refurbishment. I still haven't got it back together yet to fix this problem. How'd you go? sort the problem with Fishtales?

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside