(Topic ID: 161315)

Addams Family Meltdown


By altobalk

3 years ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 3 years ago by altobalk
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

Got done with a nice game last night and walked away after my last ball went down the tubes. About 10 seconds after I heard the sound go down and the flippers start to flip . I walked back to find the machine stuck on the bonus screen and not operating(lights are on, no sound). The flippers wouldn't work, I tried entering the menu from the coin door and that wouldn't work either. I ended up shutting the machine off, when I turned it back on nothing worked, the lights and sound won't come on. I have not even looked in the the back box yet. Anybody have any suggestions before I start to troubleshoot. It feels like a board has failed but I'm not sure. Any help would be appreciated.

#2 3 years ago

Look in the backbox. See all those flat gray cables? Press them toward the board. Turn it on briefly. If it doesn't boot in 10 seconds turn it off and regroup here.

#3 3 years ago

check your fuses

#4 3 years ago

Lift up the playfield and check the cabinet to make sure a ball didn't fall and short out something.

#5 3 years ago

It was the cables connecting the boards. They weren't loose as i pushed on them and tried to start the machine with no luck. Next i pulled them half off and gave them wiggle then pushed them back on and that did the trick. Seems like some oxidation or something had made a connection bad on a pin. Any ways this thread is much shorter than I thought

Promoted items from the Pinside Marketplace
From: $ 32.00
Playfield - Other
ModFather Pinball Mods
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside