(Topic ID: 276024)

Addams Family Insert Lights/Lamp Matrix Issue Help Please

By ktuhde

1 year ago



Topic Stats

  • 8 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by sandro
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

F3F77B48-5CB5-488A-A304-51A20E5A1CF6 (resized).jpeg
DEFEC9A4-D3BD-4ED9-9CDC-4E455B8E11A5 (resized).jpeg
8606D4EF-CE63-466F-A39A-F3847A252BF1 (resized).jpeg

#1 1 year ago

To start I want to say I am not experienced in repair. I have had a few machines so I have the very basics, but I really don't know what I'm doing. With guidance I can sometimes troubleshoot problems.

I bought an Addams Family and brought it home and set it up Sunday. I looked it over and shot a few balls when I picked it up, but didn't really pay that much attention, but I assume it was all working at time of pickup. Maybe the transport and setup shook something up?

Anyways here is my problem I noticed today:

To start, when I start a new game these inserts are already lit. Maybe some are supposed to be lit, but I know they all aren't supposed to be lit at start.

Thing Multiball(11)
Extra Ball (12)
Jackpot (13)
A (14)

Left Special(61)
Lite Thing Flips(62)
Lite 2 Bear Kicks(63)
Electric Chair Yellow(64)

Lite ADX (71)
Right Special(72)
Lite Graveyard at max(67)

So I went to the single lamp test to try to determine what was going on. As a went through many of the lamps would light more than what was suppose to light with the test. I went through and wrote them all down. I could write them all down here, but it was a lot. I looked at the Lamp Matrix to see how the additional lamps were related in the matrix. Here is what I found. Everything in column 1 is good and don't light additional lamps. All lamps in row 7 also don't light additional lamps. For everything else here is the pattern. When testing each lamp the lamp in Column 1 and the same row as the lamp also lights. Additionally the lamp in row 7 of the same column lights.

So for example when I tested Upper Left Jet (21), then Thing Multiball (11) and 2 Bear Kicks(27) also light up with it. That pattern follows for all lamps. Column 1 in the same row and row 7 in the same column.

So at least I found this pattern and I hope it can help someone give me advice on what to do next. I don't know how to use a multimeter or any of that, but I guess I should learn? I am hoping someone can say thats easy just unplug this or that and reseat it.

Any help is appreciated. Thanks, Kevin

#2 1 year ago

Lamp matrix picture

8606D4EF-CE63-466F-A39A-F3847A252BF1 (resized).jpeg
#3 1 year ago

First, check the in-line diodes within the problem row/column. Faulty diodes can cause all kinds of lamp matrix weirdness.

#4 1 year ago
Quoted from Ricochet:

First, check the in-line diodes within the problem row/column. Faulty diodes can cause all kinds of lamp matrix weirdness.

Ok. I am going to buy a multimeter after work today. I haven't done this before, but I would like to learn. How do I know which column/row is bad. Looking at the pattern there is always the lamp in Column 1 of each row and Row 7 below in the same column.

So another example would be when Quick Multiball(55) lamp is tested, also Stars (15) and House Seance (57) light up. Follows that pattern for the whole matrix except column 1 test ok.

So does that mean that it most likely is somewhere in Column 1 or Row 7? or both?

Also I don't know if this matters but the Things lamp board is not installed in the backbox because the previous owner installed a color screen. I have the lamp board that will fit in there on order. Could having no Thing lamp board install at all contribute?

Thanks again

#5 1 year ago

That implies there is a short in column 1 and another in row 7. I would assume that there is a short in the grave ‘v’ lamp. Minimally I’d start by looking in that neighborhood for an issue.

#6 1 year ago
Quoted from sandro:

That implies there is a short in column 1 and another in row 7. I would assume that there is a short in the grave ‘v’ switch. Minimally I’d start by looking in that neighborhood for an issue.

The “V” lamp makes a lot of sense after you point that out. Where the column and row that have an issue combine. I will start there. Thanks.

#7 1 year ago

Thanks for pointing me in the right direction. Home for lunch and I looked at the “V” lamp and sure enough that was the issue. Someone hacked in the Uncle Fester mod with speaker wire to the lamp. Not sure why they picked that lamp? Or why they did such a crappy job! I cut those wires and cleaned up the area and it all work correct now. Now I have to read how to correctly connect the mod. Thank you

DEFEC9A4-D3BD-4ED9-9CDC-4E455B8E11A5 (resized).jpegF3F77B48-5CB5-488A-A304-51A20E5A1CF6 (resized).jpeg
#8 1 year ago
Quoted from ktuhde:

Thanks for pointing me in the right direction.

No problem. Cheers to the new game!

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside