New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 259450)

Addams family flipper issue


By Karpy1717

8 months ago



Topic Stats

  • 47 posts
  • 5 Pinsiders participating
  • Latest reply 6 months ago by MintIndeed
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 11 images uploaded to this topic. (View topic image gallery).

image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg

#1 8 months ago

Hi everyone! I’ve had problems with my flipper eos switch not activating. As advised by a pinball friend they said to lightly sand the contacts( I don’t think this was right) and now my upper right flipper will not activate. I have no idea what to do but I can post pictures if needed. Thanks for your help in advance

#2 8 months ago

Your EOS was gold plated, you ruined that. Not the end of the world, replace, or sand if it ever needs it.

You should have been looking for a broken wire at the other EOS switches first, from them, to the fliptronics board, check the other EOS's first.

Next up, check the fliptronics board for a blown fuse. And Tests - Switch Edge - see if flipper button leaf blade switches both register on the DMD. Two on each flipper button. Push in slowly, first lowers register then uppers, when you push the flipper button in. Be sure both flipper button switches work.

LTG : )

#3 8 months ago

Wow I’m silly... eos was broken wire.... I soldered that up. I’ll do the switch test and get right back to you

#4 8 months ago

So now to the flipper... they both activate in terms on the switch test. No errors popping up at all. The only thing now is the following:

The main right flipper activates but has a hissy fit and returns to off position after moving crazily. The upper does not Activate at all

#5 8 months ago
Quoted from Karpy1717:

The main right flipper activates but has a hissy fit and returns to off position after moving crazily. The upper does not Activate at all

If both switches work, you now have an issue on the fliptronics board.

No idea what, sorry.

LTG : )

#6 8 months ago
Quoted from LTG:

No idea what, sorry.
LTG : )

I didn’t think that was possible

#7 8 months ago

Well I did a little digging.... when the upper flipper switch touches it doesn’t register so I think I’m just going to replace that. I was wrong when I read it on the screen. Basically the two pucks touch but don’t activate. Is the best thing to do replace the flipper system?

#8 8 months ago
Quoted from Karpy1717:

Is the best thing to do replace the flipper system?

Figure out what is wrong first. Remember how this started. Look at the dedicated switch column in your switch matrix. Don't be ignoring a broken wire again.

Quoted from JayDee:

I didn’t think that was possible

Very possible. I'm not standing there when mistakes were made. So no accurate way of knowing what all happened.

LTG : )

#9 8 months ago

Alright so this is what happens... r flipper button and r flipper eos activate. For the upper r flipper button activated but not eos. The little pucks are making full contact.

Essentially bottom one works top doesn’t. Before sanding they both worked

#10 8 months ago

The right flipper doesn’t stay out either

#11 8 months ago

Grab a meter and check wires from EOS to fliptronics board.

Quoted from Karpy1717:

The right flipper doesn’t stay out either

Do you mean you in game play you push the flipper button and it goes up and drops ? If so go over solder joints at the coil.

LTG : )

#12 8 months ago

Alright so basically the flipper pushes out and returns back. Power is going there but not staying. I wish I could send you a video but I don’t think that is possible. I just re soldered all the wires connecting to the coils and flippers but ultimately it’s exactly the same... here are pictures in case you could spot something

image (resized).jpgimage (resized).jpgimage (resized).jpgimage (resized).jpgimage (resized).jpgimage (resized).jpgimage (resized).jpg
#13 8 months ago

Basically when the two pucks touch it registers in switch test but no power is going to second flipper

#14 8 months ago

The other thing is that the only thing I did was sand the connections of the flipper pucks. So I have to assume that those are just not working and I should replace it

#15 8 months ago
Quoted from Karpy1717:

The other thing is that the only thing I did was sand the connections of the flipper pucks. So I have to assume that those are just not working and I should replace it

No, I'm sure they work. You need to check continuity of them from the EOS lugs to the fliptronics board.

Quoted from Karpy1717:

but no power is going to second flipper

If both leaf blade switches register in Tests - Switch Edge, I'd try swapping flipper coil with another. If they don't register in Tests - Switch Edge - check continuity from the flipper button switches to the fliptronics board.

LTG : )

#16 8 months ago

Alright I know this doesn’t sound good but what is a fliptronics board . I’m rather new to this all. I’m just annoyed since before I sanded it worked and now it won’t... do I need to go buy a meter to test the power flow to the board?

#17 8 months ago
Quoted from Karpy1717:

what is a fliptronics board .

When you are facing the game - the board in the top left corner of your backbox, above the CPU.

You can download the manual from here, if you don't have one. It will help you identify boards and what connectors on them to check :

https://www.ipdb.org/files/20/Bally_1992_The_Addams_Family_Manual.pdf

Quoted from Karpy1717:

do I need to go buy a meter to test the power flow to the board?

You need a meter, a cheap one will do. And check continuity first, not power.

Youtube is littered with how to videos. Use a meter, check continuity, etc. etc.

Quoted from Karpy1717:

I’m just annoyed since before I sanded it worked and now it won’t..

If you did his with the game turned off, just a coincidence, not something you did.

LTG : )

#18 8 months ago

Yep I did it while turned off... I’ll go get a meter and get back to you. Thanks for all the help

#19 8 months ago

Aren't those EOS switches normally closed?

#20 8 months ago

Not on mine

#21 8 months ago

Also is there anything in particular I need to check on the board?

#22 8 months ago
Quoted from Tbachli:

Aren't those EOS switches normally closed?

No.

Quoted from Karpy1717:

Also is there anything in particular I need to check on the board?

The fliptronics board - yes, the fuses. Pull and check with a meter.

LTG : )

#23 8 months ago

Alright!!! I got a meter I’ll attach a photo so you can tell me if it’s the right setting. Which fuses do I need to look at???

image (resized).jpgimage (resized).jpg
#24 8 months ago
Quoted from Karpy1717:

so you can tell me if it’s the right setting.

No, set it on ohms or diode. Watch some Youtube how to videos.

Quoted from Karpy1717:

Which fuses do I need to look at???

The ones on the fliptronics board.

LTG : )

#25 8 months ago

Not sure what this fuse does but it’s completely blown so I removed it..:

image (resized).jpg
#26 8 months ago

Alright I tested every fuse in the whole game and besides that broken one they all were .09 on this setting

image (resized).jpg
#27 8 months ago

Is the blown one a flipper fuse?

#28 8 months ago
Quoted from Karpy1717:

Not sure what this fuse does but it’s completely blown so I removed it..:

Check your manual. Replace it.

LTG : )

#29 8 months ago

F902 is for upper right flipper.

LTG : )

#30 8 months ago

Well that’s perfect!!! What about the bottom flipper going out and returning really quick??? Is that a fuse thing because I soldered it up and nothing was fixed

#31 8 months ago

I’ll fix the top one I got to go to a store but they are closed because of snow

#32 8 months ago

Got a fuse, flipper works. However the main bottom right flipper still sticks out partially and returns. How should I trouble shoot this

#33 8 months ago
Quoted from Karpy1717:

However the main bottom right flipper still sticks out partially and returns. How should I trouble shoot this

Move it by hand - determine mechanical or electrical - could need a new plunger, coil sleeve, coil stop.

LTG : )

#34 8 months ago

I’ll go take a look right now!!!

#35 8 months ago

Alright so basically what happens is it goes out all the way and instantly returns. Looking at the coil it just won’t hold out??? So maybe it’s power going to it I’m not sure. When moved by hand it feels normal and Nothing appears wrong. I’d say electrical

#36 8 months ago
Quoted from Karpy1717:

Looking at the coil it just won’t hold out???

Try a different coil.

LTG : )

#37 8 months ago

Alright I will do that. Just as an add on it seems to double fire at the end and then return? Probably a coil like you said.

#38 8 months ago
Quoted from Karpy1717:

Probably a coil like you said.

Or wiring at the coil lugs.

LTG : )

#39 8 months ago

Would taking a meter to it tell me anything?

#40 8 months ago
Quoted from Karpy1717:

Would taking a meter to it tell me anything?

No.

LTG : )

#41 8 months ago

Alright I’m just going to buy a new coil and hope it’s that!!! No way I’m able to rewire so I’d have to get someone to do that for me

#42 8 months ago
Quoted from Karpy1717:

No way I’m able to rewire so I’d have to get someone to do that for me

Be sure they know what they are doing. Didoes on coil facing the same direction, wires in the same spots.

LTG : )

#43 8 months ago

Alright so I just called up my pinball store and they said they don’t think coil is dead since it does fire. They said it could be something to do with fliptronics board. Any idea what I need to look for?

#44 8 months ago
Quoted from Karpy1717:

they said they don’t think coil is dead since it does fire.

I don't think it's dead. I do believe you have a bad solder joint at the coil lugs. Or one of the thin wires from the coil to the coil lug is cracked or broken. Or one of the two windings inside the coil is bad.

I suggested a new coil, because that would eliminate three potential problems.

You could use some hands on help with this so you quit chasing back and forth and get the game fixed so you can enjoy it.

LTG : )

#45 8 months ago

Sounds good!

#46 8 months ago

Got a new coil and it works!!!! I seriously appreciate all the help! Thanks so much

2 months later
#47 6 months ago

ltg karpy1717 Thanks to you both, because of the detailed info in this post and pics I was able to diagnose a problem with my TAF upper-right flipper

Promoted items from the Pinside Marketplace
$ 39.99
Lighting - Interactive
Lee's Parts
$ 79.00
Lighting - Under Cabinet
Arcade Upkeep

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside