(Topic ID: 26240)

Addams Family down for the count.

By Arcade

7 years ago

Topic Stats

  • 86 posts
  • 20 Pinsiders participating
  • Latest reply 6 years ago by zucot
  • Topic is favorited by 6 Pinsiders


Linked Games

Topic Gallery

There have been 8 images uploaded to this topic. (View topic image gallery).


You're currently viewing posts by Pinsider arcade.
Click here to go back to viewing the entire thread.

#1 7 years ago

My Addams Family has taken a turn for the worst as of last night. It started off on power up saying coin door open. Now on power up it just says check fuses 114 and 115. However both fuses are fine. All the lights are working and the bookcase turns but I am unable to start a game or even use the menu and volume buttons.
Anyone had this happen or know what may be wrong?

#6 7 years ago

Awesome. Thanks for the replies

#7 7 years ago

I get a reading of 10 volts on both the TP 3 and on pin 10 of the U20 chip.
Not sure if my 12 volt is faulty or if U20 has been shorted out.

#9 7 years ago
Quoted from Spudgunman:

10v on your your TP3 isn't good, your ground good?

Pretty sure ground is good, but I will check tomorrow.
My 5 volts is spot on.
12 volts reads 10 volts.
18 volts reads 20 volts.

So I am 2 volts under on one and 2 volts over on another.

#14 7 years ago

Anyone have a good source for the 20 pin ULN2803?

I found a 18 pin ULN2803A at Marco but not the 20 pin.

I'm sure I can order it from Ralphs electronics here in town, but if I can throw one in with a pinball order, then all the better.

Sure would be nice if it was a plug and play socket chip. Not a big fan of soldering those things. But I had to do it on my Twilight Zone before.

#16 7 years ago
Quoted from coz6:

Count your pins again. I think its the one listed on Marco. I got my part via them and its the same one. The A is just the way it was sold in what type of batch. The good news is they did wake up and start socketing this chip the bad news is not on your game.

Awesome. I will double check. I just went by the pinwiki that said to check voltage on the far left pin 10. Which would make it a 20 pin chip.
I will double check the count when I get home, but I bet it is the 18 pin.

#18 7 years ago

I was not aware you could put a socket on the main board. That is a great addition and I will certainly do that.
Mine has to be an age problem. I was not even playing the game when it happened.
I just turned it on to show somebody what it looked like and while I was talking to them a message came up telling me the coin door was open. since it was not open I decided to power off the game. When I powered it back up again it had the check Fuses 114 and 115 message.
I feel certain it is the U20 chip.

#20 7 years ago

All fuses are fine.
None were blown when the message came up.
But I have plenty of fuses on hand as I run an arcade.
Thanks again for all the tips.

#22 7 years ago
Quoted from ChrisHibler:

Before you fire up the iron, try this.
Remove J210 from the MPU then power up.
Measure for 12V now at TP3 on the power/driver board.
What does it measure?
Chris Hibler - CARGPB #31
http://www.PinWiki.com - The new place for pinball repair info

Happy to.
Probably can't get to it till after work.

#23 7 years ago

Stopped home for lunch.
With j210 unplugged I get 3.45 volt at T3

#25 7 years ago

I will have that done around 5:00
Really appreciate the help.

#26 7 years ago

With J 114 disconnected I get 7.45 volts on TP3 and 17.43 volts on the 12 volt unregulated.
The capacitor is in great shape with no leaking.

#28 7 years ago

It has been nice working with you Sargent. lol.
I can't get to the machine till after work tomorrow.
But that sounds easy enough.
I'll report back as soon as I have some intel.

#29 7 years ago

Alright, here is the latest information on my power board problem.

First of all I thought that TP1 was the unregulated 12volt you wanted me to measure, not TP8.

So the reading from TP8 was 21.6 Volts.
The reading at D1 was 20.2 Volts
The reading at D2 was 20.1 volts
The reading at 7812 was 11.97 volts

So I guess the guilty party is C2
It has been a long time since I had to measure capacitance and since I have to remove the entire board to do that I thought I would post a photo of my meter (a Meterman 15XP) in the hopes you could tell me what setting I should use if any.
Thanks for all the help so far.


#32 7 years ago

Thanks. I have lots of soldering experience and have replaced caps before. It should not be a problem and my local electronics store should have one in stock.
I really appreciate the step by step help.

#34 7 years ago

Picked up the cap this afternoon. Only .98 cents.
I'll post back if it fixes the problem or not.

#35 7 years ago

Houston, we have a problem.
The new capacitor is in place properly.
When I turn on the game, I get the same error message.
"Check Fuses F114 and F115"
The fuses have never blown throughout the whole ordeal.

So, Are we back to the U20 chip on the MPU board?

#37 7 years ago

Here are the readings as of now with J114, 116,117 and 118 unplugged.

TP3 = 1.08
TP8 = 22.0
D1 = 21.5
D2 = 20.8
7812 = 11.98

#38 7 years ago

Bump for any ideas from Chris.

#40 7 years ago

Here is a picture I took after removing the old cap. I took a photo during the replacement process just in case.
I will have the F115 results soon.


#41 7 years ago

Ok. Here are the numbers

left side of the fuse holder is .005
Right side is 8.7 (However it was a slow climb from 4.5 to 8.7)

Now that have taken a new photo of the new capacitor with the flash on, I can see where looks like it has leaked out on the upper pin.
I was very careful to make sure it went on the same way the old cap came off, the gray stripe is facing the same way the old cap did. It is a little bit smaller then the original but had the same specs.
Here is the photo that shows the leaking. I think.

IMG_0976small.jpg IMG_0977small.jpg

Old cap on the right and the new package they sold me from the specs sheet.

#43 7 years ago

I can email the large pics if u need.
The larger file size shows a lot more detail.

And sorry to ask, but how do I measure resistance?
I am guessing the omega symbol on my meter.

#46 7 years ago

The cap came in a pack of two so no problem there.
I get continuity to the fuse.
I tried resistance and only got a 17 to show up. However I had no idea how to set the meter properly so not sure that is any help.
I will try and read up on how to repair the traces as I feel that must be the problem

#48 7 years ago

Starting to think this may be over my ability to solve.
The new cap did not leak, but I figured the traces were bad so I removed it anyway.
I cleaned with isopropyl, then lightly scraped off the traces to bridge.
After putting in the newer capacitor, it checked all leads for continuity further up the traces.
It beeped every time. Great, I thought. It will surely work this time.
However when I fire up the game I get the same error message.
"Check fuses F114 and F115."

I guess if you are out of ideas for me to try, I can mail you the board as you suggested earlier.
I am willing to keep trying things.

#50 7 years ago

Yes. lol
I have tried that at least a dozen times.

Any clues with the way this occured maybe?
I turned on the machine, not to play it, but just to show somebody the lights.
While we were standing there talking, a message came up on the screen saying the coin door was open.
I opened and closed the coin door but nothing happened.
So I powered down the machine, then the check fuses message came up upon power up and has never gone away.

#52 7 years ago

Just don't laugh too hard at my messy attempt to fix the solder pad problem.
The first cap was soldered in nice and neat. This one, not so much. lol.

#54 7 years ago

I can swap the boards and see what happens.

As for measuring resistance.
I kind of need to be led through the correct process.
I'm not completely sure where to set my meter and what color leads go to what.
I hate just blindly touching things and hoping for a good outcome.
I have a photo of my meter up above.
There are two settings with the omega symbol.
One with just the symbol and one with a 2000m above the symbol. Which is correct?
Also do I need to press the range button to get a correct reading?
Just too many variables for me to guess correctly.

#57 7 years ago
Quoted from Shoot_Again:

I was looking over this and reading to get a better understanding of this trouble shooting procedure.
First off thank you Chris for the good info.
I noticed on page 1 picture number 2 that the center leg of transistor Q2 does not look to be well soldered and it is in direct line with the capacitor in question? Could this be causing some weird readings? Just something I noticed and wanted to bring to everyone who is helpings attention.
Thanks so far for the good read

Good catch.
At one point I noticed the same thing. I meant to try and fix it but got so busy with the cap that I forgot.
The bottom of the board looks great for the transistor. But on the top of the board there does seem to be a good hole where the middle leg goes.

#58 7 years ago
Quoted from ChrisHibler:

Put your meter on the omega symbol, which is ohms.
Try measuring a known value resistor to ensure you get the correct reading. Then measure the resistance we discussed.
Chris Hibler - CARGPB #31
http://www.PinWiki.com - The Place to go for Pinball Repair Info

I will try again.
The first time I set it the just the omega symbol I could not get a reading other than 0.
I got the 17 when I set it on the 2000m setting.
I will compare it to my Twilight Zone.

#60 7 years ago

I will get to it tomorrow.
Will report back with the results.

#61 7 years ago

OK Chris give me an address before I make this board unrepairable.
Trying to get my fat soldering iron in that tiny space is not a good recipe.
If I keep trying this we may just end up with a giant hole though the entire thing, or my sanity will be totally gone.
The whole area is just getting too messy and I don't want to short something out.
I have hit a wall and I admit defeat.

#64 7 years ago
Quoted from ChrisHibler:

All better now Arcade (Leon).
Root cause was a severed trace connecting the 7812 voltage regulator with the C2 filter cap. Board tests 100% good in my TZ.
Tish and Gomez will be yakking it up again on Monday.
Chris Hibler - CARGPB #31
http://www.PinWiki.com - The Place to go for Pinball Repair Info

Awesome. I knew I had to be close. But that area was just to tight to work in with the equipment I have.
PM me anything I owe you and the shipping charges.
Thanks a million for taking the time to work with me on this crazy problem.

1 year later
#65 6 years ago

Just to continue the F114 and f115 problem, my friend with a Fish Tales calls me yesterday to say he has the dreaded message. Knowing I can now track this down pretty quickly I drove over and removed his board and brought it home.
It did not take me very long to find the problem. Lol


#67 6 years ago
Quoted from RDM:

Someone appears to have taken a band saw to that.

It does indeed. I have never seen this happen before. But it should save me a lot of time testing components.

#72 6 years ago
Quoted from schudel5:

Holy thread resurrection, Batman!

Sorry. I hate starting new threads for the same topic.
This Fish Tales board did that on its own. No outside source.
Just decided to crack.

#74 6 years ago

Yes, I have access to Clays guide.
Read it from end to end when I was fixing my Addams Family board.
But I don't think I will need it for this Fish Tales board.

He may as well just put the guide back up.
There are so many copies printed and stored on private servers now that it is crazy to try and worry about it.

2 months later
#76 6 years ago

Wow. That capacitor really leaked. Sorry to see that. But at least you know exactly what is broken.
I'm sure someone will pop in here that knows more then me, but I can't imagine that small part of that trace going bad in just that one small section, but there is always a tiny chance.
I have heard of some people using isopropyl alcohol, but I would wait and hear from the experts.

#78 6 years ago

That should not be a problem.
Just make sure to put it in the same direction the other one came out.
Neg to neg and positive to positive. But I'm sure you already know that.

#80 6 years ago

Yes. That is the capacitor.
It has two wire leads the go through the holes in the board.
And yes that film you see is where it leaked on the board.

Promoted items from the Pinside Marketplace
From: $ 19.50

You're currently viewing posts by Pinsider arcade.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside