(Topic ID: 184239)

AC/DC Odd Flipper Issue


By blowback1976

2 years ago



Topic Stats

  • 9 posts
  • 5 Pinsiders participating
  • Latest reply 2 years ago by blowback1976
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Currently have an odd issue with my right flippers on AC/DC. Every once and awhile the flipper itself will twitch/flutter for a few seconds and go back to normal. The game itself is loaded with mods, that are on the 12v line, and I'm curious if this would be the issue. I do have a splitter on the way to see if anything changes, but if not, would I be looking at a bad transistor? And this also affects the lower one, when the game switches to hell.

Any help would be appreciated.

#2 2 years ago

Maybe check the cabinet switch. sounds like it maybe dirty or out of adjustment.

#3 2 years ago

had the same problem when i installed a mod on my star trek.
installed a splitter board and the problem went away.

disconnect one mod at the time and see if the problem go away.

#4 2 years ago

I havr the same issue with the ac dc luci. I only had the shaker motor...

Looks like it happen when the ball touch the bumpers.

#5 2 years ago

My Avatar does the exact same thing if I have the speaker lights turned on. I know for sure what the issue is, just not sure how to fix it other than turning the speaker lights off...

#6 2 years ago

Good stuff here. I do have an extra set of cabinet switches coming in as well. So, I guess I'll wait and see if the splitter works. In the mean time, I'll slowly unplug the mods one by one and see if that has any affect.

1 week later
#7 2 years ago

Just an update. There's too many mods plugged in. Unplugged the speaker lights and under cabinet lighting, and the issue has gone away. Splitter came in yesterday, so hoping to try that in the week and see if that helps.

#8 2 years ago
Quoted from blowback1976:

Just an update. There's too many mods plugged in. Unplugged the speaker lights and under cabinet lighting, and the issue has gone away. Splitter came in yesterday, so hoping to try that in the week and see if that helps.

knew it, if you still have the same problem with the board installed connect the under cabinet lighting kit to a power supply and in the wall.

1 week later
#9 2 years ago

Splitter helped this. No more twitching.

Promoted items from the Pinside Marketplace
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
$ 125.00
Cabinet - Toppers
Sparky Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside