Pinball-Browser : Customize your game !

(Topic ID: 50742)

Pinball-Browser : Customize your game !


By oga83

5 years ago



Topic Stats

  • 3,059 posts
  • 497 Pinsiders participating
  • Latest reply 20 hours ago by pekilica
  • Topic is favorited by 635 Pinsiders
  • Topic is sticky in its sub-forum

You

Linked Games

Topic Gallery

There have been 256 images uploaded to this topic. (View topic image gallery).

bandicam 2019-03-11 23-08-58-222 (resized).jpg
0x91D (resized).PNG
Capture (resized).PNG
0x91Da (resized).PNG
MET sparky splash logo (LED) (resized).jpg
ac-dc 0x6A7.jpg
Pinball Browser Not Showing BIN Files (resized).JPG
show hidden files (resized).JPG
Capture (resized).PNG
Capture (resized).PNG
low pass (resized).jpg
original puppy (resized).png
GOT (resized).png
PBv660 (resized).png
pasted_image (resized).png
Error (resized).JPG

Topic index (key posts)

24 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 3059 posts in this topic. You are on page 19 of 62.
#901 5 years ago
Quoted from oga83:

Have a look at this :
- Breakout Game
- Program modification

We want to add a MB to TRON just like a different version has.

#902 5 years ago

here's my Tron songs.

#903 5 years ago
Quoted from marlboroa:

here's my Tron songs.
» YouTube video

do you have the numbers for the song files you replaced in the rom? Thanks!

#904 5 years ago

Just tried the magic of a song change on ACDC, and did a test first before loading. Came up with a "fail to upgrade due to error 8".

Any ideas why?

Thanks

#905 5 years ago
Quoted from dendoc:

Just tried the magic of a song change on ACDC, and did a test first before loading. Came up with a "fail to upgrade due to error 8".
Any ideas why?
Thanks

That is normal and really a good thing. It prevents the update from resetting all of your high scores and game settings. If you added a song it should be there.

#906 5 years ago

Really? Cool. I'll try and go ahead with the update and ignore the initial "test image" stage then.

-1
#907 5 years ago

no luck, still error 8.

will fiddle a bit more

#908 5 years ago
Quoted from dendoc:

no luck, still error 8.
will fiddle a bit more

There is nothing to fiddle with....the error always pops up. It is expected. If you changed a song with pinball browser and uploaded that modified software to your game all the way until it gave the error...you are done. The new song you added is there.

Don't do the test or it wont go through to the update...just update it, you will get the error, but the modified code is on there.

#909 5 years ago

You are so right. That is ridiculously easy, and work! I did sub the wrong song somehow, bull will experiment with more now.

Thanks

#910 5 years ago

Is version v3.01 now working well for FG, POTC, WOF, WPT ?
Thanks in advance

#911 5 years ago
Quoted from oga83:

Is version v3.01 now working well for FG, POTC, WOF, WPT ?
Thanks in advance

I don't see a link for 3.01. It still looks like 3.00 is the current linked version.

#912 5 years ago

anybody dig through metallica code to see if there were any cool animations not in there yet or Star Trek for that matter?

#913 5 years ago
Quoted from musketd:

anybody dig through metallica code to see if there were any cool animations not in there yet or Star Trek for that matter?

I've dug through the 1.3 Pro code. There is no Khan controlling the Vengeance like we're seeing in the 1.3 LE/Premium code, so they definitely have slipped some extra changes in the LE code that I assume we'll see on the Pro in the next release....along with other stuff no doubt!

#914 5 years ago

Just FYI: I changed a song on my Tron pro (1.74) and didn't get an error (all highscores and settings lost).

#915 5 years ago
Quoted from DugFreez:

I don't see a link for 3.01. It still looks like 3.00 is the current linked version.

Yes, 3.00
3.01 soon

#916 5 years ago
Quoted from NOB:

Just FYI: I changed a song on my Tron pro (1.74) and didn't get an error (all highscores and settings lost).

This seems impossible. The change of any data breaks the crc on the image. There will always be an error after flashing as the crc won't validate. You sure you even programmed the right fw?

#917 5 years ago

I can verify what NOB says. I installed a patched image that had a song change and did not receive an error and lost my high scores as well.

#918 5 years ago

I always got the error but sometimes it would save the scores and sometimes it wouldnt. My highest on Tron was 178 million.

1 week later
#919 5 years ago

Wanted to try out this awesome tool. Downloaded V3.00 and put facebook.dll and pinballbrowser.exe in same directory. Starts up fine, can search for text and replace. However, sound is a totally different story

If I select a sound (for instance request 308) and push play I hear nothing. If I click again than often the program just freezes for some time and does nothing. When it works again I can push Stop. I assume that during this waiting time? it extracts the song from the binfile?

Using W7 and ACDCLE 1.65 bin.

What am I doing wrong?? And yes, I checked if my sound on PC was really working with other programs

Thanks for any help

#920 5 years ago
Quoted from Rensh:

Wanted to try out this awesome tool. Downloaded V3.00 and put facebook.dll and pinballbrowser.exe in same directory. Starts up fine, can search for text and replace. However, sound is a totally different story
If I select a sound (for instance request 308) and push play I hear nothing. If I click again than often the program just freezes for some time and does nothing. When it works again I can push Stop. I assume that during this waiting time? it extracts the song from the binfile?
Using W7 and ACDCLE 1.65 bin.
What am I doing wrong?? And yes, I checked if my sound on PC was really working with other programs
Thanks for any help

I am using Windows 7 also and trying the same version of Pinball Browser, the same ROM and the same request...I have no problems (T.N.T. plays fine).

What you suggested about the program extracting the song...that wouldn't be happening as you need to press the Export button to do that.

#921 5 years ago
Quoted from Rensh:

Wanted to try out this awesome tool. Downloaded V3.00 and put facebook.dll and pinballbrowser.exe in same directory. Starts up fine, can search for text and replace. However, sound is a totally different story
If I select a sound (for instance request 308) and push play I hear nothing. If I click again than often the program just freezes for some time and does nothing. When it works again I can push Stop. I assume that during this waiting time? it extracts the song from the binfile?
Using W7 and ACDCLE 1.65 bin.
What am I doing wrong?? And yes, I checked if my sound on PC was really working with other programs
Thanks for any help

Try to export and play the file with your default media player (double click on the exported file).
If the sound does not play, you probably have a codec issue on your pc (we'll try to fix it if it's confirmed).

The delay you are talking about is related to sound decompression. It's only noticeable on large sounds.

Quoted from DugFreez:

I am using Windows 7 also and trying the same version of Pinball Browser, the same ROM and the same request...I have no problems (T.N.T. plays fine).
What you suggested about the program extracting the song...that wouldn't be happening as you need to press the Export button to do that.

Thanks Dug for the test. I can't do it until next week...

#922 5 years ago

New ST/STLE code 1.40 seems to use more space for dmd bitmaps? I noticed that star trek font letters are not shown anymore in browser 3.0. In code 1.30 it was browsable at the end of address region, scrolling all the way to the right. Now it's absent and new graphics/animations are shown. Given that this font is used throughout the game for most messages, it must have been put elsewhere.. probably just not visible with the current release of this tremendous tool.. and I will never get tired of thanking oga83 for this great application.

#923 5 years ago
Quoted from astaroth:

I noticed that star trek font letters are not shown anymore in browser 3.0. In code 1.30 it was browsable at the end of address region, scrolling all the way to the right. Now it's absent and new graphics/animations are shown. Given that this font is used throughout the game for most messages, it must have been put elsewhere

Apparently, former font 0x1AD3 (v1.30) was not used and has been removed from the code.
However, a similar font, just a little smaller is at 0x523 in v1.40.
Digits (a little larger) are at 0x1AD3 in v1.40.
The other fonts can also be found around this area.

#924 5 years ago

Id love to get an updated .bin file from someone that has modded Tron LE code with original songs from the movie. Marlboroa did some pretty cool ones for Gem and Light Cycle that i like for the Pro.
Has anyone modded the code for an LE?

#925 5 years ago
Quoted from oga83:

Apparently, former font 0x1AD3 (v1.30) was not used and has been removed from the code.
However, a similar font, just a little smaller is at 0x523 in v1.40.
Digits (a little larger) are at 0x1AD3 in v1.40.
The other fonts can also be found around this area.

Thanks Olivier. I am quite surprised they've given up this font to make space. I'm trying to get someone to confirm this but they seem all busy playing the new code. I can't blame them!
I'll post back as soon as I get any info on this.

#926 5 years ago
Quoted from hassellcastle:

Id love to get an updated .bin file from someone that has modded Tron LE code with original songs from the movie. Marlboroa did some pretty cool ones for Gem and Light Cycle that i like for the Pro.
Has anyone modded the code for an LE?

Its been said many times before. Passing bin files is a sure fire way to get Stern interested doing something about this great tool. Right now they dont care and oga was kind enough to add macros so anyone can pass on the macro and make the changes themselves ( with the necessary audio files on your own computer).

#927 5 years ago
Quoted from oga83:

Try to export and play the file with your default media player (double click on the exported file).
If the sound does not play, you probably have a codec issue on your pc (we'll try to fix it if it's confirmed).
The delay you are talking about is related to sound decompression. It's only noticeable on large sounds.

Thanks Dug for the test. I can't do it until next week...

When I export the soundfile and doubleclik on it it plays fine, only when I push play in the pinballbrowser menu the button switches from play->stop but no sound

When I select the very first sound (which is a very short one) and tick the autoplay box it will go (without sound) to the next one and than the program will no longer respond for at least 30 seconds (where the sound is <1 sec) befor it jumpt to the next one. This all without sound.

Guess I should try it on another computer or any further hints?

#928 5 years ago

Does anyone happen to have an actual "knocker-sounding" sound I can put in place of the amazingly horrifyingly absurdly dissonant and annoying electronic knocker that Stern uses by default, please?

#929 5 years ago

Is the knock sound a sample like anything else?

#930 5 years ago

Hi, this tool is awesome, just for looking through the roms.
I don't own a Stern Yet, but this gives me another plus for getting one.

One question though is there a way to export all the sounds and or images in one go?

MartyB

#931 5 years ago
Quoted from Crash:

Is the knock sound a sample like anything else?

Yes, on most games it is sound request #25
If you want to replace it, the main issue is that it is a very short sample : only 108ms

#932 5 years ago
Quoted from MartyB:

One question though is there a way to export all the sounds and or images in one go?

No, it is not possible with the current version

#933 5 years ago
Quoted from Rensh:

When I export the soundfile and doubleclik on it it plays fine

So, this is not a codec issue

Quoted from Rensh:

only when I push play in the pinballbrowser menu the button switches from play->stop but no sound

It seems that something is not working in your dotnet media player library.
The 3 lines of code I use are just passing the exported file to the media player.
You could try to reinstall wmp (See here) and dotnet (See here).

#934 5 years ago

I just did my METLE with this (I kept getting the error 8 message but as someone above said, that is ok). I am running into a problem though:
I only changed out 2 songs - audibly and the titles. I loaded my new code in and everything worked - the songs and their titles are there.
MY PROBLEM: the voice callouts are super quiet everywhere now?? Any ideas? My Voice setting is at 50 (should be high enough???

Thanks for the help
Kyle

#935 5 years ago
Quoted from hollywood:

I just did my METLE with this (I kept getting the error 8 message but as someone above said, that is ok). I am running into a problem though:
I only changed out 2 songs - audibly and the titles. I loaded my new code in and everything worked - the songs and their titles are there.
MY PROBLEM: the voice callouts are super quiet everywhere now?? Any ideas? My Voice setting is at 50 (should be high enough???
Thanks for the help
Kyle

The problem is you set your voice setting to 50. That's attenuating it 50. -50 would have increased it

#936 5 years ago

Oh ok. Thanks Markmon I'll try that. After the update, the setting was automatically at 50!

Any ideas why my one song doesn't play from the beginning? I understand if the song is shorter than the one being replaced you get dead-time, but what could cause a song to not start from the beginning?

#937 5 years ago
Quoted from hollywood:

Oh ok. Thanks Markmon I'll try that. After the update, the setting was automatically at 50!
Any ideas why my one song doesn't play from the beginning? I understand if the song is shorter than the one being replaced you get dead-time, but what could cause a song to not start from the beginning?

Whatever song you put in with pinball browser will act exactly like the song did that was originally in that spot. If the original song starts 5.23 seconds into the original song clip....the replacement song will start 5.23 seconds into the replacement song clip. Without knowing what game you are talking about, what song you are talking about, where the song was replaced in the ROM and under what circumstance it is playing in the game......it's pretty much impossible to tell.

I see you mention MET LE above. I have added songs to Metallica without issue. The game behaves just as it did with the original songs...except they are different songs. Ex: When you are selecting a song before you plunge the ball. The original songs when selecting do not start from the beginning....so if you replace a song, it will also not start at the beginning. It will start at the exact same time into the song that the original song did. I hope this helps explain.

#938 5 years ago

Thanks DugFreez...makes perfect sense!
I replaced Creeping Death (or Battery - can't remember which) with The Memory Remains. Totally explains everything you said. I appreciate the feedback. I also added Harvester of Sorrow….great track!

Kyle

#939 5 years ago

I gotta say it, this browser is the best thing in the world!! I just changed a bunch of tracks on my STLE and it's even more epic than before!!! I actually didn't really think the music was bad in this game but they obviously tried to make it sound as close to the movie score as possible. I simply replaced the movie score tracks in place of the factory tracks. Easy!!!

#940 5 years ago
Quoted from DugFreez:

Whatever song you put in with pinball browser will act exactly like the song did that was originally in that spot. If the original song starts 5.23 seconds into the original song clip....the replacement song will start 5.23 seconds into the replacement song clip. Without knowing what game you are talking about, what song you are talking about, where the song was replaced in the ROM and under what circumstance it is playing in the game......it's pretty much impossible to tell.
I see you mention MET LE above. I have added songs to Metallica without issue. The game behaves just as it did with the original songs...except they are different songs. Ex: When you are selecting a song before you plunge the ball. The original songs when selecting do not start from the beginning....so if you replace a song, it will also not start at the beginning. It will start at the exact same time into the song that the original song did. I hope this helps explain.

Perhaps you injected it at a point that starts mid song rather than at start? Each song seems to have multiple injection points.

#941 5 years ago
Quoted from oga83:

Apparently, former font 0x1AD3 (v1.30) was not used and has been removed from the code.
However, a similar font, just a little smaller is at 0x523 in v1.40.
Digits (a little larger) are at 0x1AD3 in v1.40.
The other fonts can also be found around this area.

I managed to check if the theme font could have been dropped, but latest STLE Code 1.41 is using it as before. Could this mean it's been moved elsewhere in the code but just not browsable anymore? Funnily enough the standard stern fonts are still "accessible".

image.jpg

#942 5 years ago
Quoted from astaroth:

I managed to check if the theme font could have been dropped, but latest STLE Code 1.41 is using it as before. Could this mean it's been moved elsewhere in the code but just not browsable anymore? Funnily enough the standard stern fonts are still "accessible".
image.jpg 24 KB

Where was it in v1.30 (image #) ?

#943 5 years ago

0x1A72-0x1AA0: Small

STFont_Small_sample.png

0x1AA2-0x1AC6: Medium

STFont_Medium_sample.png

0x1AC8-0x1AEC: Large

STFont_Big_sample.png

#944 5 years ago
Quoted from astaroth:

0x1A72-0x1AA0: Small
0x1AA2-0x1AC6: Medium
0x1AC8-0x1AEC: Large
STFont_Big_sample.png 161 B
STFont_Small_sample.png 144 B
STFont_Medium_sample.png 155 B

Thanks; With this info, I was able to figure out what's going wrong...
It is a stupid limitation I've implemented in Pinball Browser regarding the maximum number of images.
The maximum number is 8092+1 which, afaik, has never been reached in any game... untill ST140 that has 8475 images ! All images id beyond 0x2000 were ignored
That's why this font is not listed (along with a vortex animation and a sword fight animation)
Thank you for being so insightful : I would never have seen that a single font was missing...

[EDIT]v3.02 fixes this

MissingFont.png
Vortex.png
Sword.png

#945 5 years ago

v3.02 has been released
See OP for link and change log

#946 5 years ago
Quoted from oga83:

Thank you for being so insightful : I would never have seen that a single font was missing...
[EDIT]v3.02 fixes this

Glad to be helpful and many thanks for the update!!

#947 5 years ago

I've been following this thread since the start, but have been hesitant to attempt making any changes. With the tutorial video Underspin posted, along with everyone else raving about it, I'm going to give it a shot. VERY impressive work Oga.

#948 5 years ago
Quoted from SunKing:

I've been following this thread since the start, but have been hesitant to attempt making any changes. With the tutorial video Underspin posted, along with everyone else raving about it, I'm going to give it a shot. VERY impressive work Oga.

It seems that I missed this tutorial video and I can't find it. Can you please provide the link ?

#949 5 years ago

3.02 is the first version I have had that Avast has flagged...very aggressively I might add. It throws it to the virus chest automatically.

I was also meaning to ask a couple of releases ago...what's the facebook.dll and where is it supposed to go? Is it needed?

virus warning.jpg
#950 5 years ago
Quoted from DugFreez:

3.02 is the first version I have had that Avast has flagged...very aggressively I might add. It throws it to the virus chest automatically.
I was also meaning to ask a couple of releases ago...what's the facebook.dll and where is it supposed to go? Is it needed?
virus warning.jpg 16 KB

I've seen this and I've submitted a "false positive" report to Avast a few days ago (that's why v3.01 was not published).
Avast was updated earlier today and this issue has disappeared for me.
Try to update Avast and let me know.
[EDIT] My Avast version is 2014.9.0.2011 with a VPS database version 140102-1

facebook.dll is used by the "Remote SmartDmd" feature : See photos at the end of the
SmartDmd post
It should be placed in the same directory than PinballBroser.exe; If you don't use SmartDmd, you don't need it.

Promoted items from the Pinside Marketplace
From: $ 14.95
Playfield - Toys/Add-ons
ULEKstore
$ 16.95
Playfield - Toys/Add-ons
ULEKstore
$ 5,799.00
Pinball Machine
Operation Pinball
7,000 (OBO)
Machine - For Sale
Luling, LA
From: $ 12.00
Playfield - Toys/Add-ons
Meph's Mods
$ 87.00
Playfield - Toys/Add-ons
Lermods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 14.95
Playfield - Toys/Add-ons
ULEKstore
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
5,800 (OBO)
Machine - For Sale
Clearwater, FL
€ 40.00
$ 125.00
Cabinet - Toppers
Sparky Pinball
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 32.00
Playfield - Other
Pin Monk
$ 35.00
Cabinet - Decals
Bright Lights Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 34.95
Playfield - Other
Hookedonpinball.com
From: $ 99.99
5,799
Machine - For Sale
West Chicago, IL
From: $ 99.99
Great pinball charity
Pinball Edu
There are 3059 posts in this topic. You are on page 19 of 62.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside