(Topic ID: 227515)

AC/DC 2 Issues I Can't Figure out


By guitarjunkee

1 year ago



Topic Stats

  • 8 posts
  • 7 Pinsiders participating
  • Latest reply 1 year ago by guitarjunkee
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 1 year ago

I have a couple of issues with my AC/DC and I can't figure out how to fix them. 1. The cannon will sometimes fire by its self when a ball is loaded. 2 the auto shooter looses power during multi ball and won't shoot the balls more then half way up the shooter lane. I thoroughly cleaned all the parts of the cannon and the shooter coil. I replaced the sleeves and checked all solder points. Any help will be greatly appreciated!

#2 1 year ago

The cannon will shoot itself at times if you haven't completed enough shots before hand, say like in the lower play field. Depends on the song playing, and it's objectives on that.
The auto plunger needs adjusted. Mine did that. Take a look at a ball sitting in plunger area and how the kick fork hits it. Mine needed bent together a little bit and works great now.

#3 1 year ago

Mine was just doing that today. It goes about half way forward and shoots. I lifted the play field and pressed all the connections together. The one by the cannon was loose. It seems to fix the issue. I think my shaker makes it loose. Not sure if it will work for no you, but easy to try.

#4 1 year ago

Opto switch, #62 I think, needs to be replaced on the cannon misfire. There is another AC/DC thread with the same issue; it's pretty common and aggravating.

#5 1 year ago

I had seen a post about a light that is shinning under the playfield at the cannon that is causing it to misfire... mine was doing it intermittently.... I move that light and haven’t had a problem since

#6 1 year ago

Shaker motors are cool, but I’m not a fan. Too much trauma to delicate electro-mechanical parts. May not be the issue now, but sometime down the road

#7 1 year ago

For the plunger problem check out this thread...

pinside.com/pinball/forum/topic/acdc-auto-plunger-is-starting-to-get-weak

#8 1 year ago

I adjusted the shooter forks so they evenly touch the ball and it works perfect now. I can see this is something I’m going to have to stay on top of. I checked switch #62 and it seemed to be fine. I cleaned the switch and bent the light under the playfield a bit, and now the cannon is working as it should. Thank you guys for all your help.

Promoted items from the Pinside Marketplace
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 65.00
Lighting - Backbox
Arcade Upkeep
Trade
Machine - For Trade
Berkeley Heights, NJ
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside