(Topic ID: 30712)

3 bank drop target problems

By Choggard

9 years ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 9 years ago by Choggard
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Whirlwind_-_Topper_&_Drop_Targets_(11).jpg

#1 9 years ago

Sorry Newbie to pinball repair so talk slow and detailed. I recently bought a Space Station by williams and noticed that the 3 bank drop targets weren't working. I opened up the game and saw some glue on the opt board where someone tried to fix it before me. I decided to just replace the opt board and ordered a new one. When I got the new one installed the targets worked great and then I heard the coil firing more then usual. As I play the game the coil seems to fire several times in a row and stop. Not sure what's wrong with it. I did notice that the left drop target returns very slow when hit, not sure if that affects anything. Is there a way to clean these? Any help is appreciated .. thanks

#2 9 years ago

Turn your game off, move the drop targets up and down - one feel slow or stiff ?

Yes time to take things apart and clean all the old gunk off.

Make notes or pictures the order you disassemble things so you get it back together right.

LTG : )

#3 9 years ago

yes the left one moves slow when it goes down and it doesn't go down all the way..

#4 9 years ago

Just take it apart and clean it. It's pretty straightforward.

Whirlwind_-_Topper_&_Drop_Targets_(11).jpg

#5 9 years ago

Thanks for the picture, doesn't look to difficult.. I'll try that when I have sometime on my hands.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside