(Topic ID: 252934)

2518-35 LED Locked ON


By JethroP

13 days ago



Topic Stats

  • 24 posts
  • 6 Pinsiders participating
  • Latest reply 10 days ago by JethroP
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

IMG_2374 (resized).JPG
IMG_2372 (resized).JPG
IMG_2373 (resized).JPG

#1 13 days ago

I have a -35 modified for 2-2732 EPROMs for U2 and U6. The board is on the bench with known good U2, U6, U9, and U11 chips. When power up the LED is locked on.

This is a board I repaired two years ago with some corrosion damage. It worked fine until recently. Suspecting the original ROM's were bad I purchased the 2732 EPROMs and modified the board. It still doesn't work. Any troubleshooting repair advice? I have a logic probe and DVM, but limited knowledge of circuits. I can follow instructions

#2 13 days ago

If it was working and just died them I would check the clock circuit chips as they are known to go bad. See is the clock 2 is pulsing at U15 P5 and U15 P11

#3 13 days ago

I am getting pulse at U15 p5 and p11

#5 12 days ago

I'm not the expert, but are you seeing traffic on U9 address and data lines with your logic probe? Also, if you short pin 39 and 40 briefly, does your LED go out. Put your your logic probe on a data line of your choice and short the 39 & 40. Traffic should stop when shorted and then start again when you release the short. You are forcing the processor to reset when you do this. Refer to the schematic for corresponding pins and data lines.

#6 12 days ago

If you are getting your 500 to 600mhz clocks then I would check your VMA/VUA output at U15 Pin3. If the signal isn't there - work your way back through that circuit. It's the section "left" of U10 on the circuit diagram

#7 12 days ago

Not sure I am understanding the questions properly, but I shorted P39 and P40 briefly on U9 and the LED remained on. Also when I shorted those pins the pulse stopped on the data line.

Not sure how to know if I am getting 500 to 600mhz clocks. I don't have an oscilloscope. I did check for pulse at U15 pin 3 and it is there. Now what?

#8 12 days ago

If you are sure you have jumpered 100% for 2732 and that your U9 U6 U11 chips are definitely good - and you have clocks and VMA/VUA - next I would start checking the U6 signals, especially around pins 18 to 22. Follow the signals from U9 to each of those pins to make sure U9 is selecting/chatting with U6.

PS. To get the initial flicker you can take off U2 - don't need it...

#9 11 days ago

I removed U2. Checking U6 with my probe, the green "level" LED is solid on pins 19, 20, 22, 23, and 24. However, on pin 18 there is a slight flutter on the green "level" LED and a noticeable flashing on pin 21. The amber pulse light was solid on all those pins. I'm not sure what all this means because I don't understand the circuity.

#10 11 days ago

I noticed that there is a jumper E2-E6 on my board. The jumper modifications don't show it to be jumpered, but then, it doesn't show it to be cut either. I left it alone. What should it be?

#11 11 days ago

That looks like problem number one. Cut E2 to E6.

The following is a comprehensive list of settings for all 36 jumpers on the board, when using 2732 EPROM chips in locations U2 and U6: ("nc" = not connected)

1 nc, 2 nc, 3 nc, 4-13A, 5 nc, 6 nc, 7-8, 8-7, 9 nc 10-11, 11-10,
12-GND, 13 nc, 13A-4, 14 nc, 15 nc, 16 nc, 16A-29, 17 nc, 18 nc, 19 nc, 20 nc, 21 nc, 22 nc, 23 nc, 24 nc,
24A nc, 25 nc, 26 nc, 27 nc, 28 nc, 29-16A, 30 nc, 31-32, 32-31, 33-35, 34 nc, 35-33, 36 nc

Check every one of them...

#12 11 days ago

I cut E2 to E6. All the rest I checked and they are correct. The LED is still locked on.

#13 11 days ago

Any other help?

#14 11 days ago
Quoted from JethroP:

Checking U6 with my probe, the green "level" LED is solid on pins 19, 20, 22, 23, and 24.

Green level LED is solid on at pin 24 of U6?
Pin 24 of U6 is the power pin. It should have 5 volts on it. The logic probe should indicate the red LED on solid when probing 5 volts.

#15 11 days ago

yes, have 5 volts on pin 24. Logic probe goes solid green. No other lights on my logic probe light up on that pin

#16 11 days ago

Care to post a picture of your logic probe?
Also some clear high res pictures of this MPU board?

#17 11 days ago

Pics

IMG_2372 (resized).JPGIMG_2373 (resized).JPG
#18 11 days ago

Here's a better pic?

IMG_2374 (resized).JPG
#19 11 days ago

Oh your logic probes level LED "ON" means logic high and "OFF" means logic low.

I can't clearly tell but you have E29 jumpered to E16A right? (left area of U6)

#21 11 days ago
Quoted from JethroP:

Checking U6 with my probe, the green "level" LED is solid on pins 19, 20, 22, 23,

Re-check if there's activity on these U6 pins immediately after you reset the CPU (by briefly shorting pin 39 to pin 40 of U9).

I have to head off for the day - maybe someone else will chime in.

#22 10 days ago

might be bad IC sockets. Its hard to see the contact in that type. Sometimes the wiper in the socket snaps off where it bends. Specially on boards with battery damage. The battery corrosive gas can pool in an IC socket and do hidden damage. I have experienced countless non working bally boards come to life after redoing all the IC sockets. A lot of times when you pry off the socket housing there is a surprise of green and blue corroded socket wipe contacts.

Maybe trace continuity from U9 to U6 chip leg to chip leg on all the address and data pins. Then U6 enable(18 and 21) pins back to wherever they come from.

U10 looks rough like the silver plating is coming off the chip legs. Bad U10 shouldnt stop the led from blinking unless two pins on the top row are connected together from the plating flaking off.

#23 10 days ago

Looking at your board in comparison to mine jumpered for 2732's looks different.

This is how mine is jumpered and has worked for years this way, every time.
E4 - E13A
E7 - E8
E31 - E32
E16A - E29
E33 - E35
E9 - E12
E10 - E11

Looking at your images it appears there may be a solder splash in the pads around U3 and U4. You may want to double check for shorted traces.

#24 10 days ago

Thanks to all the help and encouragement to persist. I am now getting 6 flashes on the bench! What I discovered was a jumper on the back of my board that I didn't have on another board I compared it to. The odd thing about this was the board was working before with this jumper in place before I modded it for the 2732 EPROMs. And the jumper connected pin 4 to pin 22 on U8. Not sure why it was there but I removed it and now all appears to be good. Thank you!

I have another board with the LED locked on. It's a little different beast. I'm going to start a new post and hope for help finding its problem. Thanks again for all who offered suggestions here.

Promoted items from the Pinside Marketplace
From: $ 155.00
$ 7.65
Cabinet Parts
Third Coast Pinball
$ 14.50
Electronics
PinballElectronics.com
$ 119.95
Boards
Allteksystems
From: $ 159.95
$ 21.00
€ 3.95
Flipper Parts
Multigame
$ 7.00
Electronics
Third Coast Pinball
$ 16.00
Electronics
Yorktown Parts and Equip
$ 149.95
Boards
Allteksystems
From: $ 140.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside