(Topic ID: 244920)

2518-35 booting problem.

By wugly

2 years ago

Topic Heartbeat

Topic Stats

  • 111 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by Quench
  • Topic is favorited by 4 Pinsiders


Linked Games

Topic Gallery

View topic image gallery

pin 34 (resized).jpg
pin5 (resized).jpg
24 (resized).png
23 (resized).png
20 (resized).png
19 (resized).png
18 (resized).png
22 (resized).png
17 (resized).png
16 (resized).png
15 (resized).png
14 (resized).png
13 (resized).png
12 (resized).png
11 (resized).png

There are 111 posts in this topic. You are on page 3 of 3.
#101 1 year ago

r 11 and cr7 are connected. flipped the legs on q5 when I reported them. and yes I have some n4148 diodes

#102 1 year ago

I've added voltage readings from a machine of mine in the reset section on that diagram in post #47. The voltages are noted in blue.


#103 1 year ago

I have had a long day today and am extremely annoyed. I originally got the readings for voltages before changing the diodes. information to follow. replaced diodes and tested it out with one 5 volt wire in the connector just because I didn't want to keep pulling 2 in and out continuously. tried the next 5 power ons and it booted properly. turned it off and put the other wire in and the thing would not boot at all. removed the second wire and tried to boot it and got one boot out of about 10 tries. I am now frustrated and am leaving it alone for tonight. tommorow I will try adding the cap again to lengthen the delay for stable 5 power. if that doesn't work I will take the new voltage reading but if it doesn't boot for all I know I cooked the new diodes. just to frustrated for tonight to push a bad position

#104 1 year ago

have re installed brand new diodes again and this time the board will not boot with the wires in the connector. will take voltage readings later today and supply them to you.

regarding how it booted before with the wires in the connector. who knows maybe the connection was bad enough to make it work and when I unplugged it, it removed the lucky connection

#105 1 year ago

1. What brand/model EPROM programmer do you have?
2. Do you have any spare 2732 EPROMs?

#106 1 year ago

regarding eproms nec dm2732D. GQ 4x4 programmer. I have a couple spare roms if I want to erase space invaders and seawolf test roms. I tend to discount the roms because when it first stopped booting I restrapped the roms to use the original and it still would not boot. I have tested the resistance after new diodes and there really is no change in resistance, still squirrely.
voltage measurements ad means after diode replacement
tp2 14.59 and 14.59ad q5base 4.81 4.81ad q5 collector 5.38 5.41ad
q1 collector .018 .016ad q1 base .60 .61ad r1r2r3 intersection 3.59 3.58ad
r112 6.4 6.4ad cr5 after band 5.4 5.4ad cr7 after band 4.98 5.07ad cr7 cr5 intersection 5.94 5.99ad

at this moment I do not know where I placed the free play rom files the thumb drive is missing with them on it.

the original roms were 3 factory masked roms

#107 1 year ago

Voltages look ok.
BTW you've mixed the collector and emitter legs on Q5 again The leg in the transistor diagram with the arrow in the circle is always the emitter.

Please download the "ram_clear.zip" binary at the bottom of barakandl's web page:
Erase a 2732 and burn the "memclear_v2_U6.732" file to your 2732
After you've burnt the EPROM, disable blank check in your programmer software and program the chip another two times (don't erase it between programs). Essentially program the chip 3 times with the same data without erasing between programs.

Plug it in U6. Make sure both RAM and the PIA chips are installed (pull U2 ROM out). With the 5V wires in J4 does the board boot with the LED flashing non stop?

#108 1 year ago

just finally got a good burn on the new chip. put it in in u6 only and I got continous flashing

#109 1 year ago

Can you please reburn U2 and U6 with the game code using the same process.

#110 1 year ago

thanks quench so far it seems to be working with all wires and and boards in the head plugged in. I never would have thought that just the resistance of a jumper wire would have been the difference between working and not. the small defect was well disguised. I also would never have caught the power problem unless it was recommended to me to bring the head home from the site the game was at. the minute voltage difference from in the game to my test bench where it worked was driving me crazy. quench you taught me a lot on this last adventure I can't possibly thank you enough. For those reading this the eprom was minutely out of spec and was reacting to less then .2 volt difference. everything I did to fix the problem just made things worse by increasing the voltage with new connectors and rebuilding the regulator.

#111 1 year ago

Great, I hope we can say finally this puzzle is solved!
It looked and smelt like an EPROM problem all along, what threw us was when you reverted back to the factory PROMs and there was still a failure.
Some programmers (I don't know about the GQ 4x4) will also verify at +/- 0.25v on the 5v supply to check if the write was good.

I have a Chinese TL-866 EPROM programmer. It programs 2716 EPROMs and always verifies the write as good. I put those EPROMs into a MPU board and they always fail checksum. If I verify those 2716 EPROMs in a professional programmer, the verification also fails. When I rewrite the 2716 multiple times in my TL-866 then they work properly. So I've seen this before with EPROMs not getting a deep enough charge that makes the data susceptible at certain supply voltages. Infact it was the very first thing I suggested at the start of this thread

Anyhow it was good to see you didn't give up and weren't intimidated with your oscilloscope, we learnt a few things.

There are 111 posts in this topic. You are on page 3 of 3.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside