(Topic ID: 275677)

1968 Williams Ball Park pitch and bat

By FelixTCat

1 year ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by pinballdaveh
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

IMG_20200821_141516 (resized).JPG
IMG_20200821_141421 (resized).JPG

#1 1 year ago

I'm trying to get a Williams Ball Park up and running. When I power it up everything seems fine until I coin up. At that point it gets stuck in a reset cycle until I turn it off. In cycling through the reset the game over relay would keep dropping. I found a pc of cardboard folded and stuck into the Lock coil bracket which seemed out of place. When I removed it I would get the game over and tilt relays dropping after the reset bar cycled. If I put the cardboard back in only the game over relay would drop out. I did find a broken wire on the cabinet bottom slam switch but reconnecting that didn't seem to help.

I'm guessing that the lock relay is bad hence the cardboard to bypass it but any other ideas of where to look ?

IMG_20200821_141421 (resized).JPGIMG_20200821_141516 (resized).JPG
#2 1 year ago

A new lock relay coil is always on the shopping list, along with the schematic and line cord.
Check if the outs unit and the player unit are both resetting and their zero position switches are working correctly. Along with looking for closed stack switches on the players score reels.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside