(Topic ID: 239710)

1967 Jolly Roger - won't start more than 1 player game


By Jakers

3 months ago



Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 78 days ago by Jakers
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

0Jolly-Roger-Work-02 (resized).jpg
0Shangri-La-Replay-Unit09 (resized).jpg
Capture (resized).PNG

#1 3 months ago

I've got a Williams Jolly Roger. Everything works on it except for the game will not start a 2, 3 or 4 player game. No matter how many times I push the start button it only plays a 1 player game. I've got plenty of credits on it. Where would I start to diagnose this problem? I'm fairly new to EM repair.

Also, when I switch on the game, I need to put a coin in for the game to light up and come to life. After this first coin is put in, the game stays on and plays until I unplug it. Is this normal for these older EM pins?

#2 3 months ago

Check the Coin SU unit on p. 18 of the manual: https://www.ipdb.org/files/1314/Williams_1967_Jolly_Roger_Instruction_Manual_no_schematics.pdf

Also, a thing or two here might be applicable:

Capture (resized).PNG
#3 3 months ago

I'll need to see a high quality scan of the schematic from (for example) Staples ($2) or Kinkos ($6)

#4 3 months ago

Hi Jakers
here https://www.ipdb.org/files/1314/Williams_1967_Jolly_Roger_Instruction_Manual_no_schematics.pdf on page-7 (ori-5) we learn that the Coin-Unit (How-many-Players-want-to-participate-Unit) is located on the Mech. Panel down in the Cabinet. On page-18 (ori-16) we see the Player-Unit - we see the Bakelite Plate and the Wipers. On the other side of the Unit there is a switch or there are switches actuated by a rod mounted on the wheel --- see the first JPG - it is the Replay-Counter in my "Shangri La". When my Unit is stepped up - stepped clockwise: Switch "blue 1" will be opened by rod "blue dot". Much the same the Player-Units work --- look out for a switch that opens when You manually step-up the Coin-Unit (please unplug the main power cord when manually stepping - Safety Reasons). See the second JPG - "encircled red" switch --- this switch must be closed when You have started a new game (its a ONE-Player-Game). Greetings Rolf

0Shangri-La-Replay-Unit09 (resized).jpg0Jolly-Roger-Work-02 (resized).jpg
#5 3 months ago

Thanks for these tips. I think I've isolated the problem to a gummed up Coin Unit Stepper. I tried moving it by hand to loosen it up but it still doesn't turn freely like the other steppers. Now to figure out how to remove and clean it.

#7 3 months ago

i would check the player unit since it is probably all gummed up.

4 weeks later
#8 78 days ago

Follow up: I cleaned the coin stepper and the player stepper. The game is working great now.

Promoted items from the Pinside Marketplace
$ 279.95
$ 115.00
Boards
Little Shop Of Games
$ 14.95
Playfield - Toys/Add-ons
ULEKstore
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 69.00
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 799.00
Hardware
CPR Playfields
$ 239.00
Cabinet - Toppers
Tilttopper
$ 86.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 25.00
Cabinet - Other
Filament Printing
$ 7,500.00
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 24.95
Cabinet - Shooter Rods
The MOD Couple
$ 87.00
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 5,799.00
Pinball Machine
Music City Pinball
From: $ 18.99
$ 35.00
Cabinet - Decals
Pinball Haus
$ 799.00
Flipper Parts
Mircoplayfields
$ 35.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside