(Topic ID: 72263)

*-*Medieval Madness Owners Club*-*-> The door is open ... c'mon in !!


By Thor-NL

6 years ago



Topic Stats

  • 376 posts
  • 90 Pinsiders participating
  • Latest reply 7 hours ago by pacman11
  • Topic is favorited by 70 Pinsiders

You

Linked Games

Topic Gallery

There have been 110 images uploaded to this topic. (View topic image gallery).

77BFA587-CB04-4DCC-9B23-1686FEECA9E6 (resized).jpeg
08B6AD92-273B-4E06-B2B3-80D6BE2BB85E (resized).jpeg
EEDAC4D6-7462-42D3-98B4-9F46CA5EDFA7 (resized).jpeg
51EEEDCC-5C8D-4829-B671-68853E60340C (resized).jpeg
mmplastic (resized).png
45E2FE29-EEB4-47E1-8C9D-A6B62E543404 (resized).jpeg
50BB45AE-375E-46AB-8CD0-27717E3024DE (resized).jpeg
0492028F-1868-415A-B827-E8ED54838DD6 (resized).jpeg
80F22124-A27B-4FE1-B9F8-B9E99AF1DDB5 (resized).jpeg
IMG_2837_edited.jpg
A19D2307-623C-4639-AB77-24214A5E0C62 (resized).jpeg
MVIMG_20190724_122841 (resized).jpg
IMG_20190724_122830 (resized).jpg
0 (resized).jpg
31C54BD8-0B5E-4FFA-9F3E-B6DEC5570E25 (resized).jpeg
969A74DD-B0CA-45B2-BF84-14ABC36732DA (resized).jpeg

There are 376 posts in this topic. You are on page 5 of 8.
#201 1 year ago
Quoted from Damien:

One of my trolls is not registering hits at all. I took it apart tonight, reassembled, and no change unfortunately.

Then you have a problem elsewhere if your troll is wired right. A new one won't help.

Look at the switch matrix in your manual. A broken wire on the same row or column will kill other switches.

LTG : )

#202 1 year ago
Quoted from LTG:

Then you have a problem elsewhere if your troll is wired right. A new one won't help.
Look at the switch matrix in your manual. A broken wire on the same row or column will kill other switches.
LTG : )

Everything else that is working fine. I took the troll apart last night, and the switch basically fell apart. I reassembled it, but now it's not registering hits at all.

Before I took it apart, it wasn't registering hits from that ball, but I could manually close the switch to register a hit.

I have a feeling it might be the troll that is the issue, so I'm going to take my chances putting the replacement in.

Any tips on how to get the diode onto the lug with the wire (since trying to do the diode after the wire usually just heats up the wire and it drops off).

Should I wrap wire around the lug, and the solder together with diode?

#203 1 year ago
Quoted from Damien:

Before I took it apart, it wasn't registering hits from that ball, but I could manually close the switch to register a hit.

I have a feeling it might be the troll that is the issue,

Not rocket science. A leaf blade switch, when closed together creates a continuous electrical circuit. Put a meter on it and see if it works. If so, then be sure it is wired right. Compare to the other working troll. And check for broken wires inside the wire casing you can't see.

Quoted from Damien:

Any tips on how to get the diode onto the lug with the wire (since trying to do the diode after the wire usually just heats up the wire and it drops off).

Should I wrap wire around the lug, and the solder together with diode?

Diode has long leads. Stick that on first, then bend the lead over the lug a bit, stick the end of the wire in the hole on the lug or wrap around the lug/diode lead. Flow solder on diode lead/wire/lug at the same time.

LTG : )

#204 1 year ago

Replaced the troll with my new one and everything now works perfectly.

Only issue now is I have one troll with lit eyes and the other without. What to do, what to do?

#205 1 year ago
Quoted from Damien:

What to do, what to do?

Cut wires to working one. Or check LEDs in eyes and then wiring to other one. Your choice.

LTG : )

#206 1 year ago

I recall hearing someone say that there was swearing in the original game which was bleeped out in the remake. Is this true?

#207 1 year ago
Quoted from Damien:

I recall hearing someone say that there was swearing in the original game which was bleeped out in the remake. Is this true?

The original had a hacked ROM if you could find it that unbleeped the F word.

Since the remake copied the Williams stuff and not hacks, and doesn't have ROMs, no unbleeped F word.

LTG : )
Disclaimer : The bleeped version is funnier anyway.

#208 1 year ago

I'm looking for a merlin hole protector. Pinbits has shown sold out and has gone silent. If anyone has a lead on one please let me know.

#209 1 year ago
Quoted from MiSC90:

I'm looking for a merlin hole protector. Pinbits has shown sold out and has gone silent. If anyone has a lead on one please let me know.

https://mantispinball.com/product/medieval-madness-protector-set/

LTG : )

#210 1 year ago
Quoted from LTG:

The original had a hacked ROM if you could find it that unbleeped the F word.

Matt's Basement Arcade on pinside carries it, 1.09C rom

#211 1 year ago

LTG,

Thank you. For some reason I never saw that. All ordered and waiting.

#212 1 year ago

Hey everyone. Looking for some help here. My trolls seem to more often not work than work. When I power the machine up and go test, I can hear the 'buzz' of them trying to engage, but they don't raise. When I go inside the cab and jostle them around a bit then go back to test they will then raise and lower. Thoughts? It is almost like they may not be getting enough power? Was also thinking an alignment issue, but given both are not functioning right, I doubt that. Thanks for any insight.

#213 1 year ago
Quoted from captaindorky:

Thanks for any insight.

A couple things to check. Has the troll carriage separated from the collar holding it to the plunger ? Remove the plunger, it is two pieces held together by a roll pin, is the pin sticking out and dragging in the coil sleeve. Is the coil sleeve cracked or broken ?

LTG : )

#214 1 year ago

Thank you so much. Just looking at the whole mechanism more closely made me realize it was an alignment issue because of loose/missing screws causing the coil to be not properly aligned. Tightened it all up and added a couple of missing screws and all appears well in the troll world.

Thank you for directing me towards the obvious. One of these days I'll get it all figured out.

#215 1 year ago

Anyone have an original playfield for sale? Not looking for retro.

Please let me know.

#216 1 year ago

Does anyone have a shaker installed on their MM original?

Curious to know if it reacts like the MMR one? Does it go off during castle explosion? When trolls come out? Catapult launch?

Also, do you have to do any game software updating to run it?

Thanks

#217 1 year ago
Quoted from Damien:

Curious to know if it reacts like the MMR one?

No.

Quoted from Damien:

do you have to do any game software updating to run it?

You'd have to update MM if you want a shaker to work like in MMR. But there isn't an update for MM so you could do this. On MMR, it's in the CGC software, not in the Williams.

LTG : )

#219 1 year ago

Just bought this 1997 Williams original. But I keep losing the balls. Is there supposed to be a part here?

IMG_3603 (resized).JPG
#220 1 year ago
Quoted from lschmidlin:

Is there supposed to be a part here?

https://www.marcospecialties.com/pinball-parts/03-9681.6 A whole moat goes there under the playfield. Not a broken one.

LTG : )

#221 1 year ago
Quoted from lschmidlin:

Just bought this 1997 Williams original. But I keep losing the balls. Is there supposed to be a part here?
[quoted image]

Yup! You're missing the moat.

This is what you need:

http://www.planetarypinball.com/mm5/merchant.mvc?Screen=PROD&Product_Code=PPS-A-21703

If I'm not mistaken, you will need to change the wiring harness, as they're now making these to go with MMR. LTG can confirm this though.

#222 1 year ago
Quoted from LTG:

A whole moat goes there under the playfield. Not a broken one.

And looks like everybody is out of them.

LTG : )

#223 1 year ago
Quoted from lschmidlin:

Just bought this 1997 Williams original. But I keep losing the balls. Is there supposed to be a part here?

Oh come on, you are pulling our legs! And no you shouldn’t fill your cabinet with water to make a real moat !

#224 1 year ago
Quoted from lschmidlin:

Just bought this 1997 Williams original. But I keep losing the balls. Is there supposed to be a part here?
[quoted image]

Bahahahaha!! Assuming you're pulling our legs...

...and if you're not...

BAHAHAHAHAHAHA!!!

#225 1 year ago
Quoted from lschmidlin:

Just bought this 1997 Williams original. But I keep losing the balls. Is there supposed to be a part here?
[quoted image]

Looks like it’s out of pinball fluid, about 40 gallons should do, pour it straight into the moat hole though, don’t want to get any on the playfield ... also, put some green dye in the fluid for a creepy effect!

#226 1 year ago
Quoted from Chosen_S:Looks like it’s out of pinball fluid, about 40 gallons should do, pour it straight into the moat hole though, don’t want to get any on the playfield ... also, put some green dye in the fluid for a creepy effect!

New LED compatible, will help with the flashers

IMG_0288 (resized).JPG
#227 1 year ago

OK, I'll come clean. A buddy was over and we were having beers. I took my moat out earlier in the day to fix a crack (again!) Through all the beer, somehow this became funny. I didn't mean to take advantage of anybody's good nature and I apologize.

The super cool thing is, guys jumped right in to help. Especially Lloyd who is akways there for us. I actually do need a new moat, so I appreciate the links.

The second cool thing is that some of you guys saw through it and cut right back to me with your green fluid jokes. That was awesome.

Again, I apologize and will be sure to not let the beer talk in the future! I love this community and hope you guys can take a little laugh as intended.

Now, got to get all this motor fluid outta my machine.... Again, good one.

#228 1 year ago

And thank you for not down-posting me! I probably deserved it…

1 week later
#229 1 year ago

Does only the right flipper scroll through the F-I-R-E and lane bonus inserts above pop bumpers?

Seems my game only allows me to scroll using the right, and the skill shot can only be done holding the left flipper down, and pressing launch.

I could swear my MMR letstyou do it with either flipper.

And lastly, when I start a multiball madness that includes trolls in it, the game flashes "danger" right as it launches the first ball. Doesn't seem to do this when the multiball is started without trolls.

Any thoughts as to what this might be?

#230 1 year ago
Quoted from lschmidlin:

OK, I'll come clean. A buddy was over and we were having beers. I took my moat out earlier in the day to fix a crack (again!) Through all the beer, somehow this became funny. I didn't mean to take advantage of anybody's good nature and I apologize.
The super cool thing is, guys jumped right in to help. Especially Lloyd who is akways there for us. I actually do need a new moat, so I appreciate the links.
The second cool thing is that some of you guys saw through it and cut right back to me with your green fluid jokes. That was awesome.
Again, I apologize and will be sure to not let the beer talk in the future! I love this community and hope you guys can take a little laugh as intended.
Now, got to get all this motor fluid outta my machine.... Again, good one.

If I could upvote this twice, I’d be guns a blazin!

#231 1 year ago
Quoted from Damien:

Does only the right flipper scroll through the F-I-R-E and lane bonus inserts above pop bumpers?
Seems my game only allows me to scroll using the right, and the skill shot can only be done holding the left flipper down, and pressing launch.
I could swear my MMR letstyou do it with either flipper.
And lastly, when I start a multiball madness that includes trolls in it, the game flashes "danger" right as it launches the first ball. Doesn't seem to do this when the multiball is started without trolls.
Any thoughts as to what this might be?

You should be able to use both flippers, go to switch test, each flipper button should have two switches

#232 1 year ago
Quoted from kdunbar:

You should be able to use both flippers, go to switch test, each flipper button should have two switches

You are absolutely right. The left flipper only triggers one switch in the testing. The right flipper triggers two.

Here's a photo of the flipper on the left side. Anything stand out as unusual from this photo?

Any suggestions on what I should look for to get both switches working on the left side?

IMG_20181224_144245 (resized).jpg
#233 1 year ago
Quoted from Damien:

You are absolutely right. The left flipper only triggers one switch in the testing. The right flipper triggers two.
Here's a photo of the flipper on the left side. Anything stand out as unusual from this photo?
Any suggestions on what I should look for to get both switches working on the left side?
[quoted image]

I would clean optos reset plug and put business card and switch to break beam, and then switch right and left boards to see if problem followed board

#234 1 year ago
Quoted from Damien:

Any suggestions on what I should look for to get both switches working on the left side?

Replace the bad opto.

Tests - Switch Edge - Pass something between each opto one at a time to figure out the bad one.

LTG : )

#235 1 year ago
Quoted from LTG:

Replace the bad opto.
Tests - Switch Edge - Pass something between each opto one at a time to figure out the bad one.
LTG : )

Optos are fine. Figured out that when flipper is pushed, the two plastic legs that open and close the opto, where not coming out enough. I took it out shave it down a bit, and now it clears the opto path.

One problem remaining... The "danger" warning goes off every time I start Multiball Madness. I haven't had a chance to do much process of elimination, but I think it only happens when the multiball is started and troll and catapult are lit.

Seems kinda weird.

Anyone have ant thoughts on this?

#236 1 year ago
Quoted from Damien:

Optos are fine. Figured out that when flipper is pushed, the two plastic legs that open and close the opto, where not coming out enough. I took it out shave it down a bit, and now it clears the opto path.
One problem remaining... The "danger" warning goes off every time I start Multiball Madness. I haven't had a chance to do much process of elimination, but I think it only happens when the multiball is started and troll and catapult are lit.
Seems kinda weird.
Anyone have ant thoughts on this?

Is it a tilt warning?

#237 1 year ago
Quoted from bobukcat:

Is it a tilt warning?

Yup. Flashes "danger" and the sound effect plays.

Only does it once. Seems to somehow be connected to Catapult, and goes off when this is lit when starting a multiball madness.

I took out the tilt Bob, and it still happens

One other strange activity I've noticed is that during Royale Madness, if you hit catapult, you get credited for the hot, and then get credited again when the ball launches out of the catapult.

Anyone have any thoughts on this?

#238 1 year ago

Switch matrix issue. Something is wired incorrectly or a diode is backwards.

#239 1 year ago
Quoted from pintechev:

Switch matrix issue. Something is wired incorrectly or a diode is backwards.

Hmmmm... I replaced one of the trolls with a newer one from the remake, so had to change wiring tonite, and put on a diode.

Could that be related to the catapult?

#240 1 year ago

I'd put it in switch test mode and start hitting switches to make sure only the correct one is registering, start with the troll you replaced then the catapult and tilt Bob and all other switches in those rows and columns.

#241 1 year ago
Quoted from Damien:

Could that be related to the catapult?

Yes. Wire in wrong spot or diode on backwards, or a short to wiring, can make weird switch matrix issues. Your tilt is on the switch matrix.

Compare to the other troll. White wire and black end of diode to a lug, green wire to a lug. Silver band end of a diode to a lug.

LTG : )

#242 1 year ago
Quoted from Damien:

Hmmmm... I replaced one of the trolls with a newer one from the remake, so had to change wiring tonite, and put on a diode.
Could that be related to the catapult?

Yup, follow Lloyd’s post. He’s got it as usual.

#243 1 year ago
Quoted from LTG:

Yes. Wire in wrong spot or diode on backwards, or a short to wiring, can make weird switch matrix issues. Your tilt is on the switch matrix.
Compare to the other troll. White wire and black end of diode to a lug, green wire to a lug. Silver band end of a diode to a lug.
LTG : )

Pretty sure I did it right, but I'll pull it out when I have a chance and check. Right now, enjoying this new MET code

#244 1 year ago
Quoted from Damien:

Pretty sure I did it right,

If problem started right after that repair. I'd start there.

LTG : )

#245 1 year ago
Quoted from LTG:

If problem started right after that repair. I'd start there.
LTG : )

I really don't recall. The troll wasn't registering any hits, so I was more focused on that.

Is there any way to use a DMM to test if a diode is on properly?

I have the game in a part of my room where there ceilings are too low to fully raise the pf, but I'll pull it out when. I have some time (where I'd prefer fixing pinball over playing) and I'll see if I can figure out what is causing this.

The game still plays fine. It's just a bit annoying to keep getting that "danger" warning!

#246 1 year ago
Quoted from Damien:

Is there any way to use a DMM to test if a diode is on properly?

Eyes work better. To get a DMM in there would be more work than looking at the thing and wouldn't say if you got the wires right. Look at the other troll or every stand up target in your game. White wire black end of diode there, green wire there, silver band end of the diode there. Same on every switch except the stripes on the wires may be different colors but the base color of white or green is the same.

LTG : )

#247 1 year ago
Quoted from LTG:

Eyes work better. To get a DMM in there would be more work than looking at the thing and wouldn't say if you got the wires right. Look at the other troll or every stand up target in your game. White wire black end of diode there, green wire there, silver band end of the diode there. Same on every switch except the stripes on the wires may be different colors but the base color of white or green is the same.
LTG : )

What if the diode had a cold solder. Would it have this sort of issue potentially that I'm seeing? I was thinking the multimeter could be used just to confirm that it's connected. Would a simple continuity test tell me this?

And I will definitely use my eyes to check the orientation of these wires.

#248 1 year ago
Quoted from Damien:

What if the diode had a cold solder. Would it have this sort of issue potentially that I'm seeing?

No.

Unplug the troll head switch connector. If problem goes away you screwed something up.

LTG : )

#249 1 year ago

LTG you were right as always!

Seems I put the diode on reverse. Can anything happen by playing it this way, aside from triggering the annoying"danger" on my tilt?

I'm planning to get it there and fix it up, but probably not for another few days.

Still ok to play it though?

#250 1 year ago

No damage on a switch like that - you are good to go.

Promoted items from the Pinside Marketplace
$ 87.00
There are 376 posts in this topic. You are on page 5 of 8.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside