Solar Ride Repair - Untying a Gordian Knot

Solar Ride Repair - Untying a Gordian Knot

By songofsixpence

January 01, 2019


18 days ago

Warning, the following post is rated PG-13.  Reader discretion is advised.

I want to preface this story with mentioning briefly the previous machine I had worked on.  It adds some context that I think is important.

A friend of mine asked me to get his Williams Flash running.  I think for him, it’s a way not only to get a dead machine up and running, but also a way for him to gauge my skill-set.

Flash did have extensive issues, and took a while for me to sort out and repair them.  But even after several hours of desoldering and soldering sockets and repinning connectors, I was still marveling that this machine was, remarkably, in original condition.  

All in all, it took me about a week working 1-3 hours a night.  Flash is now ready for action!

The next project, by contrast, was not in original condition.  Far from it. In fact, working on this machine has brought up memories of a word that I had learned somewhat later in life.

A few years ago I was talking with a friend who was a tech-support contractor for a customer who had Sun servers.  He had to go to the location to “unfuck” an issue with a Sun server.

“Did you say, ‘un-fuck’?” I asked?

Yes.  Apparently, the onsite tech support (gorillas) had used some combination of brute-strength and a prybar to remove the RAM.  I kid you not - I wish I still had the picture. They were either unaware, or unconcerned with the little, plastic tabs that keep the RAM locked in place.  My friend had to unfuck the new problem, which was to disassemble the server, remove the mother board with the mangled RAM bus, then install the new motherboard and reassemble.  Once this was completed, the server was then “unfucked” and he could then complete the original, intended upgrade of installing the new RAM chips.

So in case you were wondering what a Sun Microsystems server and a Gottlieb System 1 had to do with each other, the answer is:  they both have to be unfucked.

The Solar Ride, wasn’t so much a pinball machine, as it was an empty head, a cabinet, and a box of parts.  I assembled the machine on borrowed legs, and took inventory of what we had. The friend who owns this machine had it at another friend’s house.  Presumably, this other friend was trying to work on it, but found himself over his head. There was a vague story about something “smoking” under the playfield.  Also, there had been a power supply board, but that was now misplaced in unknown condition in the friend’s garage. I mentally chalk that up as a lost cause.

The box contains:

  • A NOS bag of 24 pin, single edge connector housings

  • One Ni-Wumpf board - ROM dated 2004

  • Two Solenoid Driver boards

  • A pop bumper frame

Conspicuously absent are:

  • Power supply board

  • Interconnect harness

Also missing is the right slingshot plastic.  The owner hopes it’s rolling around inside the cabinet.  The owner also mentions in passing that he might have another head.  This is an unexpected revelation.

As for this head, the backglass is in pretty awful condition.  Most of the color from the translucent sections is gone, leaving a faded, rough black outline of the girl on a robot horse.  It looks much better with the lights off. Behind the glass, I recognized something unusual.

7-digit displays!  I thought this game was as System 1?  Was there a version that came with 7-digit score displays?  I seemed to recall something about people modifying Black Hole to use 7-digit displays - but that is a system 80.  Upon closer inspection, it seems the displays have had a bit of modding…

The displays aren’t too much of a concern, in that I intend to systematically go through the critical areas first.  Concerned about the “smoking” from inside the cabinet, I lift up the playfield and first check the small transformer. Visually it looks OK.  It’s even fused. More suspect is the right pop bumper coil is missing. Perhaps that was the source of the smoking. More concerning is one of the bridge rectifiers.  The original was removed and was replaced with a new one. However, instead of resoldering the wires directly to the bridge, the wires were soldered to a jumper, which was spade-connected to the new bridge.  Seems like a lot of work, for the end result to have ugly, exposed electrical wires protruding from off the bottom board. I disconnect the output leads and test the bridge. 7.99VAC going in and 45VDC coming out.  What the heck? I do a little research and what I find is cheap multimeters are usually blamed for not accurately measuring true RMS values. But I’m measuring with an old Fluke, and a less-old Radio Shack true RMS meter.  Both say the same thing. I don’t know what’s going on, so I remove and replace. Then I wash my hands. Whoever installed that bridge used about a tablespoon of white, thermal compound.

In retrospect, I don’t know that I should have bothered.  I realized later that this bridge powers the lights. At least the repair looks a bit better.

Next stop - Power supply board.

Back when I was a young lad of 47, I undertook my first rebuild of a System 1 Power supply.  I was eventually successful - but at what cost? In the process, I had murdered two additional Sys1 power supplies, that I had high hopes of fixing.  I could have scrapped them, but instead, I put them in a ziplock bag, and tossed on the shelf. I had a vague idea of what I had done wrong. The -12V voltage regulator that is bolted to the frame / heatsink, has a small, but critical piece of nylon, that separates the metal screw from the regulator’s casing.  There were no fireworks, no magic smoke. Just a failed component and a board that doesn’t output -12VDC

Now that I’m older and wiser, I know that component has to be isolated, and that these can be ordered from China by the gross.  Furthermore I have learned that -12 is somewhat unique in the pinball world to the Gottlieb / Rockwell platform. I suspect the Ni-Wumpf doesn’t use it.

I cobble together a power supply from my ziplock bag of parts, complete except -12.  I plug in the Ni-Wumpf, and it seems to boot without errors. Which is to say, the LED flashes once then goes out.

I plug in the displays one at a time.  Stuff come up on them, but I wouldn’t call them “working”

The Missing Interconnect harness.

Among the parts are a bag of 24-pin housings.  Perfect for the interconnect! I borrow an interconnect harness and compare it pin by pin to build a new one.  It ends up taking about 3 hours. Considering the value of the connectors and the cost of the pins, and that I could have bought one off ebay for $35… This is not worth doing in the future.

Soon after finishing the harness, the owner texts me with an update about the other head.  Looks to be fully populated. He sends a photo. Decent backglass, 6-digit displays, power supply, MPU, SDB, aaaaaaaand… the interconnect harness!

Oh well.  It will be a couple days before I can meet up with the owner and collect that 2nd head.  So I forge ahead with what I have.

A look under side of the playfield and there are a couple things missing.  The right pop bumper coil and the Shoot Again light socket. The wires are fairly well isolated, so I connect everything and power it on.  It seems to work - though I can’t start a game. The test button is working, but the credit button doesn’t.

The Second Head

The other head is in generally better condition.  After short consideration I swap the entire head. Connect it up, and without fanfare, power it up.  Come on after 5 seconds, just fine. Garbled displays on the HSTD. Seems there is no battery on the MPU.  Just like before, I could get into the tests, I can also get it to coin up, but still can’t get the credit button to work.

This is a new experience for me.  

The switch looks fine.  On the other side, the MPU connector looks… dodgy.  Though it doesn’t look old. Someone chopped up one of those 24 pin connectors to create the two connectors for the switches.  They are not ideal, but as long as they are lined up correctly, they should work. I have to think about this.

My knowledge of the switch matrix was always somewhat vague.  Troubleshooting this has given me the chance to solidify my understanding of how it works.

The flippers.be website does a good job explaining the matrix

http://www.flippers.be/basics/101_switch_matrix.html

What is important for me right now is the following:

  • Are the switches broken?  No

  • Are the switches clean, and physically closing?  Yes

  • Are the switch wires broken / cut / chafed ?  No

  • Are the diodes intact?  Hmmmm

On Bally/Williams/Stern/Everyone else, the diodes are soldered directly to the switches.  Gottlieb did it a bit differently, in that bundles of switch wires are run to these little boards with diodes across them.  Not a bad concept, really. With a Fluke multimeter, you can test all the switch diodes in a few seconds. A few seconds if you know what you are doing.  I’m still learning, so my understanding isn’t fully developed.

The diode board for the coin-door switches is on the left side of the bottom board on a System 1.  I look closer. Seems to be some… missing? The solder joints were actually green with corrosion. I took a picture after I cleaned up with a Dremel.  Perhaps the corrosion actually ate through the leads, and the diodes are now mixed in with the other detritus in the bottom of the cabinet? The corrosion didn’t look that bad.  The leads actually looked cut. Oh well. An unimportant mystery at best.

I have scads of 1N4004 diodes, but these aren’t that model.  I do some research and on pinrepair, find that I can use these in a pinch.  When am I ever not in a pinch? But I search, and find that I have some more suitable 1N4148 diodes.  Solder them in, and now my credit button works - Yay!

My glee was somewhat short-lived.  I can start a game, bat the ball around, but very few of the switches are registering.  The switches themselves look fine. I check out the diode boards under the playfield. Several seem to be missing from the right most board.  What is going on? I didn’t find any random diodes rolling around in the bottom of the cabinet, and there isn’t really any corrosion on this board.  Maybe a previous owner pilfered them for another project. I still have plenty of 1N4148 diodes, so I solder them in, and with quite a bit of optimism, power on the game.  

Unfortunately, there is no improvement.  The same switches don’t work. I’ll spare you, the mundane details, of cleaning switches, and checking continuity. All looked good under the playfield.  The switches don’t show up in the testing, or during a game.

I try the Ni-Wumpf.  The hundreds are missing from the displays.  I suspect some hackery involved with trying to get these to work with the 7-digit displays.  It does much to garble the test menu on the Ni-Wumpf. I am eventually able to pick through the tests and see that the same switches are still not registering.  

At this point I had my real AH HA! Moment.  Maybe my brain works a bit differently, but for me, the Ah Ha wasn’t when I figured out the problem and knew how to fix it… that would come later.  My epiphany was figuring out what happened.

And what happened was this:  A previous owner, for reasons I don’t fully understand, decided this machine needed new connectors.  Apparently, the correct connector housings were unavailable, so the owner used what was available. 24 pin connector housings, cut down to the appropriate length.  I suppose new connector pins were also unavailable, so the old pins and wires were teased out of the old connector housings and installed into the new, modified housings.  At some point afterwards, the owner had attempted further troubleshooting on the bad switches by… cutting out the suspected bad diodes…? I have never heard of this troubleshooting method, but whatever works.  Only in this case, it didn’t. Then the owner threw up his hands, said the Hell with it, and sold it as-is. I have no guess how many times it changed hands before being acquired by my friend.

I spent the next couple hours painstakingly tracing each switch wire to each diode on the diode board under the playfield.  Once I had a reasonable sketch, I searched for a schematic to compare it to. The only System 1 manual I have is for Torch, and it is too different to be of help.  I could order a new manual, and I would be here in a few days, but I am on a roll, and want to resolve this now! After some online searching, I find a Pinside thread that has a couple pics of the Solar Ride switch matrix.  I spend several more minutes reconciling what the switches are named in the manual vs. what I have been calling them on my sketch. And then, only after I lined up the non-functional switches, with the column and row, did the light come on for me

Two wires were reversed!

Whoever had done that previous work, and created that janky connector got two of the wires backwards.

I ponder this issue for a while.  The solution was so simple, and I consider myself a reasonably intelligent person.  Yet it took me several hours to derive the answer. How could I have figured it out sooner?  Perhaps someone with more experience would have recognized the symptoms sooner. Perhaps someone else would have spotted the connector wires were out of order.  Maybe someone else might have just looked at that connector hackery and thought, “something’s wrong here.” Ultimately I conclude that, even though I didn’t figure out the problem quickly, I did eventually figure it out, and maybe next time I’ll be able to figure it out sooner.  My own education is something I have to pay for myself.

The rest of the repair goes smoothly.  I have one correct, connector housing, which I build with new pins, and place all the wires in the correct locations.  Fire it up and test, and all the switches are working - Yay! Next was the pop bumper, The coil frame and screws were in a box.  The coil was missing, but the rest of the parts were all accounted for. With the new coil installed, the game was playing 100%. Last thing was the missing slingshot plastic.  Maybe I could have cut out a piece of Lexan, and printed some kind of waterslide decal, which might have somewhat matched. In the end, I got a replacement used plastic off eBay for $25.  The last thing was the battery, which I replaced with a remote AA case and blocking diode.

Epilogue:  This very Solar Ride has been on location for a couple months, with the original, System 1 board.  Looking forward to seeing how well it holds up.

Story photos

missingdiodes1 (resized).jpg
SolarRidewith7DigitDisplays (resized).jpg
endresult (resized).jpg
missingdiodes2 (resized).jpg
bridgewiththermalpaste (resized).jpg


Comments

There are no comments to this article yet.

Add a comment

Wanna make a comment? Click here to sign in or register.